1. asiayeah's Avatar
    I am using BlackBerry Link 1.2.4 and Q10 at 10.2.1.

    Suddenly BlackBerry Link seems to forget I have synced before and asks me to "Set up your new Device". Since then, it got stuck at Synced Media - Loading sync relationships.

    I have tried to re-install BlackBerry Desktop Software as well as security wipe my Q10. But it still got hang there. My other device (passport) is working fine with BlackBerry link though.

    My Q10 flash memory got mounted correctly in Windows as a network drive. I am using a USB cable.

    Anyone has the same issues? Any idea how to solve this?
    12-11-14 12:35 PM
  2. asiayeah's Avatar
    I am using BlackBerry Link 1.2.4 and Q10 at 10.2.1.

    Suddenly BlackBerry Link seems to forget I have synced before and asks me to "Set up your new Device". Since then, it got stuck at Synced Media - Loading sync relationships.

    I have tried to re-install BlackBerry Desktop Software as well as security wipe my Q10. But it still got hang there. My other device (passport) is working fine with BlackBerry link though.

    My Q10 flash memory got mounted correctly in Windows as a network drive. I am using a USB cable.

    Anyone has the same issues? Any idea how to solve this?
    I find out the problem. It's due to a corrupted SD memory card in my Q10 which blocks BlackBerry link from syncing media with any other device.

    Thanks.
    Last edited by asiayeah; 01-07-15 at 07:40 PM.
    12-11-14 07:06 PM
  3. EastCoast17's Avatar
    Link has become completely useless to me. I've updated it, reinstalled it. I can't move any files via USB to my Z10 or Z30. Windows Vista Home Premium was is OS. Everything was working fine until I updated it. Link used to work fine, I have no idea what the problem is. Avast has always been installed, along with Spybot. I don't see any reason why it would have stopped working. It also says establishing sync relationships and always spins and never does anything.

    Thanks all in advance for your assistance.

    Posted by Me.
    12-31-14 08:32 PM
  4. lindaandjon's Avatar
    Me too, Z30. Worked fine then just stopped. No updates though. Tried turning wifi off, restoring PC to prior latest updates for the PC, all to no effect. Scoured the Web and tried every solution, none work. Wasted an afternoon doing this.


    Posted via CB10
    01-08-15 10:51 AM
  5. waool's Avatar
    Hi all,
    I just removed the whatsapp folder inside the photo folder on the phone, and sync worked fine.
    06-24-15 08:41 AM
  6. asiayeah's Avatar
    Hi all,
    I just removed the whatsapp folder inside the photo folder on the phone, and sync worked fine.
    Nice. That's one of the common causes.

    New versions of whatsapp create separate sub folders for each month's photos. It may help avoiding this problem, too.
    06-24-15 09:00 AM
  7. Swishman's Avatar
    It seems to me the primary reason for a failed sync is too many sub folders. In you music folder you want to have only the artist, and then under that the album.

    For one artist I found that I had a single album but it inadvertently ended up being 4 folders deep. When I moved all the songs up to the second "album" folder and deleted the two other folder layers, it synced immediately.
    02-16-18 07:51 AM

Similar Threads

  1. HELP.. with reading Z10 Back-ups?
    By Bowdett in forum BlackBerry Z10
    Replies: 1
    Last Post: 12-26-14, 05:13 PM
  2. Ford's Sync 3 drops Microsoft for QNX
    By sris in forum News & Rumors
    Replies: 40
    Last Post: 12-17-14, 05:13 PM
  3. Replies: 2
    Last Post: 12-12-14, 05:27 AM
  4. BLACKBERRY OUTAGE! Is BlackBerry down in Toronto?
    By byrdbrained in forum General BlackBerry Discussion
    Replies: 17
    Last Post: 12-12-14, 04:15 AM
  5. HELP.. with reading Z10 Back-ups from a PC?
    By Bowdett in forum BlackBerry Z10
    Replies: 1
    Last Post: 12-11-14, 01:45 PM
LINK TO POST COPIED TO CLIPBOARD