1. brosee's Avatar
    Maybe I am looking in the wrong places, but I still can't get my z10 to communicate with BlackBerry Link through usb.
    I have never backed it up, so that worries me.

    I am running windows 8 and have tried almost everything to work through the problem.

    If someone could link me to the proper steps to fix this problem, that would be great.


    Via my Commodore Vic 20
    09-17-13 06:27 PM
  2. Kris Simundson's Avatar
    everything including uninstalling and reinstalling link?
    09-17-13 06:42 PM
  3. Omnitech's Avatar
    There's a brand new version of Link that was just released today (v1.2.0.28), have you tried it?

    There is also a particular error that is common with Windows 8 and Link, which appears to be at least partly something that only Microsoft can fix, here is the knowledgebase article on it:

    KB34554-"DPC WATCHDOG VIOLATION" error is received when connecting the BlackBerry Z10 smartphone to a Windows 8 PC

    Another issue that seems to come up has to do with USB 3.0 ports. If you have any USB 2.0 ports on your machine, I would suggest trying to use those and see if the situation improves.

    Lastly, if you cannot get Link to do a device backup/restore, there is at least one other option in the form of a 3rd-party tool called Sachesi.
    09-17-13 06:47 PM
  4. brosee's Avatar
    Thanks for the reply.

    I have attempted all of the possible solutions mentioned without any luck.

    I will try the new update to BlackBerry Link, and see if that helps.

    If that doesn't work, I will check the 3rd party app you mentioned out.

    Fingers crossed.

    Thanks again.

    Via my Commodore Vic 20
    09-17-13 07:29 PM
  5. Yiannis K's Avatar
    The watchdog BSOD is addressed in windows 8.1.

    Note: windows 8.1 is out for preview and it is not recommended you install 8.1 on your daily work machine. This post is to simply state that a solution will be made available soon. Sit tight!!! (a sad reality with many Microsoft software issues)
    09-23-13 06:53 PM
  6. brosee's Avatar
    Thanks for the tip. I will definitely sit tight.

    Via my Commodore Vic 20
    09-24-13 01:05 AM
  7. brosee's Avatar
    I totally give up on this.....Unbelievable....or is it?
    I have honestly tried every possible solution there is to get BB Link to recognize my z10 with no luck.
    Today i finally updated to windows 8.1. STILL NOTHING.
    Windows 8 is no longer a new OS. Whats the deal, and who do I point the finger at?
    All I want to do is back up my device with software developed by the company who released the phone, on an operating system that is used by millions. Ugggggh...... f@cking frustrating to say the least.

    If someone out there has the magical solution to get this to work, let me know.
    10-18-13 11:20 PM
  8. eddy_berry's Avatar
    10-18-13 11:23 PM
  9. brosee's Avatar
    Trying the repair right now.

    Via my Commodore Vic 20
    10-18-13 11:34 PM
  10. brosee's Avatar
    Still didn't work. Tried usb3 and 2. Still can not communicate with device.

    Via my Commodore Vic 20
    Attached Thumbnails Please help, Windows 8 and Link problems.-img_20130752.jpg  
    10-18-13 11:40 PM
  11. eddy_berry's Avatar
    Wow, you sound as frustrated as I was until I repaired Link. Perhaps a restart is in order. Another thing I do is change the Device Manager settings to load at startup. The way I did it. Restart laptop. Plug in my Q10. Use Q10 to reload Link. Let it do it's thing. Click Repair. It finished. Unplugged device. Restart laptop. Plug device in. Try to keep wifi off in case. Turn it on again once you have a proper USB connection. 8.1 is now working just as well as 7 did for me. Good luck.
    10-18-13 11:52 PM
  12. brosee's Avatar
    Frustrated is an understatement to be honest.
    I have had the z10 since the release and have not been able to make a back up since.

    I will try your suggestion to see if it works. Thanks for the replies
    10-19-13 12:01 AM
  13. eddy_berry's Avatar
    Your welcome. I hope it works. Windows 8 was the issue. Windows 8.1 is the solution.
    10-19-13 12:07 AM
  14. brosee's Avatar
    Still no luck. I have some friends working at BB. I didn't want to bother them with this but I'm going to.
    I have tried everything possible.
    Thanks again for your efforts.
    10-19-13 12:49 AM
  15. Omnitech's Avatar
    I have had the z10 since the release and have not been able to make a back up since.
    There is a 3rd-party tool called Sachesi that will quite possibly work as a way to do a backup if you are having USB connection issues with Link.
    10-20-13 11:35 PM
  16. brosee's Avatar
    I know about the program you suggested. And thanks for that.

    The frustration for me is the simple fact that link and win8.1 is not working still.
    Why should we have to rely on a third party app to do this.

    This needs to get addressed. It has been an issue for many since windows 8 and link was first released.

    Via my Commodore Vic 20
    10-21-13 04:21 PM
  17. eddy_berry's Avatar
    My last possible guess, if you haven't tried it already. Uninstall link completely. Restart. Plug in your device and run the Link installation off the device. Make sure device manager is set to run at startup. Unplug device and restart when complete. Plug it back in when it boots up. I can't think of anything else. I hope you get this going. It sucks to have no way of backing up or syncing your device to your PC. Good luck bud. Keep plugging away.
    10-22-13 08:44 AM
  18. brosee's Avatar
    Yay. Today is a good day.

    Not only is it Halloween, but it is the first day I have been able to successfully back up my Z10 since I first got it.

    I haven't tried since I updated to the official 10.2, so I was excited to see the prompt for "new hardware found" as soon as I plugged it in.

    Thanks goes to all that tried to help. It was very much appreciated.

    Happy Halloween and cheers.

    Via my Commodore Vic 20
    Omnitech likes this.
    10-31-13 05:52 PM

Similar Threads

  1. Remember: saves on phone AND cloud?
    By kelton in forum BlackBerry 10 Apps
    Replies: 12
    Last Post: 12-25-13, 10:11 AM
  2. Link exposes hidden files
    By hennesseystealth in forum BlackBerry Link
    Replies: 10
    Last Post: 09-29-13, 10:32 AM
  3. Differences between Evernote and Remember
    By New_Z10 in forum BlackBerry Z10
    Replies: 22
    Last Post: 09-24-13, 12:16 PM
  4. Instagram and spotify on
    By Q10Nutter in forum BB10 Leaked/Beta OS
    Replies: 7
    Last Post: 09-18-13, 02:48 PM
  5. Are GPU's more important than CPU's in usability and smoothness?
    By jason9900 in forum General BlackBerry Discussion
    Replies: 6
    Last Post: 09-17-13, 06:51 PM