1. muellerto's Avatar
    Yesterday I got a message with the announcement of a software update to 10.2.1.3062 (software version). Normally I do software updates using BB Link.

    This morning I started BB Link and it also recognized the announced software update. I started the update and BB Link told me that components of the desktop software (BB Link) must also be replaced. OK, let's do that. It showed me a dialog with three buttons, Yes, No and Cancel. Yes tries to install something, No and Cancel are the same, the software update is completely stopped. (The dialog is completely superfluous.) But I chose Yes.

    Then I came to a screen with a progress bar and a message telling me I should remove all devices from the PC. Whenever I did this the update was immediately cancelled and I fell back to the main screen where I could start the update again. I learned I have just to ignore this wrong message. But even then the progress bar made never any progress. Instead I also fell back to the main screen after a while. This happened several times, again and again BB Link asked me to install a BB Link update and then it fell back without any further message. Probably something went wrong. And here an unexperienced user could indeed give up.

    But as a hardcore BB Link user I went to the BB website and downloaded a completely new BB Link software. Insteresting: the website says the current version is "BlackBerry Link v1.2.3.56 (Windows OS)" But the downloaded file is named "123_b055_multilanguage.exe", the "b" means "beta". The internal timestamp of this beta is June 25 2014, almost half a year old, now I wonder how old my own installed software has been ... (It was probably much younger!) However, after I had installed this and executed a reboot BB Link was now able to run it's own software update. Great! (Did I get the 1.2.3.56 now? Don't know ...) After BB Link did update himself the second reboot was required. Bahh ... what year do we have, 1995?

    After this BB Link could then indeed finally update my device to 10.2.1.3062. Took me almost an hour.
    11-05-14 03:23 AM
  2. BigBadWulf's Avatar
    IIRC Link has always had a b in its file name. I noticed the disparity between reported version number and actual download/application number. Not sure what that's been about. Unfortunately, while Link defaults to "automatically" obtain updates, I've yet to see it happen.

    Maybe one day we'll have a proper desktop tool, but I recommend not holding your breath.
    11-05-14 07:48 AM
  3. muellerto's Avatar
    OK, perhaps the "b" doesn't mean "beta". But it's interesting that the website says 1.2.3.56 is the most actual software, when I download it I get 1.2.3.55 and then it updates himself to 1.2.3.56. I checked this (you need to take a look into the exe file for this) - the current Link version on my disk is now 1.2.3.56, but the internal date is now June 24 2014, one day older (!) than the installer file of 1.2.3.55. What a creepy mess! How do they manage this internally??? There seems to be noone really responsible for what is going out.
    sum one likes this.
    11-05-14 08:13 AM
  4. BigBadWulf's Avatar
    Yes, sorry....the actual installed version is 56. Shorthanded as BlackBerry has been, it's either gone unnoticed, or simply not worth the time to fix the file name and replace. Personally, I'd rather they focus their efforts making the next one better.
    11-05-14 08:35 AM
  5. daveycrocket's Avatar
    Just to add my experience, yesterday I received the Z30 update as muellerto, I also got the weird issue around link wanting to update components. I had been sitting on updating Link, After doing all muellerto did, I updated link, restarted pc, still got the same message Thought that my phone maybe causing this as it had the update message, so restarted it, this caused it to update itself, this cleared the need for Link to update components. it has done backups and syncing without problems so far. Interestingly it shows Link version as 1.2.3.48 I'm in the UK.
    11-05-14 09:00 AM
  6. Nick Spagnolo's Avatar
    Try plugging your phone via usb and unplugging your router. I know it sounds silly but it worked for my exact same problem! Please let me know if it works for you. It's not in any knowledge base or CB foum

    Z10
    11-17-14 11:48 AM
  7. muellerto's Avatar
    Try plugging your phone via usb and unplugging your router. I know it sounds silly but it worked for my exact same problem! Please let me know if it works for you.
    Interesting idea. But there's not any problem anoymore in my case, it's over now, as I told in my first post. Perhaps next time again
    11-18-14 01:52 AM

Similar Threads

  1. Replies: 1
    Last Post: 12-05-14, 03:07 PM
  2. What is this on my Q10's screen?
    By mccs in forum BlackBerry Q10
    Replies: 7
    Last Post: 11-05-14, 09:26 PM
  3. Replies: 1
    Last Post: 11-05-14, 07:00 PM
  4. Using OEM Charger that came with my Z30
    By qphone in forum BlackBerry Z30
    Replies: 7
    Last Post: 11-05-14, 06:22 PM
  5. How do I put my Micro Sim for my iPhone into the sim slot?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 11-04-14, 08:53 PM
LINK TO POST COPIED TO CLIPBOARD