1. crackberry_geek's Avatar
    Just downloaded latest version of BlackBerry Link on new computer.

    It gives error "Unable to sign in to your BlackBerry ID. Confirm you are connected to the Internet and try again"

    Of course I'm connected... I just used the net to download the freakin software!

    Funny thing is... it never asks for my BlackBerry ID or password... just goes directly to above error message when I click on Sign In.

    Any advice appreciated.

    Thanks

    Posted with Z10 via CB10
    02-27-14 10:55 AM
  2. Elite1's Avatar
    First troubleshooting to try is rebooting everything.

    Disconnect BB from PC. Restart PC.

    Perform a device reset on BB. (NOT the same as a restart.)
    Hold down both your Volume Up & Down keys for about 10-20 seconds. Keep pressing them, ignoring screenshot notification, BB splashscreen, black screen, red LED, and BB splashscreen again. I don't release the Volume keys until I see the blue startup icon.

    After both have started up again, open Link. Wait 5 minutes, then connect BB to PC. Again, give it 5 or even 10 minutes. Link can be sloooooow.

    Anything work better after those reboots?
    Wilbm, John Scholz1 and Anilu7 like this.
    02-27-14 12:35 PM
  3. crackberry_geek's Avatar
    Thanks. I will try those things.

    But I guess it leads me to another question. Shouldn't Link be able to sign in to my BlackBerry ID account without my phone even connected?

    It just seems like a Link issue to me because I can connect with my phone, just not with Link.

    Posted with Z10 via CB10
    02-27-14 12:48 PM
  4. crackberry_geek's Avatar
    So can anyone tell me if BlackBerry Link should be able to connect to BlackBerry ID without phone connected?

    Posted with Z10 via CB10
    02-28-14 05:00 PM
  5. underway99's Avatar
    Yes, Link should be able to login to BBID without the device being connected to the computer.
    03-02-14 07:45 PM
  6. John Scholz1's Avatar
    Yes. Resetting like you suggested instead of restarting was apparently the key.
    03-07-14 03:59 PM
  7. crackberry_geek's Avatar
    Anyone else been able to resolve this problem? It has been acknowledged by BB an issue with no resolution. The following pasted from BB web site:


    "Unable to sign into your BlackBerry ID. Confirm you are connected to the internet and try again" is displayed in BlackBerry Link when the computer has an internet connection

    Article ID: KB35715

    Type: Support Content

    Last Modified: 02-13-2014
    PrintEmail Document Bookmark


    Product(s) Affected:

    BlackBerry Link

    Search the knowledge base:

    Visit BlackBerry Community Support Forums

    Follow us on Twitter @BlackBerryHelp

    Collapse all | Expand all
    Jump to: Environment | Overview | Resolution | Additional Information
    CollapseEnvironment

    BlackBerry Link version 1.2.2.13
    JI 567690

    Back to top

    CollapseOverview

    When attempting to log into BlackBerry ID in BlackBerry Link on a computer that has internet access, the following error is displayed:

    Unable to sign into your BlackBerry ID. Confirm you are connected to the internet and try again

    Back to top

    CollapseResolution
    This is a previously reported issue that is being investigated by our development team. No resolution time frame is currently available.
    03-09-14 12:03 PM
  8. nfld_sapper's Avatar
    It just randomly started to work today....
    04-04-14 06:30 PM
  9. Er1nyes's Avatar
    First troubleshooting to try is rebooting everything.

    Disconnect BB from PC. Restart PC.

    Perform a device reset on BB. (NOT the same as a restart.)
    Hold down both your Volume Up & Down keys for about 10-20 seconds. Keep pressing them, ignoring screenshot notification, BB splashscreen, black screen, red LED, and BB splashscreen again. I don't release the Volume keys until I see the blue startup icon.

    After both have started up again, open Link. Wait 5 minutes, then connect BB to PC. Again, give it 5 or even 10 minutes. Link can be sloooooow.

    Anything work better after those reboots?
    Will this blank my handest and reset it to factory default?

    I don't need Link THAT much if every time it has a hissy fit I have to reload/restart/relaunch/re-everything just to get it to do what it used to do without (too many) issues

    I am just getting so fed up with Link not working first time, out of the box after every single update! It's like the updates kill the program.
    Frankly I'm not surprised the company is in trouble if their desktop software is so flaky
    04-18-14 05:27 AM
  10. ubizmo's Avatar
    I have this same problem. I had it before when I had a Z10, too. Now I have a Q10. Being away from BB for about seven months, I made a point of deleting every trace of previous BB software from my PC: BB device manager, drivers, former version of Link, etc. I ran CCleaner to mop up any dangling registry entries or other digital debris. So when I got the Q10 last week I was, I believe, fresh installing everything.

    Link installed without a problem, but just as the OP reported, it tried to log into my BlackBerry ID without even prompting me for login details. Then of course it reported, "Unable to log into your BlackBerry ID. Confirm you are connected to the Internet and try again." (after taking about a minute trying) I've tried everything I can think of, including the steps suggested earlier in this thread. Nothing has worked yet. I've also tried disabling all virus software on the PC.

    Browsing the BB knowledge base, this has been a known and unsolved problem since at least 2011, with legacy BBOS. I think it has nothing to do with the phones, since it happens whether or not they are connected. In my case, I hadn't yet connected the phone to Link. As soon as I started Link, it tried to connect with BB ID, without my even clicking anything.

    As far as I can tell, this problem only affects Remote File Access--makes it impossible--and OTA updates via Link. I may be mistaken, though. As far as backup is concerned, Link seems to work a lot better than what I remember from last summer. I haven't tried restore yet.
    04-21-14 01:17 PM
  11. Er1nyes's Avatar
    Oddly enough Link has just magically connected to my BBID - I have no idea why - but I'm just glad it's working...I stand by my original comment, flaky as hell!

    Knowledge is power... Posted via CB10
    04-23-14 01:50 PM
  12. ubizmo's Avatar
    Oddly enough Link has just magically connected to my BBID - I have no idea why - but I'm just glad it's working...I stand by my original comment, flaky as hell!

    Knowledge is power... Posted via CB10
    Congrats! I'll try mine again tonight to see if the magic has spread. Or maybe BlackBerry fixed something at the server end. Maybe certain IP addresses were/are being blocked for some strange reason.

    It works fine on my office computer, for what it's worth. So it's not specific to my account.
    04-23-14 02:56 PM
  13. ubizmo's Avatar
    I just thought I'd update this thread to note that the new Link update hasn't fixed the problem for me.
    05-14-14 09:05 AM
  14. Er1nyes's Avatar
    I'm so disappointed that this isn't working for you yet. I can only suggest trying to contact BB directly via twitter ( @BlackBerryHelp ) if you use it - they do answer! It's not a perfect solution but it could help!

    Slainte, Knowledge is power... Posted via CB10
    ubizmo likes this.
    05-14-14 10:33 AM
  15. ubizmo's Avatar
    Oddly, what has changed is this: Even though I can't login to my BB ID on Link on my home machine, my Q10 file manager now shows that computer in its list, but has it as "Offline", even though the computer is up and running.

    This change wasn't from the Link update though. After selling my Z10 last summer, I had uninstalled Link and all BB drivers, etc., from my computer. So when I got the Q10 a few weeks ago, I installed Link etc. from scratch. That's when the "Offline" behavior started.
    05-14-14 10:38 AM
  16. ubizmo's Avatar
    I'm so disappointed that this isn't working for you yet. I can only suggest trying to contact BB directly via twitter ( @BlackBerryHelp ) if you use it - they do answer! It's not a perfect solution but it could help!

    Slainte, Knowledge is power... Posted via CB10
    I've been working with them on this throughout the day, but still no solution. Naturally, the first thing they had me do was uninstall and reinstall Link...again. So I did it. I still get no opportunity to input BB ID details. It goes straight to "connect" then fails.
    05-14-14 09:41 PM
  17. Uzi's Avatar
    Try to un active your anti virus it's working for me

    Posted via CB10
    05-14-14 09:54 PM
  18. ubizmo's Avatar
    Try to un active your anti virus it's working for me

    Posted via CB10
    Yep, we tried that too. No luck. I haven't heard from BBHelp in a while; maybe they're done for the night. Hopefully they'll have some more ideas.
    05-14-14 10:31 PM
  19. Er1nyes's Avatar
    This might be a moot point but have you gone to the BBID site and checked that your new handset is linked to your account? There is also the BBID in the settings menu to see if everything is working ok on that end (only to check because you said in 1 of posts that your work pc was working fine)

    I'm completely at a loss as to why it's not working.

    Slainte, Knowledge is power... Posted via CB10
    05-15-14 04:32 PM
  20. ubizmo's Avatar
    This might be a moot point but have you gone to the BBID site and checked that your new handset is linked to your account? There is also the BBID in the settings menu to see if everything is working ok on that end (only to check because you said in 1 of posts that your work pc was working fine)

    I'm completely at a loss as to why it's not working.

    Slainte, Knowledge is power... Posted via CB10
    Yeah, everything's fine with the BB ID. And remote file access works fine from my office computer, which wouldn't be the case if there were a problem with my ID.

    BlackBerry Help gave up today and suggested I call my carrier and escalate a service ticket to BB Technical Support. I don't have time to do that until next week. Also, since my carrier is T-Mobile US, and I didn't buy the Q10 from them, I don't know how helpful they'll be.

    Although this really has nothing to do with the Q10. I don't need to have the phone connected to sign into my BB ID from Link. Moreover, I had the same problem with my Z10 last year, and was never able to solve it. From the little digging I did in the BB knowledge base, there's no general solution. There are things that can be tried, but some people just never get it working and they don't yet know why.
    05-15-14 09:14 PM
  21. dmouwes's Avatar
    I have this exact problem with the latest version of link. BB help told me the same things, only my carrier doesn't offer that service, so i'm still stuck with a non working link.
    10-27-14 12:36 PM
  22. ubizmo's Avatar
    I have this exact problem with the latest version of link. BB help told me the same things, only my carrier doesn't offer that service, so i'm still stuck with a non working link.
    Link should work, except for Remote File Access, which depends upon BBID login. I use Link for everything else without any problem.
    10-27-14 12:39 PM
  23. Anilu7's Avatar
    Congrats! I'll try mine again tonight to see if the magic has spread. Or maybe BlackBerry fixed something at the server end. Maybe certain IP addresses were/are being blocked for some strange reason.

    It works fine on my office computer, for what it's worth. So it's not specific to my account.
    I've found that if I use an older version of Link - 1.2.3.56 - then it's fine. It was when I upgraded to 1.2.4.23 when downloading Blend that the trouble started. Previously I'd been able to monitor 3 separate devices with different BBIDs without a hitch. Now, same error message as above. I've tried making sure IPv6 is enabled (got that from the support forms at BB), cleaned using CCleaner, turning Norton firewall off during download and install, nothing works. Short of following the other thread on this subject and deleting all C++ and Java + other 'unnecessary' programs, I'm at a loss.

    I'm on Windows 8.1 with a 1-year-old PC, for what it's worth.
    10-27-14 05:48 PM
  24. estery's Avatar
    I need to flash my bbQ5 but ever since am not able to sign in my bb id and I can't create new one all it keep telling me is unable to connect to blackberry server. Please try again (50504)
    07-28-17 03:09 AM
  25. estery's Avatar
    How can you help because the blackberry id is not working
    07-28-17 03:53 AM

Similar Threads

  1. Replies: 40
    Last Post: 03-31-14, 02:28 AM
  2. Z10 bug deleted all SMS & call history plus emails won't open!
    By terrycotant in forum BlackBerry 10 OS
    Replies: 6
    Last Post: 03-10-14, 12:04 PM
  3. Replies: 5
    Last Post: 02-27-14, 11:46 AM
  4. Z30 won't pass data through wifi when conn. to carrier net
    By jasonvan9 in forum BlackBerry Z30
    Replies: 1
    Last Post: 02-27-14, 09:34 AM
  5. Replies: 2
    Last Post: 02-27-14, 08:28 AM
LINK TO POST COPIED TO CLIPBOARD