1. cadoresg's Avatar
    I know I'm not alone. Many have had and are having issues with Link.
    I got a new computer. Installed Link - all seemed fine.

    Attached Z10 - would sync content but won't backup.
    Attached Q10 - told me to charge using phone charger. No sync, no backup.
    Restarted both phones
    no difference with Z10 - sync but no backup
    Q10 will backup but won't sync.

    Not sure what to do.
    Will try reinstall of Link.
    Anyone else have trouble with 2 phones on one computer (windows 8).

    C
    05-04-13 09:52 PM
  2. middbrew's Avatar
    You might try the updated Link. Here's the blog posted regarding it. BlackBerry Link for Mac and Windows updated with bugfixes | CrackBerry.com
    05-09-13 07:06 AM
  3. cadoresg's Avatar
    Figured it out - apparently link doesn't like usb3 or the phones don't like usb3.

    Today I hooked a usb2 hub up to my new windows 8 computer which only has usb3 ports.

    Plugged in the phones and all of the backup issues and other link trouble was gone.

    Maybe this is something that may help others.

    Posted via CB10
    05-23-13 07:00 PM

Similar Threads

  1. Replies: 9
    Last Post: 05-04-13, 11:29 AM
  2. BB10 Gaming - Z10 vs Q10
    By os30 in forum BlackBerry Z10
    Replies: 3
    Last Post: 03-23-13, 01:20 PM
  3. Replies: 14
    Last Post: 02-04-13, 11:11 AM
  4. Q10, Z10 and the Playbook
    By Jeff Kida in forum News & Rumors
    Replies: 1
    Last Post: 01-31-13, 07:43 PM
  5. Blackberry Announces the Z10 and Q10. The first Blackberry 10 Smartphones!
    By Bold_until_Hybrid_Comes in forum General BlackBerry Discussion
    Replies: 1
    Last Post: 01-30-13, 12:11 PM
LINK TO POST COPIED TO CLIPBOARD