1. hugh_jorgan's Avatar
    Hi,
    I did a bit of searching, but couldn't find the answer. I have a Q10 running the latest 10,3.1 software from Rogers. I have a Windows 8 laptop. I connected my Q10 to my computer, and my computer wanted to install BB Blend, and update Link and drivers. The update failed, and now Link is gone. I've tried to download and install link again, but when I run the install, it says a newer version of Link already exists on my computer, and I have to uninstall that version first, but when I look for programs to uninstall, Link isn't there. Any help would be much appreciated.
    02-28-15 11:48 AM
  2. diegonei's Avatar
    Use Control Panel to uninstall ALL BlackBErry software and reboot both devices. Good idea to run CCleaner before the boot too.

    Next, allow your Q10 to install Blend and Link, you should be good from that point on.
    hugh_jorgan likes this.
    02-28-15 11:58 AM
  3. Aju's Avatar
    I also had the same trouble. And I believe I tried the way above person said, but was failed. Atlast how I managed to get it rectifed was by doing system restore. Just restore to the point before u upated Link. Simple..it works for sure!!

    Posted via CB10
    hugh_jorgan likes this.
    02-28-15 12:03 PM
  4. diegonei's Avatar
    Try both, in the order posted.

    The more options the marrier, but the less intrusive first.
    hugh_jorgan likes this.
    02-28-15 12:10 PM
  5. hugh_jorgan's Avatar
    Yep, I tried the first one (without CC Cleaner, because I don't know what that is), and the problem still existed, so I did the system restore, and it fixed things up. I still cant get my Q10 to backup with Link (for months now), so I use Backup Pro. I was hoping updating Link, and the new software would fix the backup issue, but that's a whole other topic. I appreciate the suggestions from you all!
    FireChestApps likes this.
    02-28-15 01:09 PM
  6. diegonei's Avatar
    02-28-15 01:15 PM
  7. Aju's Avatar
    Best way to do now is delete all the BlackBerry link and all BlackBerry apps by urself going to control panel or with CCleaner and download he new by urself and then try. I personally have never backed up with BlackBerry link, but my mind say this can work. And when u connect the phone, never choose install drivers. And If I were u, I would do a fresh install of my phone before I try all these.
    All de luck

    Posted via CB10
    02-28-15 03:48 PM
  8. diegonei's Avatar
    Phone only asks to install drivers if Link isn't installed or is not working. It will never ask to do it if Link is working fine.
    02-28-15 03:57 PM
  9. Aju's Avatar
    Nop...it still asks for installing drivers....it doesnt matter if it is old or new....i even have blend in my pc...but still it asks for what to do....

    Posted via CB10
    02-28-15 04:03 PM
  10. chopachain's Avatar
    Same problem with me. Asks to install drivers and update fails with a error a few times. I restarted the phone with link open, phone connected.
    02-28-15 04:10 PM
  11. J_Caloy's Avatar
    Try going in your C drive, program files and find any BlackBerry folders and delete it.

    Posted via CB10
    02-28-15 04:13 PM
  12. diegonei's Avatar
    Try going in your C drive, program files and find any BlackBerry folders and delete it.

    Posted via CB10
    Don't do that at all. All installations should be done using proper software.

    And read what I said guys: the device only prompts for drivers IF LINK ISN'T WORKING PROPERLY.

    Posted via CB10
    04-14-15 09:19 PM
  13. dbow27's Avatar
    Same issue here, mine says there are still files from the old software that are being used by another program. I have scanned through everything and there is nothing BlackBerry related on my computer. Still get the same error. I used cc cleaner so well that I lost any previous restore points as well. I am stuck

    Posted via CB10
    05-07-15 10:14 PM
  14. rebroker2009's Avatar
    Once, a while back I had to use regedit an old dos editor, worked like a charm. Just look for software once inside, then RIM or research in motion folder, delete all rim then reboot and install it again

    Blackberry Passport running 10.3.2.500
    05-07-15 11:35 PM
  15. dbow27's Avatar
    Thanks rebroker I tried that but still no luck. There is no way there is any other BlackBerry files on the computer with all the cleansing I did. When I go to install it still says some files may have not been removed or being used by another application.

    Posted via CB10
    05-08-15 12:34 AM

Similar Threads

  1. Can 10.3.1 get BlackBerry in front of Windows phone ?
    By themats in forum BlackBerry 10 OS
    Replies: 87
    Last Post: 03-29-15, 06:46 PM
  2. Not as many blackberries on house of cards s3
    By dmateo in forum BlackBerry Classic
    Replies: 18
    Last Post: 03-02-15, 11:06 PM
  3. Replies: 1
    Last Post: 02-28-15, 11:01 AM
  4. How can I delete the BlackBerry ID?
    By Vics111 in forum BlackBerry Z10
    Replies: 1
    Last Post: 02-28-15, 10:09 AM
  5. How do I get my keyboard back on my lockscreen on my BlackBerry Z10?
    By CrackBerry Question in forum Ask a Question
    Replies: 0
    Last Post: 02-28-15, 09:16 AM
LINK TO POST COPIED TO CLIPBOARD