1. Joshua Kingsley's Avatar
    Whenever I try to connect my Z10 to Link I keep getting the message "Your current version of BlackBerry Playbook Tablet OS is not supported by BlackBerry Link. Check for available software updates for your tablet and try again." I have been scouring the web, and BlackBerry support forums for fixes to this issue, and have come up completely empty handed. I have uninstalled and reinstalled Link 2 times now with no luck. There are some people who have asked the same question on BlackBerry's official support forums, and have received completely unprofessional answers. Is there anybody here that has had this issue, and knows of a fix?
    04-27-13 07:57 PM
  2. anon(153966)'s Avatar
    Is your BlackBerry 10 running an official OS for your carrier? Also in BlackBerry World is the correct device listed?
    04-27-13 08:43 PM
  3. Joshua Kingsley's Avatar
    I have the most recent update available from Verizon which is 10.0.9.422. Where in BlackBerry World can I see where my device would be listed?
    04-27-13 10:58 PM
  4. phinphan1's Avatar
    I'm having similar issues with link as you are. It seems that you have gotten at least a step further than I, link doesn't recognize anything I plug in. I have installed it and uninstalled it several times. Now my playbook software doesn't even recognize my playbook. I was reading the 10.1 file transfer article in here I see they posted some screen shots of link and the z10 which shows the z10 having a blackberry link in the settings which I don't have. I looked for it in blackberry world but no luck so maybe that's what they meant by suggesting its in BlackBerry world.

    Posted via CB10
    04-30-13 11:30 AM
  5. Scott2000's Avatar
    Hi I have a Play Book and Z10 and would have preferred both to work on the one set of desktop software.
    I have had a similar problem with the previous Blackberry desktop software opening when connecting the Z10. I just chose to shut it down and manually open Link.
    But I have the problem that in Link, I have set it to synchronise and use ITunes for my music (have young daughters that have paid for a lot of music) but it is not recognising the play lists properly and not transferring the songs across. The Playbook with the previous desktop software works fine, but not the Z10 and Link. I am using it with Windows XP on an older machine as Link and previous desktop version won't work properly with Windows 8 64 bit. sorry, don't load or work at all I should say. Neither does ITunes for that matter, so using the old computer for music and backing up for the time being for all our phones and ipods. But each time I do try and synchronise some music, I do get a Windows error report message. Also when I open Link. I simply click don't send and the software keeps working (winXP in this case)
    One last thing, I have also tried to link my Playbook to the Z10 with the bridge software, which it did, but unlike my work 9800 Torch, there isn't the same remote access to texts, email, browser etc. Is this the same experience of any one else?
    05-01-13 01:01 AM
  6. Scott2000's Avatar
    Hi Everyone,

    I am a Blackberry convert personally and use a 9800 torch for work, bought a cheep playbook 6 months ago and love it (better than Ipad) and recently sold my iphone and replaced it with the Z10. So I have been using the original desktop software fine with the Playbook and easily syncing it with my daughters ITunes music etc. But I have had to keep using it on a older Windows XP computer as both Blackberry Desktop software and ITunes software will not work on my new Windows 8 64 bit computer.

    Enter the Z10 and Link. It too will not work with Windows 8 64bit and if anyone has, please let me know how and hat you did to get it to work. Link I have loaded on both machines and in the process got error messages similar to what you have described here. I deleted and reloaded Link and the same happens. But what I have found is that if I cancel or ignor the error message to Microsoft, it seams to still work ok on my XP machine. But one problem I am having is the syncing with ITunes. Only some of the songs from play lists I tried to copy across did so and each time I got the error message as well.

    Also the Blackberry bridge software to link the Z10 to the Playbook doesn't give the same remote access to emails, texts etc of the 9800 Torch and only a readme file. Any help there would be great as well.

    Cheers guys
    05-01-13 01:20 AM
  7. neil9356's Avatar
    Did you ever find a solution for your Blackberry Link and Z10 problem? I'm having the exact same problem.
    05-08-13 09:04 PM
  8. Scott2000's Avatar
    Hi Neil,
    Yes the latest download of Link seams to have sorted things out with Windows 8. It also managed to do the latest Z10 update and backup everything OK. I gather it was a software gremlin and would sort itself out.
    The latest copy of ITunes down loaded seams to be more stable on the Windows 8 machine.
    But I am having problems still with linking my Z10 to the Playbook. Or should I say deleting the Z10 link and trying to go back and link my work Torch 9800 and the playbook. Still working on that.
    Cheers
    05-19-13 06:32 PM

Similar Threads

  1. Connection error with BlackBerry World on my z10
    By Krabats Cat in forum BlackBerry Z10
    Replies: 12
    Last Post: 04-24-13, 03:44 AM
  2. Issues with BB Link and my iMac
    By uschi002 in forum BlackBerry Link
    Replies: 3
    Last Post: 04-18-13, 09:45 PM
  3. Z10 SW upgrade issues with Blackberry Link
    By distributor1 in forum BlackBerry Z10
    Replies: 0
    Last Post: 03-04-13, 03:02 PM
  4. Hi guys am having a issue with blackberry link with my new z10
    By babyjuan77 in forum BlackBerry 10 OS
    Replies: 4
    Last Post: 02-08-13, 10:15 AM
  5. Wierd issue with Blackberry's and my company's firewall
    By sniffs in forum BlackBerry Administrators
    Replies: 2
    Last Post: 05-07-09, 11:11 AM
LINK TO POST COPIED TO CLIPBOARD