1. BriniaSona's Avatar
    I dont know what it is, or why it's doing this to me, but, blackberry link never connects with my device on any windows computer I connect it to. I am frustrated beyond belief. I was supposed to meet with someone tomorrow but now I cant because the f***ing link wont connect to my device so I can restore data.
    GreenCopperz likes this.
    08-03-13 12:54 AM
  2. Lendo's Avatar
    Is the DM closed before you connect the device?
    08-03-13 12:56 AM
  3. BriniaSona's Avatar
    I have tried it open, closed, resetting both the device and laptop. It works 2% of the time, all the other times to gives me the alert triangle and tell me to reconnect. It knows the device is there, it's just too damn cocky and doesnt want to connect.
    08-03-13 01:00 AM
  4. BriniaSona's Avatar
    Been at this for 5 hours now, NO RESULT. its happened to me at least 6 other times.

    "device driver software was not installed sucessfully.... ect
    Attached Thumbnails Cannot Connect to Link-untitled.png  
    08-03-13 01:21 AM
  5. Chi Cong Nguyen's Avatar
    Been at this for 5 hours now, NO RESULT. its happened to me at least 6 other times.

    "device driver software was not installed sucessfully.... ect
    The same to me, on windows 8 64 bit, BB Device Manager cannot recognize my Z10 via USB cable.
    GreenCopperz likes this.
    08-03-13 10:53 AM
  6. moody's Avatar
    I spent 9+ hours over a 3 day period, with BlackBerry tech level 3, used 3 different computers and exact same problem. Can't install drivers.

    Windows 7 on all 3 computers.

    Still no Link.

    The new 10.2 is available for download now via CB but since I can't backup my phone I'm afraid to try updating my OS.

    Posted using my white Q10 via the very addicting CB10 app
    08-03-13 11:08 AM
  7. Chi Cong Nguyen's Avatar
    Everything happen the same to me.

    I can connect through the Wi-Fi Network but I cannot get the BB Link to connect to my Z10 via a USB cable.

    My laptop OS: Windows 8 pro 64 bit
    My bb link version: 1.1.1.32

    Ago times, fortunately, I can connect my Z10 via usb 3.0 port. But it isn't stable, after a random period of time, my windows was crashed, blue screen of death apeared and my windows must be restarted. That's so annoyed but the most importance is the bb link can recognize my Z10, so I can backup my data.

    But now, that fortune do not happen and I cannot backup my data ,cannot install new bbm channel etc...

    I tried:
    - Uninstall & Install BB link a hundred of times but useless
    - Search "BlackBerry" in registry and delete all of them then try re-install BB link but useless
    - Uninstall & Install BlackBerry Virtual Private Network but useless
    - Uncheck use tcp/ip v6 and enable netBIOS over tcp/ip in tcp/ip v4 (BlackBerry Virtual Private Network Connection Property) but useless

    Please help me solve this problem
    08-04-13 11:04 AM
  8. montberry's Avatar
    same here, my phone (Q10) dose NOT show up in blackberry link when plugged in
    please help........
    08-04-13 03:52 PM
  9. oldguy102's Avatar
    Try Sachesi, worked for me, z10-3,

    Posted via CB10
    08-04-13 05:28 PM
  10. Jurimo's Avatar
    Blackberry Link works on my Mac laptop but won't on my Windows 7 desktop with my BB Z10. It shows my BB Z10 as connected but "cannot communicate with device". I have search for a solution and tried many things. So far, no luck. Any suggestions before I abandon my quest.
    10-02-13 08:30 AM
  11. wazzmd's Avatar
    me too can't connect my z10 via link on windows xp.
    It shows device connected but can't communicate with device
    It sucks..as I tried reinstalling many times, update my system, downloaded iTunes also, but of no use...

    Posted via CB10
    10-10-13 02:38 AM
  12. Hawberry's Avatar
    Anybody got a solution?
    11-01-13 09:59 AM
  13. LJ238a's Avatar
    Hi All

    I am having the EXACT same issue - and I have tried the EXACT same 'attempts' as you all to fix it!

    No idea what to do next

    LJ
    11-10-13 12:43 AM
  14. Hawberry's Avatar
    I just got it to work at last!
    - Uninstalled the old Link, restarted;
    - downloaded and installed the new version of Link
    - plug Z10 in (can not communicate with device)
    - go to control panel , device manager, network adapters, uninstalled Blackberry device, clicked the box 2 to the right of the ? help box (scan for hardware changes), after it checked unplug the device and replug again
    - go to control panel, go to ports (CO and LPT), if you see "blackberry virtual ports, uninstall, close Link
    - unplug and replug the device again and open Link

    That worked for me!
    Don_Henry and Bethany Moore like this.
    11-20-13 05:56 PM
  15. AWDragon200's Avatar
    I found that if I turn off WIFI on my Z10 or put in Airplane Mode on, then everything connects by USB.
    I cannot get WIFI syncing or access my Z10 files by WIFI through my PC however. When I turn off WIFI radio on phone then connect to USB then it works. This is on a an XP and Windows 7 computers.
    11-24-13 11:25 AM
  16. Marko M1's Avatar
    Since I installed update to BB Link, I cannot get WiFi Connection from Z10 to Link. On old version of Link all worked fine, but now it won't. I tried old version of Link, it doesn't work, I uninstalled, rebooted, installed Link countless times, but still problem is same. I followed instructions on Help page to try Logout and Login again from Link, I changed password on my BBID, but nothing helped. Over USB it all works fine, but in most cases I prefer to use WiFi.
    11-26-13 05:39 PM
  17. GreenCopperz's Avatar
    I haven't been able to start, let alone use BlackBerry Link since after the first week. I finally got Sascha (sp??) to work and did a full backup. I can't stand what they did with their desktop software.

    Posted via CB10
    11-26-13 05:42 PM
  18. Coyote55's Avatar
    I have tried all of the suggested solutions with no results. This has been an issue for some time now and I am surprised Blackberry has not addressed this issue. Very, very disappointed. I am having email issues too, which is why I really need to backup my phone from time to time. Perhaps it's time to buy a Windows phone.

    Z30
    Windows: 8.1
    Link: 1.2.3.23

    UPDATE:
    I found the issue had to do with my USB 3 ports. I could get it to work if I connected a USB 2 HUB in between my Z30 and laptop.

    UPDATE 2:
    The issue has been resolved in 10.2.3.
    Last edited by Coyote55; 07-30-15 at 11:43 AM.
    04-17-14 01:28 PM

Similar Threads

  1. How to install 10.2.0.1047....Please help!
    By tvko in forum BlackBerry Z10
    Replies: 17
    Last Post: 08-17-13, 12:46 PM
  2. I'm confused what to expect on the 10.2 OS
    By lTatis in forum BB10 Leaked/Beta OS
    Replies: 3
    Last Post: 08-03-13, 11:51 AM
  3. If you want to remain private, get off the internet.
    By ronniell in forum General BlackBerry Discussion
    Replies: 12
    Last Post: 08-03-13, 07:32 AM
  4. Need apps to load onto my device
    By Dylanmichael603 in forum BB10 Android App Sideloading
    Replies: 8
    Last Post: 08-03-13, 01:23 AM
  5. I'm confused what to expect?
    By lTatis in forum BBRY
    Replies: 2
    Last Post: 08-03-13, 12:31 AM
LINK TO POST COPIED TO CLIPBOARD