1. cr4igora's Avatar
    Couple of issues, I'm wondering if others have suffered these or have a solution?

    Ever since I've upgraded mine and my colleague's BB Z30 phones to release 10.3.1, I get the message "Cannot Communicate with Device" when I plug the phone into a PC and start BlackBerry Link. This is happening with a number of other phones at work that I've upgraded, all on 10.3.1 and all using Windows 7. Uninstalling Link and reinstalling doesn't seem to do the trick and clicking Reconnect only works on some of the PCs that I've had this issue on. It hasn't been an issue in the past and it only seems to have started happening after the upgrades to 10.3.1.

    I also seem to get "USB Connected" options on the phone every time I connect a phone to a PC (see image below) . Is this a new feature to 10.3 and can it be disabled?

    Cannot Communicate with Device-usb-connected.png

    Thanks for any help in advance.
    Icardi101 likes this.
    03-04-15 05:17 AM
  2. jaydee5799's Avatar
    when you uninstalled Link, did you use ccleaner and also reboot afterwards?
    03-04-15 06:32 AM
  3. cr4igora's Avatar
    Link was uninstalled through Programs and Features in the Control Panel and yes, I rebooted afterwards. Should that matter though, am I going to have to uninstall every copy of Link on each user's PC because of the phone OS upgrade?
    03-04-15 08:55 AM
  4. BBJRG's Avatar
    I reloaded my Z10 operating system (turned off phone, removed sim & SD cards first) because of quirkiness with trying to use the phone/camera and navigating using touch screen. BB link was working fine before that.
    Now BB Link will not sync my contacts & calendars) and stops working when I try to configure contacts and calendars. I have tried removing and reinstalling BB Link and nothing tried has worked.
    Any suggestions??
    03-04-15 02:56 PM
  5. cr4igora's Avatar
    My suggestion would be: go and highjack someone else's thread!
    sirk25 likes this.
    03-05-15 02:45 AM
  6. M4KKU's Avatar
    I had the same problem with my blackberry passport, had to update the blackberry blend on the device by going to blackberry world, then the computer was able to communicate with my device.
    03-05-15 10:22 PM
  7. cr4igora's Avatar
    No update available for Blend on my phone
    03-06-15 02:42 AM
  8. cr4igora's Avatar
    Has nobody else had this issue since upgrading to 10.3? Or is this potentially one of the bugs with the update and the reason BlackBerry have pulled deployment of this OS upgrade?
    03-09-15 03:45 AM
  9. ja0401's Avatar
    I have had same problem on my Q10 since 10.3 update. Have deleted link and reinstalled but still same problem. Frustrating.

    Posted via CB10
    03-09-15 03:23 PM
  10. conite's Avatar
    Has nobody else had this issue since upgrading to 10.3? Or is this potentially one of the bugs with the update and the reason BlackBerry have pulled deployment of this OS upgrade?
    You need to install the latest version of BlackBerry Link, which can only be obtained by installing the BlackBerry Blend package.
    www.blackberry.com/blend

    Z30STA100-5/10.3.1.2267
    03-09-15 03:29 PM
  11. cr4igora's Avatar
    The issue is, I don't want to! We've got around 120 people with BlackBerry 10 phones and each one has a computer with an admin password. Why should I go through the rigmarole of reinstalling Link and be forced to install Blend on every single one of those computers because of a bodge upgrade to the phones? If there's an incompatibility issues between the phone with a new OS and the software, then it should require an upgrade to Link....and that's it.
    03-10-15 03:54 AM
  12. conite's Avatar
    The issue is, I don't want to! We've got around 120 people with BlackBerry 10 phones and each one has a computer with an admin password. Why should I go through the rigmarole of reinstalling Link and be forced to install Blend on every single one of those computers because of a bodge upgrade to the phones? If there's an incompatibility issues between the phone with a new OS and the software, then it should require an upgrade to Link....and that's it.
    You won't need to install Blend. Just unselected that. Only install Link and the drivers. Install package presents you with a list.

    Z30STA100-5/10.3.1.2267
    03-10-15 07:41 AM
  13. cr4igora's Avatar
    No joy! I did exactly as you suggested, reinstalled Link (deselecting Blend) and still when I connect my phone, it tells me to install software and the software tells me the device is not connected.

    I have just found out that there will be an OS update pushed out for Z30 phones who upgraded to 10.3, early next week (carrier dependent), so I'm going to wait for that and see if the issue is resolved.
    03-10-15 12:12 PM
  14. conite's Avatar
    No joy! I did exactly as you suggested, reinstalled Link (deselecting Blend) and still when I connect my phone, it tells me to install software and the software tells me the device is not connected.

    I have just found out that there will be an OS update pushed out for Z30 phones who upgraded to 10.3, early next week (carrier dependent), so I'm going to wait for that and see if the issue is resolved.
    I assume you let the drivers install/update with the Blend package too? Not just Link?

    Z30STA100-5/10.3.1.2267
    03-10-15 12:33 PM
  15. cr4igora's Avatar
    Yes, I left Drivers and Link ticked and unticked Blend.
    03-11-15 03:37 AM
  16. DeNEROuno's Avatar
    Hi, pleased did you ever get a solution to this issue? I'm having same issues on my Macbook pro. Thought is was something to do with the computer and installed BB link etc from the device (didn't work) and then directly from the BlackBerry website and still no joy. Even got 2 Windows computers (running windows 7 and 8) and still no joy.

    So please if you've been able to solve the issues with yours, kindly do share.
    10-24-15 02:05 PM

Similar Threads

  1. Replies: 12
    Last Post: 03-06-15, 05:55 PM
  2. Replies: 5
    Last Post: 03-04-15, 12:02 PM
  3. switch device different blackberry id
    By CrackBerry Question in forum Ask a Question
    Replies: 3
    Last Post: 03-04-15, 11:21 AM
  4. charging with non original charger/cable
    By passported in forum BlackBerry Passport
    Replies: 1
    Last Post: 03-04-15, 07:42 AM
  5. Which is the BlackBerry Curve screen with better color accuracy?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 03-04-15, 06:41 AM
LINK TO POST COPIED TO CLIPBOARD