1. mttomas's Avatar
    BlackBerry Link is for me since day one completely useless. I am using a Windows 64bit notebook and it works horrible.
    I updated to the 10.2 OS and playing back my backup is impossible. It always fails, gives no proper reasons for it and is slow as hell.
    I had uninstalled and reinstalled and always updated the newest Link version. But it still sucks, As much as i love my devices. BB Link is for me the best reason to throw the phones and get something else.
    The only thing i need to restore is my password keeper. And there seems no way to get it without BB Link.
    08-05-13 02:18 PM
  2. BigBadWulf's Avatar
    Whike I can't argue with your title , I might be of some help.

    Did you make the backup using the latest available Link, 32? Are you using the latest OS leak, 1047?
    08-05-13 02:31 PM
  3. GreenCopperz's Avatar
    Link used to work and a phone software update and BlackBerry Link update nulled it for me... no windows backup either...
    Link won't even install and rolls back... fix this BlackBerry, or at least allow us to use BlackBerry Protect as per legacy bbos 5+ devices could...

    Posted via CB10
    08-05-13 02:51 PM
  4. mttomas's Avatar
    Yes , i used the latest link, and i have installed the latest leak1047.
    I tried it as well on the notebook of my wife which unfortunately runs as well a 64bit windows and it is the same story...
    08-06-13 06:49 AM
  5. Drew Oswalt's Avatar
    Link was working for me. But I changed up the way I do updates and uninstalled the old version of Link before installing the new one (versus installing over the old version) .

    So now, I cannot install Link and run backups of my Z10. Which means I am not installing 10.2 until the official OTA update. And that makes me a bit unhappy.

    Posted via CB10
    08-23-13 04:37 AM
  6. grumpyaeroguy's Avatar
    I would recommend trying:

    1) Uninstall Link (i mean UNINSTALL it). I have had good look with a tool such as REVO uninstaller. It will search your resgistry and other nooks and crannies in your machine to truly kill it.

    2) If you have an old installtion of DM, do the same as step 1) for the old DM

    3) Re boot

    4) DL the latest Link software from BB. Install

    5) Reboot

    6) Retry connecting.

    I am running Win7x64. I hear too many reports of things like what is described above for it not to be the case, and I believe you are having problems.

    For some reason, I have been having decent luck since I did the above. Initially I had issues as well, but all seems OK now.

    That being said, I agree, Link seems to have MANY opportunities for improvement.
    08-23-13 11:37 AM
  7. Drew Oswalt's Avatar
    Did all registry cleaning and clean removal of DM. No luck. May have to get my old computer out of storage and install on there.....
    GreenCopperz likes this.
    08-23-13 01:36 PM
  8. GreenCopperz's Avatar
    Thinking same, but we shouldn't have to do that... it should simply work...

    Posted via CB10
    08-23-13 03:28 PM
  9. Drew Oswalt's Avatar
    powderbanks found a possible solution posted in the forums on the BB Beta site. It worked for me.

    The error logs seem to be showing something to do with your printer's interaction with Windows which is causing the installation to fail. Try this workaround:

    - Close all running programs on your computer, including Intuit QuickBooks and Point of Sale.
    - Click "Start," "All Programs," "Accessories" and "Run."Type "Services.msc" into the Run dialog and press "Enter.
    - "Click "OK" and "Continue" in the user account control dialog.
    - Scroll down in the list of services, right-click "Print Spooler" and click "Properties.
    - "Click the "Startup Type" box and click "Automatic.
    - "Click the "Start" button under "Service Status."Click "OK."Close the services window.
    - Retry the installation
    - If it still fails, restart and try again.
    Last edited by Drew Oswalt; 08-28-13 at 03:56 AM. Reason: corrected spelling
    08-28-13 03:56 AM
  10. GreenCopperz's Avatar
    Tried this, still didn't work. How and where do we find logs pertaining to the install and it's subsequent roll back?

    Posted via CB10
    08-29-13 08:28 PM

Similar Threads

  1. BlackBerry World updates
    By mokimoki in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 08-05-13, 10:13 PM
  2. Blackberry link/Update issue
    By Purification in forum BlackBerry Q10
    Replies: 2
    Last Post: 08-05-13, 04:49 PM
  3. How to backup contact, calendar,email in Link
    By mhw100 in forum BlackBerry 10 OS
    Replies: 3
    Last Post: 08-05-13, 02:53 PM
  4. Replies: 3
    Last Post: 08-05-13, 02:40 PM
  5. bReader - New RSS feeder for BlackBerry 10!
    By kumilabs in forum App Announcements
    Replies: 1
    Last Post: 08-05-13, 12:49 PM
LINK TO POST COPIED TO CLIPBOARD