09-22-16 03:03 AM
48 12
tools
  1. powderbanks's Avatar
    If you are a beta zone member, go here for a possible solution:

    https://beta.webapps.blackberry.com/...088?pg=1#93351
    Drew Oswalt likes this.
    08-26-13 11:14 PM
  2. Drew Oswalt's Avatar
    OMFG! That tip worked. Link installed. Must spread this around for others having the issue. As a note I did have issues after I disabled SPOOL, obviously did not realize that was the issue.

    I am copying and pasting the solution for people who do not have a beta account. I am not listing the BB mod to make sure I won't get into trouble. I will or someone else can, if it is ok to do so.

    The error logs seem to be showing something to do with your printer's interaction with Windows which is causing the installation to fail. Try this workaround:

    - Close all running programs on your computer, including Intuit QuickBooks and Point of Sale.
    - Click "Start," "All Programs," "Accessories" and "Run."Type "Services.msc" into the Run dialog and press "Enter.
    - "Click "OK" and "Continue" in the user account control dialog.
    - Scroll down in the list of services, right-click "Print Spooler" and click "Properties.
    - "Click the "Startup Type" box and click "Automatic.
    - "Click the "Start" button under "Service Status."Click "OK."Close the services window.
    - Retry the installation
    - If it still fails, restart and try again.


    If you are a beta zone member, go here for a possible solution:

    https://beta.webapps.blackberry.com/...088?pg=1#93351
    08-28-13 02:49 AM
  3. GreenCopperz's Avatar
    Tried this, still didn't work. How and where do we find logs pertaining to the install and it's subsequent roll back?

    Posted via CB10
    08-29-13 07:28 PM
  4. Drew Oswalt's Avatar
    Sorry that didn't work for you. Not sure how to create the log. Hopefully someone here can help you out so you can submit it to BlackBerry.
    08-30-13 03:41 AM
  5. powderbanks's Avatar
    Tried this, still didn't work. How and where do we find logs pertaining to the install and it's subsequent roll back?

    Posted via CB10
    Hmm, if you're not already a Beta Zone member (you should be now, I think any BBID will let you log in) join, and then post in that thread.

    The log file is in C:\Users\*UserName*\AppData\Local\Temp and is called 'BBLink_Install.log' I use Search Everything and just found it that way, otherwise you'll just have to look around that Temp folder.
    08-30-13 07:35 AM
  6. GreenCopperz's Avatar
    Anyway I can send you the log and you can help me decipher what's causing the install error? Mine is not being cause by the printer thing in the above post...

    Posted via CB10
    09-06-13 02:48 PM
  7. powderbanks's Avatar
    Anyway I can send you the log and you can help me decipher what's causing the install error? Mine is not being cause by the printer thing in the above post...

    Posted via CB10
    I can't, but the developer team at Blackberry can. Hit up that Beta Zone link, register if you already haven't (it's through your BBID now), and read that thread I linked earlier. The guy from Blackberry has a post about where to email log files. Also make a post letting them know you're submitting one because of a different issue
    09-06-13 09:39 PM
  8. GreenCopperz's Avatar
    Thanks will see what I can do...

    Posted via CB10
    09-06-13 09:53 PM
  9. GreenCopperz's Avatar
    I can't, but the developer team at Blackberry can. Hit up that Beta Zone link, register if you already haven't (it's through your BBID now), and read that thread I linked earlier. The guy from Blackberry has a post about where to email log files. Also make a post letting them know you're submitting one because of a different issue
    Your old link wasn't going directly to the thread. Can't seem to find it via search either. Can you try to post a link again?

    Posted via CB10
    09-12-13 06:58 PM
  10. powderbanks's Avatar
    Your old link wasn't going directly to the thread. Can't seem to find it via search either. Can you try to post a link again?

    Posted via CB10
    https://beta.webapps.blackberry.com/...iew/16088?pg=1

    The first link I posted was still working for me, let me know if that works. If not, you just have to navigate through a bunch of stuff to get to the discussion board
    09-13-13 05:15 PM
  11. andrearp's Avatar
    I finally found a solution to this problem

    While performing some searches, I discovered this affected BOTH Blackberry Link AND Blackberry Desktop Software, so there should have been some ... link between the two.

    There are many threads around, but each one refers only to one of the two softwares, but the common problems led me to understand that this is unrelated to the software package itself, but to automatic driver installation procedures
    carried out by the installer (Windows INstaller)

    Here's what I found:

    Affected Environment: the problems shows up on Windows 7 and other Windows version machines, when installing or upgrading Blackberry Desktop Software, or Blackberry Link.

    Sometimes, you have Desktop software installed and you want to install Link, OR you have Desktop software installed, it is working fine, but you need to upgrade it (automatically) to apply some software update -
    some Desktop SOftware updates are required to update some devices.

    Symptomps
    The problems shows in exactly the same way, during the final steps of installation of either Blackberry Desktop 7 OR Blackberry Link.
    You get a warning message saying
    "Some of the installation files from the previous versions of the software could not be removed. Make sure that no other application is using these files."

    open the

    Users\$_you_user_name\AppData\Local\Temp
    directory. You may need to choose hidden files and folders in Windows Explorer to see these

    Choose to sort files by creation date, scroll to the most recent files, and look for one of these

    BB_Desktop.log, if you're installing Blackberry Desktop Software
    OR
    BBLink_Install.log if you're installing Blackberry Link software.

    Open your file with a text editor, and look for part of the error message "some of the installation" using the Find feature
    The cursor should stop where the error occoured.
    If the line above shows something referring to InstallRimUsbDriver, there are good chances you're exactly in my situation.

    If you DON'T find the same error I found, the line above the error message should give you a clue about what's going on, and you may want to share it on this forum, however the solution below may not be applicable to you.



    Solution

    Before you begin BACKUP YOUR SYSTEM AND CREATE A SYSTEM RESTORE POINT. The best thing is to have a full hard drive image. While the following steps are quite straightforward, additional problems on your system may be creating a
    potentially worse situation. Remember to backup your Blackberry device as well and also contacts/calendars/notes as these can be affected by the first sync after Desktop Software reinstallation.

    While I'm listing all the steps I took, some of them may be unnecessary, however the uninstall/reinstall of Desktop Manager or Link software should be performed anyway, IMHO.

    Uninstall Blackberry Desktop Software or Blackberry Link (I chose the "erase user data" option as well).
    With the device still connected, Uninstall the Blackberry smartphone driver from Control Panel / Device Manager
    Disconnect the device.
    Open a command prompt window, and type
    pnputil.exe -e
    you'll get a list of devices/drivers, scroll as needed and take note of the "oemxx.inf" entries regarding Research In Motion devices.
    (xx can be a 2 or 3 digits number)
    type
    pnputil.exe -f -d oemxxx.inf
    to remove the entries regarding the Research in Motion devices.
    Chech that the operation succeded after each action.
    Restart system.

    At this point, yoy may start reinstalling the Blackberry Desktop or Blackberry Link Software;

    You may still get the error.

    Now perform again the above actions regarding pnputil.exe to see if there are still Research in Motion devices appearing.

    then open the

    Users\$_you_user_name\AppData\Local\Temp
    directory. You may need to choose hidden files and folders in Windows Explorer to see these (you should have done this before, see above)

    Choose to sort files by creation date, scroll to the most recent files, and look for one of these

    rim_usb_install_log (date stamp) - choose the most recent

    Open it with a text editor

    In my case, I found this(20:52:07): Entering ModifyRimUsbRegKey

    (20:52:07): Exit ModifyRimUsbRegKey, RimUsb.sys count: 2

    (20:52:07): InstallRimUsbDriver NT
    (20:52:07): DeleteAllRIMInfFiles ENTER
    (20:52:07): SetupUninstallOEMInf inf fileem192.inf ERROR 0xe000023c

    Look for the oemxxx.inf (in this example is oem192.inf) file on your hard drive. Delete it.

    Run the installer again. This time, I went into another error

    (20:59:48): DisconnectDevices: Enter
    (20:59:48): DisconnectDevices: CreateInstance failed. Error=0x80070002
    (20:59:48): DisconnectDevices: Enter
    (20:59:48): DisconnectDevices: CreateInstance failed. Error=0x80070002


    Then rebooted and the install went fine.

    Keep in mind that, whenever something goes wrong with these driver related action, you get little information in the main log file, but you get some more in this file.

    After performing these action, reconnect the device, it should be recognized; you'll almost certainly need to reconfigure your sync preferences, and start synching again.

    Please let me know if this helped.
    01-06-14 02:54 PM
  12. Akamali's Avatar
    Thanks but the fix is very simple

    To resolve this issue simply delete the following RIM files in the following location
    C:\Windows\Inf\RIM*.inf
    C:\Windows\System32\Drivers\RIM*.sys files
    Then try to re-install link and it will complete without any issues. I did not even have to reboot my PC..

    I trust this helps.

    Thanks

    Adam K
    skipromark likes this.
    01-29-14 03:04 PM
  13. 13echo4's Avatar
    For some of yall that still can't get BlackBerry link installed the problem is most likely do to a permissions problem with a system file most likely an .Inf extention.
    What ya want to do is search for blackberry file and folders. To cut to the chase you can just delete the research in motion folder in program files then open c:\windows and search the folder. Delete all the findings. Mostly you'll get a message that some files and a folder in system32\driverstore\filerepository can't be deleted you need permission. So this is how you include your user to have the same rights as system.
    Take ownership:
    Right click the file\properties\security\advanced\owner. Current owner is going to be system so under the section to "change owner to:" select edit and select your user account click apply. Your going to get a message that pretty much says you have to close out properties to make changes to permissions.
    Right click the file again properties\security: under the group or user name section click edit then select everyone then select full control in permissions then apply then close out. Now you can delete the file.
    If you have a folder you do it the same way but have one more step. After taking ownership and setting the permissions to full control click on advanced and click on edit under permission entries. High light the top entry then at the bottom uncheck the first block and check the second block then click apply and now you should be able to delete the whole folder at one time. If it doesn't work you'll have to go into the folder and manually change every file.
    All should be well and link will now install.
    02-03-14 01:43 AM
  14. skipromark's Avatar
    Awesome! That worked perfectly...thanks so much as couldn't get BB Link to download and wanted to transfer files from old phone to new one. Love your work.
    03-04-14 02:37 AM
  15. Rhonda Snappyrue's Avatar
    After a month of trying to sync my computer with my BBz10 I give up. Drop Box is what I use now to add pictures music etc or at least access .
    03-17-14 09:59 PM
  16. fabio984's Avatar
    Im desperating. 5 days trying to install blackberry link. getting crazy with it.
    09-02-14 05:49 PM
  17. barbarianthemadserb's Avatar
    I too had a problem with installing BBlink. After I upgraded my Z30 to the latest leak (10.3.0.1154) I could neither install BBlink nor see my Z30 from win7 on my laptop. I got several different errors one of which said something about "error opening installation of log file" . There were other errors too. I spent most of this morning browsing the web and finally found something on microsoft site that addressed bblink and blackberry. It was a very technical description (I don't remember the msft web location). Well anyway, msft showed two methods. Method a (complex and good possiblity of messing up the registry). Method b (work around) was simple. This was according to their instructions. I made (in win 7) a second account WITH administration priveledges. Bblink installed with no problem and I not only could use BBlink but also connect to my Z30. I then went back to my first account (admin priveledges) and voila- BBlink was there and worked with no problems. I don't know the technical reason why but for me this quick workaround worked.
    09-09-14 05:51 PM
  18. fabulousdanceway's Avatar
    When I was bought this phone then it having no any problem, but few days my BlackBerry z3 is not installing any app, please help me
    01-04-15 08:42 PM
  19. Halifax Guy's Avatar
    I have spent almost two weeks trying to install Link. The most I could do (until just moments ago) was 25% of the download, before having an error message. This evening I tried again and was amazed to watch the entire download successfully download to my PC Win 7 laptop. Then I watched in awe as the file was installed and my laptop has Link on it once again. Now it is a matter of finding out if it will function properly.

    Posted using 10.2.1, thankfully not 10.3.1
    05-18-15 06:13 PM
  20. Halifax Guy's Avatar
    Working fine now.

    Posted using 10.2.1, thankfully not 10.3.1
    05-18-15 07:01 PM
  21. henrymc8's Avatar
    I have had many program problems and fix it with Microsoft Fixit! I can't link it because not enough post yet.

    Microsoft Fixit
    Fix problems that programs cannot be installed or uninstalled. Automatically repair issues that block program installation or removal because of corrupted registry keys.
    What it fixes

    Corrupted registry keys on 64-bit operating systems
    Corrupted registry keys that control the update data
    Problems that prevent new programs from being installed
    Problems that prevent existing programs from being completely uninstalled or updated
    Problems that block you from uninstalling a program through the Add or Remove Programs (or Programs and Features) item in Control Panel
    Last edited by henrymc8; 06-14-15 at 06:53 PM.
    06-14-15 04:02 PM
  22. norenendur's Avatar
    Fast solution for ultra-geeks running windows 10 and unable to install link: install the software in a virtual machine running windows 7 32bit: no problem at all, installed in 3 minutes, set the phone's shared folder as a folder on the main machine.
    This being after about 1 hour of installs, uninstalls, moving .inf and whatever, which is about the maximum time I can allocate to working on something like this.
    Disappointed, but hey, I still have the qwerty keyboard, moving on.
    08-01-16 05:24 AM
  23. SonyainTx's Avatar
    @BlackberryHelp did the same to me. BB Link will not open on my Windows 7 computer. I tried to get BBHelp to help and they say contact Verizon. Makes no sense as Link is Blackberry's software, not Verizon's. Grrr....

    Thing is, my Z30 was able to be backed up through BB desktop manager app. I downloaded Link and Blend, and the Desktop Manager told me that the app doesn't support BB10 phones anymore.
    09-22-16 03:03 AM
48 12

Similar Threads

  1. Replies: 2
    Last Post: 03-05-13, 12:36 PM
  2. BB AppStore Install Error...
    By xtnded in forum BlackBerry Bold 9000
    Replies: 1
    Last Post: 10-18-09, 10:18 PM
  3. BB Messenger Java Error
    By feetr2c in forum General BlackBerry Discussion
    Replies: 13
    Last Post: 04-24-08, 08:57 PM
  4. BB Messenger installation help requested
    By ksechrest in forum BlackBerry 8830 WE
    Replies: 3
    Last Post: 03-24-08, 10:28 AM
  5. PocketMac, BB 8130, Installing Dope Wars
    By archer823 in forum Mac Users
    Replies: 5
    Last Post: 03-11-08, 02:02 PM
LINK TO POST COPIED TO CLIPBOARD