1. CRETY's Avatar
    I have been a Blackberry customer for many years, and with all the other phones coming out, I still decided to stick with Blackberry. I have also updated our phones over the years with Blackberry. For the first time I have become a very dissatisfied customer of BB.

    Since having to set up Windows 10 on our computers we slowly started seeing a change with the syncing of data from BB through the BB Link and Blend. Over the last few months it has gotten worst, we are getting the same error messages as a lot of others I have researched on CrackBerry. I have tried many of the "fixes" listed without any luck to getting my data to back up, even via Wi-Fi with the USB connected.

    The error messages are "The USB is not connected, or malfunctioning and Windows does not recognize it" I tried using the Wi-Fi to connect it and try to sync the data and that did not work. Then it showed connected to Wi-Fi, however, BB Link showed it can't do a "back-up, restore, or sync contacts and calendar using Wi-Fi".

    I contacted BB through my carrier and got bad news, I was told by a BB Representative: VERBATIM ( BB DOES NOT have a fix for their phones, and there is NO PATCH for any of the phones to work with Windows 10. My cell is NOT COMPATIBLE with Windows 10). When asked what that does for the many customers with BB phones, the answer given was VERBATIM: The phone will work using Windows 7.

    That was very disappointing to hear as a long time customer of BB and seeing they are not considering a PATCH or any fix for the users to be able to sync their data. We have 5 BB phones in our home, and after today looks like we will have to give up using BB. What bothered me the most was hearing there is no fix for this.

    If anyone has a real fix and are able to sync your BB's without issues using Windows 10, post and let me know. I felt it was very to post this so other BB users experiencing the same problems would know.
    08-31-17 09:09 PM
  2. brookie229's Avatar
    If anyone has a real fix and are able to sync your BB's without issues using Windows 10, post and let me know. I felt it was very to post this so other BB users experiencing the same problems would know.
    You are a newbie to CB and I realize you are frustrated but you need to know that BB has dropped Link and Blend and no further updates or fixes will be forthcoming. As you have done some research on CB you can see that many people are unable to connect with Windows 10. I am NOT one of those people as my Win 10 laptop (and my Win 10 Lenovo Thinkpad tablet) will both connect using Link and Blend. No one has been able to figure out why some can connect and others can not. All I can tell you is that if you are having trouble you can try to uninstall the BB link and blend software, then manually go into the register of your computer (be very careful!) and search for and delete ANY registry or key related to BlackBerry, then reboot your PC. Next, attach your BB10 device by USB and follow the driver and software installation instructions that show up ON your BB10 device. In other words, let your BB10 device begin the software installation. This procedure has worked for me but YMMV. Finally when connecting with Link, I have noticed that it takes an unusually long time to connect with the BB10 device when connected via usb (in the range of 5 minutes or so) and many people may not be patient enough to wait for the connection. If none of this helps, sorry but it's all I can offer. Make double/triple/quadruple sure that your registry is clean of ANY BB software/files etc before you reinstall. Good luck!
    08-31-17 11:25 PM
  3. bb10adopter111's Avatar
    There is more info on the issues with Link, which runs fine on all my Win10 machines. ITunes is a known problem, and I've heard Uninstaller it can help.

    Posted with my trusty Z10
    09-01-17 12:03 AM
  4. brookie229's Avatar
    There is more info on the issues with Link, which runs fine on all my Win10 machines. ITunes is a known problem, and I've heard Uninstaller it can help.

    Posted with my trusty Z10
    Revo Uninstaller for the PC works great for going through your PC's registry and removing a programs remnants.

    Posted via CB10
    09-01-17 08:16 AM
  5. CRETY's Avatar
    Hi Brookie229,

    Thanks for the reply, and yes I am very frustrated, however, I did try some of the suggestions, I am still having the same issues, but I did find some alternatives which may make us happy enough to stick with BB. We are going to try some of the alternatives and see how they work for us.

    Thanks Again for the positive response!
    09-03-17 01:05 AM
  6. BB4matt's Avatar
    After this upgrade for WIN 10 Pro: 1703 OS Build 15063.540 Link stopped working but Blend and Y: and Z: drives served by BB Device Manager kept working OK. I guess Link uses its own Device Mgr. to talk to BB10 devices and it gets messed up with new WIN10 releases sometimes.

    I uninstalled Link, Blend, and Drivers; rebooted; disabled all antivirus software, e.g. Windows defender, Avast (google, how to disable all of them), re-installed: Link, Blend, and Drivers and all is good again. I also had to do this un-and re-install when WIN10 updated with the anniversary edition. FYI
    09-03-17 04:16 PM
  7. CRETY's Avatar
    Still going through doing some of the posted suggestions, everything is working except the "backup and restore" for BBLINK. Trying out the Ultimate BB backup for the cells. Like it so far!
    09-07-17 10:55 PM
  8. Peter_Cincy's Avatar
    My own experience is that I have not been able to use Link with any release of Windows 10 Pro later than 1511. I will admit to having not tried exhaustively to find a work-around, so maybe it *is* possible. However, I have fortunately staggered the W10 updates to my five machines - two on 1703, one on 1607, but two still on 1511 - that I am not completely locked out.

    Of course the incompatibility is not completely the fault of Windows updates, the iTunes 12.5 release being the first culprit. It's hard remembering to not apply Apple updates, which I accidentally did before recalling that I didn't want to. I found that a Link uninstall-reinstall cycle with reboots did the trick on one machine, but Link now only works for one user (me) and not the other one (my wife) even though we both have admin rights. I wish Link weren't so spotty. At least Blend continues to work.
    09-12-17 06:24 PM

Similar Threads

  1. Some SMS text messages not showing in messages
    By Jonathan R in forum BlackBerry KEYone
    Replies: 8
    Last Post: 12-22-17, 04:11 PM
  2. Sold my KEYone and pre-ordered Samsung Note 8
    By kitmo in forum BlackBerry KEYone
    Replies: 39
    Last Post: 09-02-17, 09:41 AM
  3. Phone app calling people on its own?
    By Lucas D in forum BlackBerry KEYone
    Replies: 13
    Last Post: 08-31-17, 07:57 PM
  4. Unable to log in to Phone
    By svsrbh in forum BlackBerry Z10
    Replies: 1
    Last Post: 08-31-17, 02:12 PM
  5. Call Name does not appear in call log history how do we fix this?
    By CrackBerry Question in forum Ask a Question
    Replies: 0
    Last Post: 08-31-17, 01:49 PM
LINK TO POST COPIED TO CLIPBOARD