1. intravino's Avatar
    Hi all,

    I replaced on the weekend the battery on my wife's Keyone. The replacement went well, it is the second gen build without extra glue.

    She noticed that the WiFi connection tends to disconnect and reconnect since the battery.

    Do you think I may of damage something on the back cover (antenna) because of the battery swap ?

    Many Thanks,
    02-17-20 09:06 AM
  2. Dunt Dunt Dunt's Avatar
    Is the WiFI antenna on the back cover... or is that for NFC?

    I'd check on line for the location of the WiFi antenna, and open it up and see if something came loose.
    02-17-20 10:50 AM
  3. Gundagordy's Avatar
    The tiny connectors just above the battery that press against the back of the battery door (inside top leftish side) probably got bent or crushed. I did the same thing.

    PITA too because I can't find a repair shop skilled enough to do some micro soldering.

    Hopefully you're able to realign the connectors yourself. Be careful with them... they're very delicate.
    brookie229 likes this.
    02-17-20 11:27 AM
  4. intravino's Avatar
    Okay thanks. I will check the connectors tonight.
    02-17-20 03:06 PM
  5. intravino's Avatar
    Yes, you were right. It was one the pins on the connectors. I straiten them out. Works fine now.

    Thanks Again,

    Intravino
    02-18-20 08:32 AM
  6. Gundagordy's Avatar
    Excellent glad to hear!
    02-18-20 10:51 AM

Similar Threads

  1. Replies: 31
    Last Post: 03-24-20, 12:51 PM
  2. Ghost touch problem after switching loudspeaker / handsetcall
    By titipan Mertua in forum BlackBerry Passport
    Replies: 2
    Last Post: 03-09-20, 07:14 AM
  3. Blackberry z10 stl100-1 Startup Setting Issue.
    By Honey Singh91 in forum BlackBerry 10 OS
    Replies: 7
    Last Post: 02-15-20, 06:14 AM
  4. Replies: 8
    Last Post: 02-14-20, 03:24 PM
  5. DTEK50 Battery Replacement
    By rlattajr in forum Ask a Question
    Replies: 3
    Last Post: 02-12-20, 01:33 PM
LINK TO POST COPIED TO CLIPBOARD