1. mh1983's Avatar
    Wow, Wi-Fi is pretty bad on the KeyOne. I see it's a longstanding issue that many post about. I switched from 5 to 2.4 ghz as most recommend but still observe the dropping issue. Am on the latest patch (June) and Wi-Fi signal is squeaky clean (even my PB can use both bands just fine).

    Any other suggestions worth exploring?
    03-19-20 01:49 PM
  2. Dunt Dunt Dunt's Avatar
    Remove the rear cover to see if the "springs" are making contact with the antenna on the rear cover... (watch a video to see how to do this without breaking tabs)

    Only other thing is to do a Factory Rest.... see if it improves.
    mh1983 likes this.
    03-19-20 03:03 PM
  3. mh1983's Avatar
    Remove the rear cover to see if the "springs" are making contact with the antenna on the rear cover... (watch a video to see how to do this without breaking tabs)

    Only other thing is to do a Factory Rest.... see if it improves.
    Thanks! Things look fine with the back of the phone. I identified some router config issues (mainly band steering. Seems to confuse some devices). I changed the Wi-Fi broadcast channels too. That seems to help and the phone actually does better with the 5G now. If the issue returns, I'll keep the factory reset in mind. Cheers!
    03-23-20 07:50 AM

Similar Threads

  1. Sci-fi chat (open) group
    By Mwanahabari in forum Discover BBM Groups
    Replies: 8
    Last Post: 03-05-20, 03:57 PM
  2. Linus recommended a random PKB slider over the KEY2
    By johnb_xp in forum BlackBerry KEY2
    Replies: 22
    Last Post: 02-17-20, 08:55 PM
  3. Key2 randomly opens camera and Chrome when unlocked
    By Leuttra in forum BlackBerry KEY2
    Replies: 2
    Last Post: 02-06-20, 10:00 AM
  4. Dropped my Keyone Now looking for Key2 on Sprint
    By IETZR1S in forum BlackBerry KEYone
    Replies: 4
    Last Post: 01-30-20, 04:36 AM
  5. Hotel Wi-Fi networks
    By Matt Beyea in forum Ask a Question
    Replies: 12
    Last Post: 01-23-20, 11:12 PM
LINK TO POST COPIED TO CLIPBOARD