Built for Business - Learn more about BlackBerry KEY2
  1. ftm42's Avatar
    I've tried everything!

    Switching Wi-Fi off and on
    Restarting my phone
    Forgetting the network + re connecting
    Switching airplane mode off and on

    What do I have to do to make it work again! All works brilliantly using mobile data but as soon as I switch the Wi-Fi on, it all comes to a shuddering halt.

    Any advice PLEASE - it's been going on for weeks now.
    09-10-19 03:36 PM
  2. Chuck Finley69's Avatar
    I've tried everything!

    Switching Wi-Fi off and on
    Restarting my phone
    Forgetting the network + re connecting
    Switching airplane mode off and on

    What do I have to do to make it work again! All works brilliantly using mobile data but as soon as I switch the Wi-Fi on, it all comes to a shuddering halt.

    Any advice PLEASE - it's been going on for weeks now.
    There’s always the nuclear factory reset option...
    09-10-19 07:48 PM
  3. ftm42's Avatar
    As long as there's a failsafe 'backup everything' option?
    09-11-19 02:19 AM
  4. yamahammer's Avatar
    I've tried everything!

    Switching Wi-Fi off and on
    Restarting my phone
    Forgetting the network + re connecting
    Switching airplane mode off and on

    What do I have to do to make it work again! All works brilliantly using mobile data but as soon as I switch the Wi-Fi on, it all comes to a shuddering halt.

    Any advice PLEASE - it's been going on for weeks now.
    Is your back cover on tight? The WiFi antenna is on the back cover with the contacts just below the camera.
    09-11-19 02:57 AM
  5. ftm42's Avatar
    Just to be clear - it does connect to the wifi, but every time it does, the phone just goes into impossibly slow mode. If I switch the wifi off again, it all works fast, but is munching my data!
    09-11-19 01:36 PM
  6. Chuck Finley69's Avatar
    Just to be clear - it does connect to the wifi, but every time it does, the phone just goes into impossibly slow mode. If I switch the wifi off again, it all works fast, but is munching my data!
    Is the WiFi bill paid? Sometimes when past due, ISP will slow down to encourage phone call. At least that’s what close friend told me.. ;-)
    09-11-19 02:28 PM
  7. yamahammer's Avatar
    Just to be clear - it does connect to the wifi, but every time it does, the phone just goes into impossibly slow mode. If I switch the wifi off again, it all works fast, but is munching my data!
    Based on what you posted, the issue is with your Wi-Fi source. Do you ever go to a place that has free WiFi access? If so report back...
    09-11-19 11:15 PM
  8. ftm42's Avatar
    I'm on our home Wi-Fi. Everyone else in the house is fine.

    I haven't used it much outside the house, so maybe need to test it next time I'm in our local shopping centre, where I have a login to their Wi-Fi.
    09-12-19 03:57 AM
  9. ftm42's Avatar
    OK so I have Wi-Fi on now + so far so good. However, Lens refuses to work. I was supposed to be using it during a cyber security session this morning at work to read QR codes but couldn't as it just wouldn't run. However, when I got back to my desk in a different building it worked fine.

    Now I'm home it doesn't work any more. It just seems so inconsistent
    09-12-19 03:39 PM
  10. ftm42's Avatar
    Bills are paid by direct debit, but even so, why is the rest of the family OK?

    I used shopping centre free WiFi today + all OK
    09-12-19 03:43 PM
  11. ftm42's Avatar
    Bills are paid by direct debit, but even so, why is the rest of the family OK?

    I used shopping centre free WiFi today + all OK
    09-12-19 03:51 PM
  12. ftm42's Avatar
    Went to settings/wifi + switched off "allow use of mobile data even when wifi is connected" and it now seems much quicker. Or is this wishful thinking??
    09-12-19 03:54 PM
  13. Chuck Finley69's Avatar
    Bills are paid by direct debit, but even so, why is the rest of the family OK?

    I used shopping centre free WiFi today + all OK
    On the bill paid, I was being semi-facetious but I’ve had my internet slowed down by the ISP to alert me of pending disconnect.

    That bad joke aside, that affects everything so your bill sounds paid up...

    I’m going with something in your WiFi settings that’s deeper than my smart arse knowledge.

    Perhaps a CB member that experience with actual networking equipment and deep settings..

    Factory reset usually fixes but that seems a bit extreme if moving a toggle or two solves the problem
    09-12-19 03:57 PM
  14. ftm42's Avatar
    Went to settings/wifi / wifi preferences + switched off "allow use of mobile data even when wifi is connected" and it now seems much quicker. Or is this wishful thinking??
    09-12-19 04:05 PM
  15. RLeeSimon's Avatar
    Based on what you posted, the issue is with your Wi-Fi source. Do you ever go to a place that has free WiFi access? If so report back...
    Reboot the router
    09-13-19 06:03 PM
  16. Rgrblue's Avatar
    having same issue on my Sprint ketone - suddenly today Wifi not connecting to Internet! help!
    All other iphone in my home are connected to the Wifi. It's just suddenly my Ketone is having issue and no connection to Internet.
    09-14-19 11:46 AM
  17. Rgrblue's Avatar
    Router issue for me!
    Last edited by Rgrblue; 09-14-19 at 01:25 PM.
    09-14-19 11:53 AM
  18. RLeeSimon's Avatar
    I don't know who your provider is but I do know Xfinity in the United States does cause router misery just to keep their customers in line … periodically I need to restart the router either using a command from the television screen or from the X fi app on my phone or just simply pulling the plug and the results results always the same the entire thing works fine afterwards. The reason for this is incomprehensible. They don't manufacture anything, the routers are made by Motorola now called Arris.
    09-14-19 02:10 PM
  19. ftm42's Avatar
    Spoke too soon. Continually having to switch Wi-Fi off + on; restart the phone; swear...dangerously close to going over mobile data usage for this month. I have the most up to date router + no-one else in the house has an issue. Im the only one with a blackberry + will get rid of it soon if I can't fix it. Been in to see Vodafone techie expert several times now but he/she is never actually there. In a town of 60K plus people, you'd think they might need >1 expert?!
    09-16-19 02:44 AM
  20. Bigbootayyy's Avatar
    Spoke too soon. Continually having to switch Wi-Fi off + on; restart the phone; swear...dangerously close to going over mobile data usage for this month. I have the most up to date router + no-one else in the house has an issue. Im the only one with a blackberry + will get rid of it soon if I can't fix it. Been in to see Vodafone techie expert several times now but he/she is never actually there. In a town of 60K plus people, you'd think they might need >1 expert?!
    I have been having the same problem at home only, anywhere else my Wi-Fi works fine. No one else at home (samsung/iphone users) have these problems. I have reset network etc on phone turned of use data while using Wi-Fi etc! I can browse websites but certain things (mainly games) will not work unless I switch it on off through out game play.

    Any suggestions please???? I really don't want to factory reset as really cba backing up everything to have to re-installed at the minute
    09-18-19 07:23 PM

Similar Threads

  1. Can we ask BlackBerry to unlock bootloader?
    By michalko58 in forum BlackBerry KEYone
    Replies: 35
    Last Post: 09-13-19, 03:14 PM
  2. Getting Blacberry Hub icon - back to the front screen
    By Paul Magill in forum BlackBerry KEY2
    Replies: 2
    Last Post: 09-11-19, 03:48 PM
  3. how to enable native contacts
    By mackconsult in forum BlackBerry KEY2
    Replies: 2
    Last Post: 09-10-19, 12:18 PM
  4. UConnect : Request to Confirm Pairing Code
    By HereinHalifax in forum BlackBerry Classic
    Replies: 20
    Last Post: 09-09-19, 05:04 PM
  5. Replies: 2
    Last Post: 09-09-19, 03:47 PM
LINK TO POST COPIED TO CLIPBOARD