1. unity04's Avatar
    Hey, I have the Keyone with Rogers and I'm running into an issue where my text messages are taking a minute or two to send. A quick restart seems to fix it but then it starts happening again after a few hours. Anyone else facing a similar issue?
    hoytbowhunter likes this.
    06-05-17 07:25 AM
  2. hoytbowhunter's Avatar
    If you're using Android messenger that's normal, its probably the slowest app from the Play Store. I prefer Chomp SMS not only can you get themes but you can get WhatsApp emojis also..
    06-05-17 07:58 AM
  3. unity04's Avatar
    I've used Messenger on all my Android devices and it's never taken this long to send a message.
    06-05-17 08:01 AM
  4. hoytbowhunter's Avatar
    Weird. Did you set up the apn settings?
    06-05-17 08:03 AM
  5. Pinot2015's Avatar
    You should not have to adjust anything. Maybe reinstall Messages. Or clear cache for it in Settings > Apps > messages app > storage > clear cache or clear data. Clear data is better but you would lose all existing messages.
    06-05-17 08:17 AM
  6. nucks26's Avatar
    Could perhaps be a Rogers issue. I'm not aware of them having any issues at this time but always check their twitter page. They ran into a horrible double text issue last year where I was sending 10 duplicate texts to my friends at one point lol.

    However to stay on topic, I much prefer textra SMS.
    06-05-17 09:19 AM
  7. jay2s's Avatar
    I use textra for text messaging, works great
    Bucky2016 and anon(870071) like this.
    06-05-17 09:20 AM
  8. irweezyy's Avatar
    Hey, I have the Keyone with Rogers and I'm running into an issue where my text messages are taking a minute or two to send. A quick restart seems to fix it but then it starts happening again after a few hours. Anyone else facing a similar issue?
    I noticed the same issue just now. Never had this issue in the PRIV.
    06-05-17 09:26 AM
  9. psychofox13's Avatar
    For me, texting takes the same length of time as my previous Android and Windows phone. It takes a few seconds, but it's because I'm on a MicroCell. It's almost instant when I'm in the city.
    06-05-17 12:22 PM
  10. SStever's Avatar
    I have been desperately trying to fix this. I sent my Keyone back to Rogers while I was still in the buyers remorse stage until I can get this figured out. This is what I have noticed. I have Rogers internet at home and also Rogers internet at work. AT home only, the texts take a really long time to send if I have both wifi and data turned on. IF I turn either one off it works great. At work I can leave them both on and everything is fine all day long. I called Rogers thinking there is possibly a modem/router issue at my house and of course they said no and said it was a blackberry issue. I called blackberry and they insisted it was a Rogers issue. I decided I couldn't live with the frustration and returned it. Otherwise I loved everything about the phone and I am convinced I will be getting another one once this is figured out. I keep reading forums but nothing yet. I am really convinced its a modem/router setting.
    06-22-17 02:14 PM
  11. SStever's Avatar
    also, I have downloaded and tried many different sms apps and it was the same with all of them.
    06-22-17 02:15 PM
  12. bigjman's Avatar
    I think maybe it's a android (or BlackBerry android?) thing. On my dtek50 sometimes there is a delay (not several minutes but maybe 30 seconds at the most) when I send texts through yaata, while on my Passport it's always instant. But to me, no big deal. I don't send life or death text messages anyway.

    Posted via CB10
    06-22-17 03:09 PM
  13. Rustlers17's Avatar
    I have the same issue with Rogers and text messages. Main issue for me is dropping calls and bad reception. I already returned the phone and got a new one and it hasn't changed. Maybe Rogers?
    06-22-17 04:51 PM
  14. kbz1960's Avatar
    I have the same issue with Rogers and text messages. Main issue for me is dropping calls and bad reception. I already returned the phone and got a new one and it hasn't changed. Maybe Rogers?
    Could be or could be something they need to tweak in the radio software.
    06-22-17 05:14 PM
  15. schwartz1030's Avatar
    I have been desperately trying to fix this. I sent my Keyone back to Rogers while I was still in the buyers remorse stage until I can get this figured out. This is what I have noticed. I have Rogers internet at home and also Rogers internet at work. AT home only, the texts take a really long time to send if I have both wifi and data turned on. IF I turn either one off it works great. At work I can leave them both on and everything is fine all day long. I called Rogers thinking there is possibly a modem/router issue at my house and of course they said no and said it was a blackberry issue. I called blackberry and they insisted it was a Rogers issue. I decided I couldn't live with the frustration and returned it. Otherwise I loved everything about the phone and I am convinced I will be getting another one once this is figured out. I keep reading forums but nothing yet. I am really convinced its a modem/router setting.
    OK, I was having the same text sending problem, but I did not draw the connection with my wifi. I get the problem mainly at home, but sometimes at work as well (where I use wifi as well). Just disabled wifi, and lo and behold, texts seem to be sending fine. Sounds like a device hardware problem, or a software driver/os issue...

    I do have Rogers as well, but I can't imagine how they would be the problem. My wifi router is not the rogers one.

    How did you complain to BlackBerry?
    06-22-17 10:38 PM
  16. Shane8750's Avatar
    I also noticed sms is slow, and sometimes not sent when I'm on wifi.Annoying because it fails more often then not. Is this only a rogers/wifi issue or are others on another carrier experiencing same issue? Pain having to keep wifi off for reliable sms.
    07-02-17 03:31 PM
  17. llrenta's Avatar
    I have had the same issue at times, but have also had this with other phones as well. I'm on TMO in the States. I guess I'm used to it. If it happens I just check the WIFI and turn it off if need be. My UVERSE at home is crappy also and is going to be replaced soon.
    07-02-17 10:36 PM
  18. reintgenrc's Avatar
    I've found that my KeyOne on AT&T took forever to send messages on the messages app due to RCS/advanced messaging being turned on. Why? Because I admit the app itself is slow with texts, but RCS messages will get hung up if you don't have good reception. My advice is to disable that feature.
    07-03-17 11:30 AM
  19. Shane8750's Avatar
    after a call with tech support (Rogers) he first starts by asking if I had wifi calling enabled. I stated I did not know it was available as I don't have any settings for it. He found out it will be with next update (July presumably) as for delayed texts, it's only when wifi is enabled. it takes awhile, and many times will just fail to send. he suggested turning off 'VoLTE' in cellular settings. seems to have cleared up the delay and hopefully the update, which he couldn't confirm any dates, will correct this annoying issue.
    07-06-17 07:45 PM
  20. anon(870071)'s Avatar
    I use textra for text messaging, works great
    And fast too!
    07-06-17 07:53 PM
  21. schwartz1030's Avatar
    after a call with tech support (Rogers) he first starts by asking if I had wifi calling enabled. I stated I did not know it was available as I don't have any settings for it. He found out it will be with next update (July presumably) as for delayed texts, it's only when wifi is enabled. it takes awhile, and many times will just fail to send. he suggested turning off 'VoLTE' in cellular settings. seems to have cleared up the delay and hopefully the update, which he couldn't confirm any dates, will correct this annoying issue.
    Perfect. That seems to be working for me as well. I have no idea what Voice over LTE is anyways. Thanks.
    07-15-17 08:27 PM

Similar Threads

  1. Need some help with deciding on which Priv to buy
    By stevegamer in forum BlackBerry Priv
    Replies: 12
    Last Post: 06-18-17, 06:08 AM
  2. Replies: 21
    Last Post: 06-06-17, 11:31 PM
  3. BBM on BB10 to BB Android
    By coffee-turtle in forum General BBM Chat
    Replies: 5
    Last Post: 06-06-17, 12:52 PM
  4. Text messages not showing up in the Hub
    By shawnpandey in forum BlackBerry KEYone
    Replies: 8
    Last Post: 06-05-17, 01:40 AM
  5. Replies: 0
    Last Post: 06-04-17, 10:14 PM
LINK TO POST COPIED TO CLIPBOARD