11-21-19 09:46 PM
51 123
tools
  1. Rando3000's Avatar
    For those on AT&T (US) and have upgraded to Oreo 8.1, I finally found the Wi-Fi Calling setup option!

    Unfortunately for myself and anyone else on a prepaid plan, the feature won't be usable at the moment (see screen shot). But still, I hope this helps others access Wi-Fi calling!

    Where I found the setting:

    1. Press and held the home screen to access widgets + shortcuts

    2. Selected the "Settings shortcut"

    3. Scrolled to the bottom of the list of settings to create as a shortcut, selected Wi-Fi Calling

    4. Once on the home screen, opened the shortcut

    Device info:

    - BBB100-1

    - AT&T Space Black KEYone

    - carrier plan: AT&T PREPAID

    - v. 8.1.0

    - ABD375
    Attached Thumbnails AT&T Wi-Fi Calling Found! (Oreo)-50409.jpg   AT&T Wi-Fi Calling Found! (Oreo)-screenshot_20180822-224635.jpg   AT&T Wi-Fi Calling Found! (Oreo)-screenshot_20180822-224623.jpg  
    Last edited by Rando3000; 08-23-18 at 11:01 AM.
    sorgo and gouger05 like this.
    08-23-18 02:23 AM
  2. sorgo's Avatar
    good catch! you definitely have some good hacking skills
    08-23-18 11:06 AM
  3. megafan2000's Avatar
    I managed to do that on my KEY2 on T-Mobile using Nova just now. It was already toggled on but my KEY2 has not made a single Wi-Fi call yet in the month I've had it, so pretty sure the Wi-Fi Calling doesn't work on Oreo on either. I haven't downloaded Oreo on KEY1 yet though as I didn't get the update as of this morning.
    08-23-18 11:38 AM
  4. ksloth's Avatar
    Did this with my ATT KeyOne, but when I go to enable it I get an "entitlement failed" ... I guess I don't have it on my plan, or perhaps I'm just being too entitled!
    john_v likes this.
    08-23-18 12:13 PM
  5. pooyam's Avatar
    I managed to do that on my KEY2 on T-Mobile using Nova just now. It was already toggled on but my KEY2 has not made a single Wi-Fi call yet in the month I've had it, so pretty sure the Wi-Fi Calling doesn't work on Oreo on either. I haven't downloaded Oreo on KEY1 yet though as I didn't get the update as of this morning.
    Try going on airplane mode, then enabling wifi. Then wait and see if it'll enable wifi calling.
    08-23-18 12:39 PM
  6. psychofox13's Avatar
    I managed to do that on my KEY2 on T-Mobile using Nova just now. It was already toggled on but my KEY2 has not made a single Wi-Fi call yet in the month I've had it, so pretty sure the Wi-Fi Calling doesn't work on Oreo on either. I haven't downloaded Oreo on KEY1 yet though as I didn't get the update as of this morning.
    I got Oreo on K1 (Unlocked SE) on AT&T and mine shows the same. It shows toggled on, but it has never worked.
    08-23-18 12:42 PM
  7. pooyam's Avatar
    I did this on my TMo K1 but when I click on About it'll take me to the Att page lol
    08-23-18 12:46 PM
  8. gouger05's Avatar
    Tested and works! Thanks OP!
    Rando3000 likes this.
    08-23-18 09:30 PM
  9. JAL1's Avatar
    I tried several times to toggle it on. I received a message at bottom of screen "Entitlement Failed."

    I am using the AT&T Branded KeyOne. Suggestions?
    08-23-18 10:23 PM
  10. DanylW's Avatar
    I tried several times to toggle it on. I received a message at bottom of screen "Entitlement Failed."

    I am using the AT&T Branded KeyOne. Suggestions?
    Yup, same for me. "Entitlement Failed"
    08-24-18 12:42 AM
  11. jagr32's Avatar
    me too ... anyone .... for the money I pay ... I should be ... entitled ... imjussayin
    john_v likes this.
    08-24-18 12:50 AM
  12. wilkto's Avatar
    I'd never heard of WiFi calling so I did some checking here in the UK. My network provider does not offer the service, only 7 of the 17 service providers offer WiFi calling.
    08-24-18 03:50 AM
  13. RLeeSimon's Avatar
    Tested and works! Thanks OP!
    Would you specify what kind of plan and how it works? If you shut off your GSM calling, will it allow calls? How do you know it's on wifi?
    08-24-18 05:18 AM
  14. gouger05's Avatar
    It established fine and said setup was successful. It showed the wifi calling icon in the status bar. I may have jumped the gun on the testing claim, will check further. On ATT unlimited plan with family.
    08-24-18 08:37 AM
  15. gouger05's Avatar
    I just checked my ATT account online and it's active.

    AT&T Wi-Fi Calling Found! (Oreo)-capture.png
    08-24-18 02:11 PM
  16. Chuck Finley69's Avatar
    Did this with my ATT KeyOne, but when I go to enable it I get an "entitlement failed" ... I guess I don't have it on my plan, or perhaps I'm just being too entitled!
    Same for me .....
    08-24-18 05:18 PM
  17. Chuck Finley69's Avatar
    I just checked my ATT account online and it's active.

    Click image for larger version. 

Name:	Capture.PNG 
Views:	74 
Size:	45.1 KB 
ID:	439474
    Is your device AT&T carrier locked Space Black or the factory unlocked?
    08-24-18 05:20 PM
  18. RoseBud68's Avatar
    I tried several times to toggle it on. I received a message at bottom of screen "Entitlement Failed."

    I am using the AT&T Branded KeyOne. Suggestions?
    Same here. Will have to check my AT&T account.
    08-24-18 06:18 PM
  19. mvsalvino's Avatar
    I managed to do that on my KEY2 on T-Mobile using Nova just now. It was already toggled on but my KEY2 has not made a single Wi-Fi call yet in the month I've had it, so pretty sure the Wi-Fi Calling doesn't work on Oreo on either. I haven't downloaded Oreo on KEY1 yet though as I didn't get the update as of this morning.
    I can confirm WiFi calling does work on T-Mobile. I have it set to cellular preferred, but if I am down to 1 bar it will usually switch over to WiFi when making or receiving a call.

    Turn on airplane mode, turn on WiFi, and it should pop up.
    08-24-18 06:28 PM
  20. gouger05's Avatar
    AT&T carrier-locked space black
    08-24-18 06:36 PM
  21. elcheapodeluxe's Avatar
    I'm on AT&T Postpaid (small business multi-line). KeyONE is an unlocked north american SE purchased from Amazon. Wi-Fi calling said it was already on with this setting. Flipped it off and back on. No error, but no Wifi calling icon, and if I try to make a call in airplane mode with wifi turned on I am then told I must turn off airplane mode to make a call - so pretty sure it isn't working even though it shows "enabled".
    08-24-18 06:50 PM
  22. gouger05's Avatar
    Mine doesn't work in airplane mode either. Below is a screenshot of the icon. I'm still not sure it's working.
    Attached Thumbnails AT&T Wi-Fi Calling Found! (Oreo)-img_20180824_180816.jpg  
    08-24-18 07:11 PM
  23. Rando3000's Avatar
    What does the Wi-Fi Calling notification say when you slide down to open Quick Settings? The reason I ask is because when I had the same icon on my menu bar and I opened the Quick Settings, it displayed an error regarding Wi-Fi Calling. (See my original screenshot for visual)
    08-24-18 11:34 PM
  24. gouger05's Avatar
    Here ya go
    Attached Thumbnails AT&T Wi-Fi Calling Found! (Oreo)-screenshot_20180825-072133.jpg  
    08-25-18 08:23 AM
  25. scrannel's Avatar
    FWIW Oreo, on Motion, will allow Wifi-calling while in airplane mode, on T-Mo.
    08-25-18 10:32 AM
51 123

Similar Threads

  1. Oreo on hold?!
    By gjh1978 in forum BlackBerry KEYone
    Replies: 53
    Last Post: 06-23-19, 08:23 PM
  2. battery monitor with Oreo and keyboard issue
    By tegowner in forum BlackBerry KEYone
    Replies: 2
    Last Post: 08-22-18, 08:49 PM
  3. Wifi calling on KeyOne vs. Key2
    By yybenedb in forum BlackBerry KEY2
    Replies: 2
    Last Post: 08-22-18, 10:30 AM
  4. Why is my battery draining so fast, since I got Oreo?
    By robertssanz in forum Ask a Question
    Replies: 0
    Last Post: 08-21-18, 10:42 PM
  5. Why is my battery life drainning so fast since I got new Android Oreo?
    By CrackBerry Question in forum Ask a Question
    Replies: 0
    Last Post: 08-21-18, 10:17 PM
LINK TO POST COPIED TO CLIPBOARD