09-23-17 08:51 AM
46 12
tools
  1. Smokeaire's Avatar
    Cool, and as my suggestion is for there to be an option for it, you can still keep preferring to do it that way...
    Options are always good.
    08-05-17 06:28 AM
  2. slagman5's Avatar
    Yep agreed. The option should be there but I also understand why they did it.

    For now, I can easily hide it with the on-screen option. It has become a muscle memory thing. I really don't want to lose the on-screen VKB for swiping though, that works like a charm in those situation when you can't use the PKB.

    Yes we bought the phone for PKB and that's what it's used for primarily however we live in 2017 and the on-screen keyboards have evolved and can supplement in some cases.
    Nah, I only prefer vkb's on years that end with a 4... On every other arbitrary year I still prefer to do everything on the pkb. Lol. If adding steps to things that already work is "the future" then maybe we need to rethink whether newer is better in that case
    08-09-17 07:59 PM
  3. Jaktspindel's Avatar
    Well, this sucks. I bought my KeyOne less than a week ago after finally retiring my old companion Nokia E6. Of course I value a smooth working pkb a lot, otherwise I had bought another phone. I write mostly in Swedish, I write a lot, and need quick access to åäö/ÅÄÖ, so I made sure it was possible to change sym + o l $ / i k m to these charachters before purchase. Now with this update it is a complete mess. I guess this goes for all Nordic and German speaking users.

    Does anyone know if there is a another workaround allowing access to umlauts using ONlY the pkb combining no more than two keys? I tried the word replace function, eg $$ -> ö, but it does not work neither in text messages, nor in the browser.
    08-19-17 08:23 AM
  4. Ulferini Schusterotti's Avatar
    Update to the latest beta of the keyboard, this fixed the issue.
    08-19-17 09:41 AM
  5. Dino84's Avatar
    Yes the sticky sym-key is killing my keyone-experience aswell. (Swedish user)
    And it is inconsistent with the Shift and Alt keys...

    Update to the latest beta of the keyboard, this fixed the issue.
    How can I apply this update? Thanks
    08-24-17 12:26 PM
  6. TheBond's Avatar
    Seems like the new keyboard update has resolved the issue.

    Now if you want to continuously input symbols, either you keep the Sym key pressed or use on-screen characters.
    08-25-17 06:21 PM
  7. Dino84's Avatar
    Hmm, at first when I tried this morning for some reason I was stuck with not only a sticky sym-view, but also CAPPED, and when picking a letter it would automatically pop to the second sym-layout which is of no use to me.

    So, 4 or 5 presses to get an å ä or ö.

    However, just now after checking the mail a few minutes later, the issue seems magically resolved, and the sym-key is non-sticky and non-capped. Very odd. I hope it stays like this...
    08-26-17 06:19 AM
  8. lobstaj's Avatar
    Hmm, at first when I tried this morning for some reason I was stuck with not only a sticky sym-view, but also CAPPED, and when picking a letter it would automatically pop to the second sym-layout which is of no use to me.

    So, 4 or 5 presses to get an å ä or ö.

    However, just now after checking the mail a few minutes later, the issue seems magically resolved, and the sym-key is non-sticky and non-capped. Very odd. I hope it stays like this...
    Got the update today. I was going to celebrate, because I was suffering from the previous behaviour.

    But unfortunately it'll go to that broken state which you noticed when I type a capitalized umlaut, for example 'Ä'. First of all the sym layout won't disappear after that (same problem as when holding the sym-key down was the way to do it).

    But the worse problem is, I'm not able to enter little umlauts anymore until I change the app. It'll only enter capitalized umlauts, no matter what the shift indicator states and no matter how many times I toggle it.

    The only workaround for that seems to be to press the shift first, then sym and the back button to make the sym layout go away. After that the sym key will work normally again. Until you enter another capitalized umlaut... A pain in the *beep* it is. Disabling auto-capitalization will not fix it, btw.

    UPDATE: The weirdest workaround to that problem with enabled auto-capitalization is this. When you're in the beginning of a sentence (i.e. just finished the last sentence by pressing a dot) and want to type a capitalized umlaut, press shift, which will make the shift indicator GO AWAY. Then just normally type sym followed by e.g. 'ä'. I'll actually capitalize the 'Ä', sym will disappear right away and you can continue to type umlauts normally.
    @Blackberry There's not much missing to get that bug fixed... :-)
    Last edited by lobstaj; 08-27-17 at 03:35 AM.
    08-27-17 03:06 AM
  9. Dino84's Avatar
    Ah thats the same issue as me then. Interesting workaround, however annoying. Once I forget to do the shift-workaraound, the messed up sym key will stay messed up for the entire message.

    So to summarize, auto-capitalization messes with the sym view and function.
    08-27-17 08:13 AM
  10. lobstaj's Avatar
    Ah thats the same issue as me then. Interesting workaround, however annoying. Once I forget to do the shift-workaraound, the messed up sym key will stay messed up for the entire message.

    So to summarize, auto-capitalization messes with the sym view and function.
    Unfortunately, for me this happens also with auto-capitalization disabled when capitalizing manually in the beginning of a word.
    08-27-17 09:30 AM
  11. LiamQ's Avatar
    We haven't been able to reproduce this. Does anyone have clear steps to reproduce it? It's also helpful to mention your device, input language, BlackBerry Keyboard version, and any custom settings for the Keyboard.
    08-28-17 10:56 AM
  12. lobstaj's Avatar
    @LiamQ Steps to reproduce:

    1. Create a custom sym layout with 'ä' on the 'a' key.
    2. Choose "Show custom sym layout first" (not sure if necessary)
    3. Make sure auto-capitalization is enabled (in order to be able to reproduce both auto-cap and manual-cap versions)
    4. Open the Blackberry Notes application, create a new note. Click on 'additional notes'.
    5. Press sym to show your custom sym layout
    6. Press 'a' to insert an auto-capitalized 'Ä' umlaut
    BUG: Sym layout does not go away
    EXPECTED: Sym layout is closed

    7. Close the sym layout by pressing the triangle back button
    8. Type 'm' or any other character
    9. Press sym to show the custom sym layout
    10. Type 'a'
    BUG: Capital 'Ä' umlaut is inserted even though shift was not on and we're in the middle of a word
    EXPECTED: Little 'ä' umlaut is inserted
    NOTE: Sym layout is closed
    NOTE 2: Opening the sym layout again and pressing shift will not insert a little 'ä' umlaut either

    11: Press shift followed by sym followed by the back button. This makes the keyboard return to a correct internal state. I.e. you can enter little umlauts again after that.
    12. Insert a space
    13. Press the shift key
    14. Continue from step 5. to see the same bugs as before without auto-capitalization. Alternatively, switch off auto-capitalization completely and repeat necessary steps.

    Device: Keyone
    Build number: AAM481
    Input language: Any of German, English, Finnish (does not seem to affect this bug)
    BB keyboard version: 3.0.0.12459
    No special keyboard settings as far as I can recall.

    Let me know if you need more information.
    gizmo21 and Dino84 like this.
    08-29-17 12:41 PM
  13. gizmo21's Avatar
    @LiamQ , please also check this ^ also for PRIV and AAN335 and additional languages before releasing a bugfix.
    Last edited by gizmo21; 08-30-17 at 12:07 AM.
    08-29-17 10:59 PM
  14. LiamQ's Avatar
    @LiamQ Steps to reproduce:
    ...
    Thanks so much for the detailed report! That was extremely helpful.

    We have a fix in code review now.
    Dino84 and gizmo21 like this.
    09-01-17 06:54 PM
  15. lobstaj's Avatar
    Thanks so much for the detailed report! That was extremely helpful.

    We have a fix in code review now.
    You're welcome. Hope you get the fix out soon.
    09-02-17 04:25 AM
  16. Dino84's Avatar
    Thats great.

    The biggest flaw of the keyone soon to be fixed

    Fingers crossed!
    09-02-17 10:13 AM
  17. LiamQ's Avatar
    The fix is now available on Google Play in Keyboard 3.0.0.12606.
    gizmo21 likes this.
    09-07-17 11:53 AM
  18. gizmo21's Avatar
    Anyone tested already?
    09-07-17 04:02 PM
  19. gizmo21's Avatar
    Took the plunge and so far it seems SYM close works so I have same behaviour for Umlauts as on 2.7.0.
    No problem with Caps-only bug or other Umlaut troubles. Thx to LiamQ and the team.

    If anyone needs something tested, just ask.

    STV100-4 (Aug17 patch), QWERTZ, DE/UK dual lang setup, keyboard 3.0.0.12606 (17-09-06)
    09-08-17 12:38 PM
  20. lobstaj's Avatar
    Same here, confirmed to be fixed in 3.0.0.12606 .
    gizmo21 likes this.
    09-09-17 05:22 AM
  21. Dino84's Avatar
    I just had an auto update and the issue seems to be resolved at a first glance atleast. Sweet!
    09-23-17 08:51 AM
46 12

Similar Threads

  1. Contacts app is not working properly
    By Ahmedgamel in forum BlackBerry Android OS
    Replies: 8
    Last Post: 10-03-17, 10:10 PM
  2. Cyrillic keyboard broken after update.
    By metrobrutal in forum BlackBerry Android OS
    Replies: 2
    Last Post: 07-25-17, 01:03 AM
  3. Passport to Keyone
    By The Kel in forum BlackBerry KEYone
    Replies: 4
    Last Post: 07-24-17, 07:35 AM
  4. Replies: 1
    Last Post: 07-23-17, 02:55 PM
  5. Register KEYone with Google Find My Phone in case...
    By charogne in forum BlackBerry KEYone
    Replies: 0
    Last Post: 07-23-17, 02:23 PM
LINK TO POST COPIED TO CLIPBOARD