1. Kazuki454's Avatar
    As much as I love the keyone! I've only had it for 4 weeks and have had nothing but reception issues I've tried wiping the phone factory resetting it and tonight I completely lost all signal I can't even get the radios to come on I've even tried different Sims and the phone errors saying it can't find any towers well I guess I'll call Hackberry and go through the warranty process I even had to do this for my classic this is such a disappointment. I really do love this phone.
    08-16-17 02:34 AM
  2. spantch101's Avatar
    You had bad reception with the classic? Where do you live and what carrier do you use? Here in Canada all the major carriers having a tower share deal so rarely ever lose service anymore, I drive across this massive country and use my classic when I have poor reception with my g5

    Posted with my good ol reliable classic
    08-16-17 06:55 AM
  3. HostessCupcake's Avatar
    As much as I love the keyone! I've only had it for 4 weeks and have had nothing but reception issues I've tried wiping the phone factory resetting it and tonight I completely lost all signal I can't even get the radios to come on I've even tried different Sims and the phone errors saying it can't find any towers well I guess I'll call Hackberry and go through the warranty process I even had to do this for my classic this is such a disappointment. I really do love this phone.
    https://forums.crackberry.com/blackb...blems-1118045/
    Kazuki454 likes this.
    08-16-17 10:49 AM
  4. BB-JAM215's Avatar
    ... I drive across this massive country and use my classic when I have poor reception with my g5.
    It could be that your G5 is always looking for LTE in remote areas with less coverage and your network preference settings are different on the Classic.
    08-16-17 11:03 AM
  5. spantch101's Avatar
    It could be that your G5 is always looking for LTE in remote areas with less coverage and your network preference settings are different on the Classic.
    No I typically turn off lte when travelling if am looking to get good signal, both the classic and g5 keep a stronger signal on hspa+ and battery life lasts much longer in my experience. Speed is negligible when you are struggling to get service. My classic does genuinly seem to keep more bars and I've never had signal issues with either phone but in some remote parts of nortern ontario I can safely say the classic kept getting messages while the g5 would die off trying to keep a bar

    Posted with my good ol reliable classic
    08-16-17 11:17 AM
  6. chain13's Avatar
    As much as I love the keyone! I've only had it for 4 weeks and have had nothing but reception issues I've tried wiping the phone factory resetting it and tonight I completely lost all signal I can't even get the radios to come on I've even tried different Sims and the phone errors saying it can't find any towers well I guess I'll call Hackberry and go through the warranty process I even had to do this for my classic this is such a disappointment. I really do love this phone.
    What is the network your phone mostly poor on? LTE or 3G? A phone could have poor reception at some radio bands and stronger at some others. And maybe your keyone is weak at the bands your carrier currently using.
    08-17-17 04:39 AM
  7. Kazuki454's Avatar
    Yeah I've seen that
    08-17-17 10:46 AM
  8. Kazuki454's Avatar
    I have T-Mobile and it's everywhere it's progressively gotten worse so I called blackberry and there sending me a RMA so I can get this phone fixed on another note WiFi calling works great also I've tired different Sims from att like a said it won't even search for towers.
    08-17-17 10:50 AM

Similar Threads

  1. Z30 (STA100-2) on fresh 10.3.3.2205 weak signal.
    By 1337anon1337 in forum BlackBerry 10 OS
    Replies: 16
    Last Post: 08-17-17, 09:39 AM
  2. Warranty Issue with DTEK50
    By bravowisky in forum BlackBerry DTEK50
    Replies: 7
    Last Post: 08-16-17, 05:38 AM
  3. Truecaller issues with KEYone
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 08-14-17, 03:06 PM
  4. KEYone issues
    By androacct in forum BlackBerry KEYone
    Replies: 9
    Last Post: 08-14-17, 08:32 AM
  5. Replies: 1
    Last Post: 08-13-17, 11:13 AM
LINK TO POST COPIED TO CLIPBOARD