1. Kitadashi's Avatar
    I was using the KeyOne for only like 2 days, until I noticed some serious problems with my unit, I'm now wondering if anyone experienced the same stuff and already turned in his KeyOne for repairs (preferably from europe or germany and even using the same provider)?

    (1) Bad Signal, no Mobile Data available, etc.

    At first I didn't quite notice myself, but after several calls and people complaining about not understanding or not hearing me at all, I thought I'd do a self test and called myself, tested with several phones, and it looks like sometimes I'm not even able to make a phone call at all. Sending SMS sometimes took several hours to finally be sent. Also, mobile data didn't work at all sometimes, even when the display shows 3G/4G, I can't browse the net, send e-mails or do anything else.

    Note: It should not be the SIM-cards or providers fault, since I tested the same SIM card in three different phones without any problems at all, including a BlackBerry Priv and a BlackBerry Classic.

    (2) Serious overheating

    I was using Maps for about 15 minutes, didn't have any other apps open at the time, it was quite chilly (14° C / 57° F) and I was not charging the device, only holding it in my hand. After quite some time the phone got so hot, I literally burned my palm at the metal part on the left-bottom side. My Priv also was getting quite warm sometimes, but then I got the notification saying "Device cooling down" and it never got so hot, that it felt uncomfortable to hold it in my hand. Never thought it would be so dangerous to use a phone and hold it in your hands. (Exploding phones aside.)
    07-26-17 01:35 PM
  2. Dunt Dunt Dunt's Avatar
    Signal issues can affect power usage and heat build up.

    Was probable just a bad unit.
    07-26-17 03:29 PM
  3. Kitadashi's Avatar
    Was probable just a bad unit.
    I really hope so, since It's a great phone. Hope all the wait will be worth it and I'll get a good unit.
    07-26-17 03:37 PM
  4. muindor's Avatar
    I really hope so, since It's a great phone. Hope all the wait will be worth it and I'll get a good unit.
    Always a gamble with BlackBerry.

    As a side note: O2 has rubbish signal in Germany. Especially when you move away from the city centre.

    07-26-17 03:38 PM
  5. Kitadashi's Avatar
    As a side note: O2 has rubbish signal in Germany. Especially when you move away from the city centre.
    Heard that a lot from friends living far away. Though in my area I never had any signal issues with any phones.
    07-26-17 03:41 PM
  6. stlabrat's Avatar
    did you brought the phone locally? or imported from other country?
    07-26-17 07:37 PM
  7. Kitadashi's Avatar
    Bought in my country, since we have QWERTZ-keyboard.
    07-27-17 01:52 AM
  8. Kitadashi's Avatar
    Just a heads-up:

    I've sent in my KeyOne on 28th July. I received a "Yep, we received your phone!"-mail on 1st August.

    I still don't have my KeyOne back. Support told me, that they'd have to replace a part that would take quite some time for them to get their hands on. Oh well...
    09-09-17 02:47 AM
  9. elfabio80's Avatar
    Just a heads-up:

    I've sent in my KeyOne on 28th July. I received a "Yep, we received your phone!"-mail on 1st August.

    I still don't have my KeyOne back. Support told me, that they'd have to replace a part that would take quite some time for them to get their hands on. Oh well...
    Es tut mir leid for you man. You can try to contact again BlackBerry Mobile via Twitter with a strong message, and maybe they will provide you an update. It is not tolerable this poor of customer service. Episodes like this create problems to the brand image. There are no justification, apart for fanboys...

    Posted via CB10
    FF22 likes this.
    09-09-17 03:37 AM
  10. FF22's Avatar
    Just a heads-up:

    I've sent in my KeyOne on 28th July. I received a "Yep, we received your phone!"-mail on 1st August.

    I still don't have my KeyOne back. Support told me, that they'd have to replace a part that would take quite some time for them to get their hands on. Oh well...
    I, too, recommend recontacting BB Mobile at their support number. More than a month should really not be acceptable for a repair. They should replace the unit in a quicker fashion.
    09-09-17 12:56 PM
  11. Kitadashi's Avatar
    I'm in a weird situation right now. I bought the phone from Otto. Otto told me to send the phone to a service center called "Siegmann + Schröder Technik GmbH" (SISC), and they sent my phone to BlackBerry Mobile Support (BBM).

    This week I contacted BBM about my KeyOne. They told me I need to contact my retailer, Otto. Aaand they told me I need to contact SISC for further assistance. And SISC keeps telling me that the phone is still with BBM, that BBM is waiting for parts to repair my phone and there'd be nothing SISC could do other than wait for it to be sent back to them.

    So... my situation right now is, I bought a phone for 600 € nearly two months ago, and I'm still not able to actually use it. What bugs me the most is that the Black KeyOne is already out and the Silver KeyOne is already priced at 549 € now, 50 € less than what I bought it for...
    09-17-17 02:17 AM
  12. Taigatrommel's Avatar
    Sad to hear TCL doesn't handle this any better than BlackBerry directly. When I bought my Classic back then, I had to send it in not less than three times due to ongoing malfunctions and problems. The usual turn-around time was four to six weeks. With four weeks being the fastest. IMHO for such a new and still pretty expensive device, it should be a service goal of TCL to return a working phone to the customer within two weeks.

    Back than I bought the phone from a reliable german online store, they would receive the damaged phone, send it to BlackBerry (or a maybe some contracted service center) and have to wait until they are getting it back. I, as a customer, had zero insights into the whole progress and the store itself said they can pretty much do nothing either than waiting for BBRY to return the repaired unit.
    09-17-17 08:12 AM
  13. Kitadashi's Avatar
    Okay, update.

    tl;dr: Got my money back. Got a black KeyOne now, that is working so far (besides the missing notifications). Not sure if BlackBerry Mobile was responsible for the long wait.

    Okay, so... there have now been a total of 4 companies involved. Otto, Siegmann + Schröder (SISC), Brodos, and Protel Telekommunikation (Protel), the TCL service center in germany.

    After waiting one more week I contacted SISC again. After asking "Hey, so... I've been waiting for quite some time now. WHERE actually is my phone now?" and they told me that they've sent it to a company called Brodos; and guess what? Brodos said that they would've sent the phone to Protel. Well, okay, I thought... I called Protel, told them my IMEI and they said something like "We've never seen this phone!". I have then contacted Otto and SISC again, told them "Hey, that's weird, but looks like my phone just disappeared?" and 3 days later I received my money back from Otto...

    I have no idea now if anything of what happened was actually BBM's/TCL's fault. I'm just happy that at least I got my money back. I bought a Black KeyOne now and so far it's working great, besides that I'm not getting any notifications, which hopefully will be fixed with the September Update.
    09-25-17 02:03 PM
  14. stlabrat's Avatar
    strange. i thought TCL/BBM would want every faulty phone back, especially the one has unique problem to do FA...how can it disappeare? with legit IMEI number? soon or later it will surface... get black listed...
    09-25-17 05:04 PM

Similar Threads

  1. Part for Blackberry Passport
    By Yuzry Yusoff in forum BlackBerry Passport
    Replies: 5
    Last Post: 07-27-17, 02:00 PM
  2. KeyOne and the Whatsapp LED notification? Need help, pls
    By DevilRon in forum BlackBerry KEYone
    Replies: 1
    Last Post: 07-27-17, 03:45 AM
  3. BB10 File manager on KEYone!
    By TranceRomance in forum Ask a Question
    Replies: 5
    Last Post: 07-26-17, 03:14 PM
  4. keyone camera not working
    By michaelsean14 in forum Ask a Question
    Replies: 1
    Last Post: 07-26-17, 12:44 PM
LINK TO POST COPIED TO CLIPBOARD