1. sqlt's Avatar
    Hey, guys. Sorry to be the guy asking for all the help recently.

    I rebooted my K1 this morning, and when it came back up, it had the following error:
    keyone sd card has been removed or built-in
    I've rebooted the phone, and reinserted the sd card, a handful of times, but I still get the same error message. I'm not sure if there's a way to try and reset the sd card (I didn't have a lot on there at this point in time). Even if there was, I'm not sure the phone would even recognize the card at this point.

    Thanks for any tips!
    09-12-18 08:46 PM
  2. FF22's Avatar
    Hey, guys. Sorry to be the guy asking for all the help recently.

    I rebooted my K1 this morning, and when it came back up, it had the following error:


    I've rebooted the phone, and reinserted the sd card, a handful of times, but I still get the same error message. I'm not sure if there's a way to try and reset the sd card (I didn't have a lot on there at this point in time). Even if there was, I'm not sure the phone would even recognize the card at this point.

    Thanks for any tips!
    If there's anything valuable on the card, back it up.

    Try reformatting it in the phone or in a computer (or another phone). Tried another card? Brand? Size?

    Have you tried the hard reset?

    Press and Hold the Power Button for 32+ seconds ignoring the screen and any sounds or vibrations.
    09-13-18 12:33 AM
  3. sqlt's Avatar
    If there's anything valuable on the card, back it up.

    Try reformatting it in the phone or in a computer (or another phone). Tried another card? Brand? Size?

    Have you tried the hard reset?

    Press and Hold the Power Button for 32+ seconds ignoring the screen and any sounds or vibrations.
    I tried reformatting the SD card, and it said "complete" but then when I checked in storage, it shows as corrupt. I tried a different SD card, and the same thing. Any time I format it, regardless of format/set-up options, it shows as corrupt.

    I tried a factory reset and the hard reset (32 sec), but it's still doing the showing corrupt, regardless of formatting on both SD cards.

    Is this an issue with the OS, my phone? Is it possible both SD cards are actually corrupt (they were both working then just stopped all of the sudden).

    Thanks.
    09-14-18 08:22 PM
  4. Soapm's Avatar
    SD cards do go bad, did you try them in a PC?
    FF22 likes this.
    09-14-18 08:41 PM
  5. FF22's Avatar
    I tried reformatting the SD card, and it said "complete" but then when I checked in storage, it shows as corrupt. I tried a different SD card, and the same thing. Any time I format it, regardless of format/set-up options, it shows as corrupt.

    I tried a factory reset and the hard reset (32 sec), but it's still doing the showing corrupt, regardless of formatting on both SD cards.

    Is this an issue with the OS, my phone? Is it possible both SD cards are actually corrupt (they were both working then just stopped all of the sudden).

    Thanks.
    It could be a hardware problem. As suggested above, have you tried reading them in a computer or another phone?
    09-15-18 12:00 AM
  6. sqlt's Avatar
    It could be a hardware problem. As suggested above, have you tried reading them in a computer or another phone?
    I have and can't read the SD, but it's only a year old. I didn't think it would go bad that quickly.
    09-15-18 07:33 AM
  7. Emaderton3's Avatar
    I have and can't read the SD, but it's only a year old. I didn't think it would go bad that quickly.
    It is odd. I have had the same one for over 5 years.
    09-15-18 07:48 AM
  8. thurask's Avatar
    Is this an issue with the OS, my phone?
    What OS are you on? If I remember correctly some older builds had issues with SD cards, but that should have gone away by now. If you're on something recent and it still happens then your SD reader itself might be the cause.
    09-15-18 07:53 AM
  9. sqlt's Avatar
    What OS are you on? If I remember correctly some older builds had issues with SD cards, but that should have gone away by now. If you're on something recent and it still happens then your SD reader itself might be the cause.
    I updated to oreo ~3 weeks ago, and then did a factory reset on the phone 2 weeks ago. SD card worked fine for 9 days or so, and then I've began having issues with it on Wednesday after a reboot on my phone.
    09-15-18 10:25 AM
  10. mandony's Avatar
    There is a BB app on some OS called Support Center (with a heart icon)
    There you can do a Quick Diagnostics of the SIM (and other stuff)
    09-15-18 06:57 PM
  11. sqlt's Avatar
    There is a BB app on some OS called Support Center (with a heart icon)
    There you can do a Quick Diagnostics of the SIM (and other stuff)
    Thanks. I'll check that out.
    09-16-18 11:43 AM

Similar Threads

  1. IPhone XS or KEY2 which one you will choose?
    By shehab Al Ghazali in forum BlackBerry KEY2
    Replies: 280
    Last Post: 10-15-18, 05:48 PM
  2. When is the red KEY2 LE coming out in Germany?
    By SuperFister in forum BlackBerry KEY2 LE
    Replies: 3
    Last Post: 10-02-18, 11:59 AM
  3. KEYone Oreo update in India
    By Sathish S in forum BlackBerry KEYone
    Replies: 7
    Last Post: 09-22-18, 11:21 PM
  4. Why not selected messages or mail in save folder in blaclberry keyone
    By CrackBerry Question in forum Ask a Question
    Replies: 0
    Last Post: 09-13-18, 11:46 AM
  5. Hub x Gmail (or Outlook) app
    By aluiziomachado in forum BlackBerry HUB+ Suite
    Replies: 1
    Last Post: 09-12-18, 01:39 PM
LINK TO POST COPIED TO CLIPBOARD