08-06-17 06:13 PM
33 12
tools
  1. thurask's Avatar
    Newer loader: https://forums.crackberry.com/blackb...loader-1117851

    DISCLAIMER: This is untested, and I have no guarantee if this will work. You have been warned.

    https://mega.nz/#!rAdkRbDD!OOtKU_G8L...iS4i-zLtf1cQd0

    Above is, hopefully, an autoloader for OS AAM481 for all KEYones. Thanks to TCL slipping up here and there, the raw files (radio, OEM partition, etc) for all KEYone variants, released or unreleased, have been made available. This 7z file consists of those raw files, plus hand-modified versions of the flashall scripts common to autoloaders, so that it can read the device details via fastboot and load the right files accordingly. Therefore, it shouldn't matter if you have a carrier version or an unlocked version, GSM or CDMA, black or silver, it should work.

    Since I don't have a KEYone, and even if I had one it would only be one version, that's why I'm asking for those with KEYones and a bit of spare time to try loading this and see if it works. Especially welcome are contributions from those with Sprint KEYones, to see if I got the OEM partition checking right, and unlocked CDMA KEYones, since they're still on an OS from like three months ago.

    The procedure should be the same as any other autoloader for a BB Android device, i.e. download, extract, plug in your phone (in fastboot mode), and run the .bat/.sh file. It will wipe your phone, of course; this is an autoloader after all.

    Reply here and tell us if and how it works.

    Edit: If you want to try this without wiping your phone (still, back up!), consider this:

    If anybody tries this, please remove the line about the "securewipe" and the line about flashing "userdata" and try it like this first (dirty flash). It could probably make the update without erasing all userdata.
    Last edited by thurask; 08-06-17 at 06:14 PM.
    08-05-17 02:30 PM
  2. bunky1971's Avatar
    Thurask, it won't come across through text, but a HUGE thanks to you, Contite and the other coders that keep us berryheads up on the newest releases!!
    08-05-17 02:35 PM
  3. mbirth's Avatar
    If anybody tries this, please remove the line about the "securewipe" and the line about flashing "userdata" and try it like this first (dirty flash). It could probably make the update without erasing all userdata.
    08-05-17 03:04 PM
  4. selimpusat's Avatar
    [QUOTE=thurask;12981669]DISCLAIMER: This is untested, and I have no guarantee if this will work. You have been warned.

    https://mega.nz/#!rAdkRbDD!OOtKU_G8L...iS4i-zLtf1cQd0

    Above is, hopefully, an autoloader for OS AAM481 for all KEYones. Thanks to TCL slipping up here and there, the raw files (radio, OEM partition, etc) for all KEYone variants, released or unreleased, have been made available. This 7z file consists of those raw files, plus hand-modified versions of the flashall scripts common to autoloaders, so that it can read the device details via fastboot and load the right files accordingly. Therefore, it shouldn't matter if you have a carrier version or an unlocked version, GSM or CDMA, black or silver, it should work.

    Since I don't have a KEYone, and even if I had one it would only be one version, that's why I'm asking for those with KEYones and a bit of spare time to try loading this and see if it works. Especially welcome are contributions from those with Sprint KEYones, to see if I got the OEM partition checking right, and unlocked CDMA KEYones, since they're still on an OS from like three months ago.

    The procedure should be the same as any other autoloader for a BB Android device, i.e. download, extract, plug in your phone (in fastboot mode), and run the .bat/.sh file. It will wipe your phone, of course; this is an autoloader after all.

    Reply here and tell us if and how it works.[/QUOTE @thurask
    Please find a solution to the following notification problem
    08-05-17 03:06 PM
  5. thurask's Avatar
    Please find a solution to the following notification problem
    You'll have to wait for BlackBerry to fix it, it's present in any build AAL964 or newer. This isn't the thread for that regardless.
    08-05-17 03:07 PM
  6. thurask's Avatar
    If anybody tries this, please remove the line about the "securewipe" and the line about flashing "userdata" and try it like this first (dirty flash). It could probably make the update without erasing all userdata.
    Good idea. I'll edit the first post.
    mbirth likes this.
    08-05-17 03:09 PM
  7. citystars41's Avatar
    @thurask downloading now. ill try it out shortly
    08-05-17 04:17 PM
  8. citystars41's Avatar
    Good idea. I'll edit the first post.
    What's a good backup app? Is there anything that backs up all apps instead of having to install them manually?
    08-05-17 04:44 PM
  9. thurask's Avatar
    What's a good backup app? Is there anything that backs up all apps instead of having to install them manually?
    Nothing can do a complete backup without root, unfortunately. If the app has developers that care and a recent enough API level it should hook into Google's automatic Drive-based app backup, if the app itself doesn't have a backup function. If it does connect to Drive, though, then installing apps should happen automatically once you log back in to your Google account.
    08-05-17 04:44 PM
  10. hoytbowhunter's Avatar
    Do you just install it with the mega link?
    08-05-17 04:58 PM
  11. thurask's Avatar
    Do you just install it with the mega link?
    You'll need a computer, but at least you can use a Mac or Linux machine with Android loaders.
    08-05-17 04:59 PM
  12. jcrutchvt2010's Avatar
    You'll need a computer, but at least you can use a Mac or Linux machine with Android loaders.
    I'll give it a go with my cdma keyone. What was the trick for determining pull URL?
    08-05-17 05:30 PM
  13. thurask's Avatar
    I'll give it a go with my cdma keyone. What was the trick for determining pull URL?
    I didn't. AAM481 comes from someone running the TCL desktop updater and saving the zip file it downloads (h/t @citystars41).
    08-05-17 05:31 PM
  14. Kumba42's Avatar
    If anybody tries this, please remove the line about the "securewipe" and the line about flashing "userdata" and try it like this first (dirty flash). It could probably make the update without erasing all userdata.
    Can confirm that manually flashing each partition via flashboot, in the order specified, but without "oem securewipe" OR the "userdata" partition does work to go back a build. Am now running the AAM481 build. However, definitely still seeing the issue with Android dropping Exterminatus on my recent apps and their background processes. Anyone know where to find an AAL964 autoloader? That build definitely had a lot less issues for me.
    08-06-17 12:52 AM
  15. Kumba42's Avatar
    Can confirm that manually flashing each partition via flashboot, in the order specified, but without "oem securewipe" OR the "userdata" partition does work to go back a build. Am now running the AAM481 build. However, definitely still seeing the issue with Android dropping Exterminatus on my recent apps and their background processes. Anyone know where to find an AAL964 autoloader? That build definitely had a lot less issues for me.
    It looks like AAL093 is a total no-go on T-Mobile/GSM. It won't even detect the SIM card, see the baseband modem (reports as unknown), or find a working cell signal. In my attempt to fix that, I temporarily hard-bricked the phone (white LED blinks three times, pause, repeats; no screen power on or vibration). To break out of that, had to pry the back of the phone off, unscrew the battery connector, and de-energize it, then while holding PWR+VOL_UP (yes, up, not down), plug the USB cable in. That got me to a fastboot screen where I was able to flash back to AAM481.

    So it looks like I am stuck with the notification bug now unless someone can find an AAL964 autoloader.

    **Note: Did not wipe the device before backrevving to AAL093 -- could be something goofy in /data that prevents the SIM card from getting detected. Everything works fine on AAL964 and up, however.
    08-06-17 03:19 AM
  16. thurask's Avatar
    An AAL964 autoloader would require the help of someone with a KEYone that has AAL964 as the latest OTA software, but I think that window has passed.
    08-06-17 08:16 AM
  17. jcrutchvt2010's Avatar
    An AAL964 autoloader would require the help of someone with a KEYone that has AAL964 as the latest OTA software, but I think that window has passed.
    FYI, CDMA owners AAM is working for me just modify the flashall script to flash USA modem, devcfg.mbn, and oem_common to be safe. I have had token issues so the flash all script as-is couldn't validate the loader so I took out that check. The full script I used is available in the keyone upgrade tool thread.
    08-06-17 09:35 AM
  18. thurask's Avatar
    FYI, CDMA owners AAM is working for me just modify the flashall script to flash USA modem, devcfg.mbn, and oem_common to be safe. I have had token issues so the flash all script as-is couldn't validate the loader so I took out that check. The full script I used is available in the keyone upgrade tool thread.
    There should only be two in vivo configurations for the BBB100-3:
    1. devcfg.mbn, oem_common.img, NON-HLOS-usa.bin (unlocked)
    2. devcfg.mbn, oem_sprint.img, NON-HLOS-usa.bin (Sprint)


    If anyone here has a Sprint KEYone I'd appreciate the output of

    fastboot getvar device
    fastboot getvar variant
    fastboot getvar subvariant
    fastboot getvar hlos-sig-tag

    from a phone in fastboot mode and a PC with ADB/fastboot set up.
    08-06-17 09:47 AM
  19. jcrutchvt2010's Avatar
    There should only be two in vivo configurations for the BBB100-3:
    1. devcfg.mbn, oem_common.img, NON-HLOS-usa.bin (unlocked)
    2. devcfg.mbn, oem_sprint.img, NON-HLOS-usa.bin (Sprint)


    If anyone here has a Sprint KEYone I'd appreciate the output of

    fastboot getvar device
    fastboot getvar variant
    fastboot getvar subvariant
    fastboot getvar hlos-sig-tag

    from a phone in fastboot mode and a PC with ADB/fastboot set up.
    Verizon CDMA output:
    fastboot getvar device: bbb100
    fastboot getvar variant: usa
    fastboot getvar subvariant: no result (shows "subvariant: ")
    fastboot getvar hlos-sig-tag: also blank
    08-06-17 09:57 AM
  20. thurask's Avatar
    Verizon CDMA output:
    fastboot getvar device: bbb100
    fastboot getvar variant: usa
    fastboot getvar subvariant: no result (shows "subvariant: ")
    fastboot getvar hlos-sig-tag: also blank
    Yeah, that's why loading the Verizon OEM image didn't work. That one requires your hlos-sig-tag and/or subvariant to be "vzw". The Sprint one should look the same except for "sprint" as hlos-sig-tag and/or subvariant.
    jcrutchvt2010 likes this.
    08-06-17 10:02 AM
  21. jcrutchvt2010's Avatar
    Request for Testers: AAM481 Autoloader-bootloader-vars.png
    Yeah, that's why loading the Verizon OEM image didn't work. That one requires your hlos-sig-tag and/or subvariant to be "vzw". The Sprint one should look the same except for "sprint" as hlos-sig-tag and/or subvariant.
    Yeah full fastboot oem info out below. not much to be gained probably.
    thurask likes this.
    08-06-17 10:14 AM
  22. RadioTech's Avatar
    FYI, CDMA owners AAM is working for me just modify the flashall script to flash USA modem, devcfg.mbn, and oem_common to be safe. I have had token issues so the flash all script as-is couldn't validate the loader so I took out that check. The full script I used is available in the keyone upgrade tool thread.
    If you have the VZW variant, do you just run the autoloader or is there some other work around you have to do to get it to work?
    08-06-17 10:39 AM
  23. thurask's Avatar
    Yeah full fastboot oem info out below. not much to be gained probably.
    What was the error that came up when running the script?
    08-06-17 10:49 AM
  24. jcrutchvt2010's Avatar
    What was the error that came up when running the script?
    Something like the loader could not be verified for your device. I will look up in the script the exact words.
    08-06-17 11:17 AM
  25. jcrutchvt2010's Avatar
    If you have the VZW variant, do you just run the autoloader or is there some other work around you have to do to get it to work?
    I posted the edited flashall.bat script I used in the keyone update tool thread.
    08-06-17 11:21 AM
33 12

Similar Threads

  1. I'm Totally Trapped: No Time to Charge for Tonight !
    By DoctorNeutron in forum BlackBerry Priv
    Replies: 19
    Last Post: 08-31-17, 02:27 PM
  2. New(old) life for retired Z10
    By meilenstein in forum BlackBerry Z10
    Replies: 7
    Last Post: 08-07-17, 10:02 AM
  3. Replies: 2
    Last Post: 08-05-17, 12:14 PM
  4. my bb passport has being off for weeks and its not charging
    By paulId71 in forum BlackBerry Passport
    Replies: 1
    Last Post: 08-04-17, 12:00 PM
LINK TO POST COPIED TO CLIPBOARD