1. anon(870071)'s Avatar
    So got my K1 launch day on Rogers Wireless! Like most of us screen popped off and got an advance exchange via Canadian support channel!

    Here's the mystery! I did call to update the IMEI! The replacement Device does not have HD calling nor will it activate VOLTE despite the ims settings switched to green! Still shows "ims not connected" in settings! Called tech support to inquire about this to aslo make sure my calling features are all provisioned correctly!

    I thought about this and despite getting a replacement, I lost some feature sets that should be functioning in the device!!! I am super p'oed about this!!! So I get an new replacement and then I lose a feature set!!! Not impressed!

    The tech guy I spoke with checked with level 2 support and apparently my account is provisioned correctly and that the August update will re-activate HD calling and VOLTE!

    I thought reloading the os and doing a factory wipe will re-activate but it didnt!!!!

    If the Aug update won't fix this issue, I will see blood!!!
    Last edited by cellphonejunkey; 08-22-17 at 12:09 AM.
    08-21-17 10:53 PM
  2. Bla1ze's Avatar
    If the Aug update won't fix this issue, I will see blood!!!
    So violent.
    08-22-17 12:23 AM
  3. anon(870071)'s Avatar
    So violent.
    I know right!!!! I should have just brought it in to a level 1 service center here in Vancouver and re-sealed the screen! My original device was functioning just fine no issues! I hate getting refurbished units as these slightly off-issues can happen! I've experienced this (not same issue) quite a bit in my long history using mobile devices! It's a Rogers locked replacement I got as well so hopefully As per the tech guy I called in and spoke with, the Aug update will fix this!
    08-22-17 12:33 AM
  4. anon(870071)'s Avatar
    OK Aug update done and gone still Nada! Called tech support and they told me my Sim card was not provisioned for VOLTE or HD calling! They want me to get a new sim!
    Will follow up when I get the new sim card!
    08-23-17 01:08 PM
  5. anon(870071)'s Avatar
    Went to a Rogers+ store changed sim, geuss what no change still no VOLTE and HD calling!!!
    08-23-17 04:02 PM
  6. anon(870071)'s Avatar
    I feel like I'm in the twilight zone! there's absolutely nothing wrong with the replacement device except for this little issue of not having VOLTE and HD calling! Tech support said changing sim will correct this and it hasnt!!!!
    08-23-17 04:04 PM
  7. anon(870071)'s Avatar
    great just called tech support and my replacement device is a "non Rogers supported device" that's wif WiFi calling ,HD calling and VOLTE won't work!!!!!! I should have just resealed the screen myself and kept my old device!!!
    08-23-17 04:22 PM
  8. FF22's Avatar
    great just called tech support and my replacement device is a "non Rogers supported device" that's wif WiFi calling ,HD calling and VOLTE won't work!!!!!! I should have just resealed the screen myself and kept my old device!!!
    Clearly, BB Mobile or their support outfit needs to know the origin of the phone before shipping off any old gsm replacement.
    08-23-17 04:55 PM
  9. anon(870071)'s Avatar
    I know that was my exact thought. Don't get me wrong there is absolutely nothing wrong with the device otherwise. It works amazing. Seems more solidly built too. Despite adding the IMEI to my account and updating to the latest Aug update. NADA. I've ordered another device directly from Rogers. I can't have non access to these functions.
    08-23-17 06:20 PM
  10. ToniCipriani's Avatar
    I know that was my exact thought. Don't get me wrong there is absolutely nothing wrong with the device otherwise. It works amazing. Seems more solidly built too. Despite adding the IMEI to my account and updating to the latest Aug update. NADA. I've ordered another device directly from Rogers. I can't have non access to these functions.
    Just out of curiosity, did you try to see if your replacement phone is unlocked (i.e. putting another carrier's card in it)?

    I figured given the mess the situation is and TCL is scrambling to repair and replace (there's even a report about someone being sent an old stock unit, and like clockwork the screen separated on that replacement), they might've slipped that process and gave you a non-carrier one. I mean it happened back then with BlackBerry too, there was one report about an unlocked variant 1 Priv being a replacement for a locked variant 3, it was reported somewhere in these forums.
    08-23-17 09:19 PM
  11. anon(870071)'s Avatar
    Good point not sure if it unlocked! there's no way to check unless a diff sim is put in! The only logical explanation is that they sent me an unlocked non Rogers device flashed as an NA version!
    Last edited by cellphonejunkey; 08-24-17 at 02:18 PM.
    08-24-17 04:31 AM
  12. anon(870071)'s Avatar
    Thank God for Nathan @RogersHelps I suspected adding the IMEI to the Rogers database will initialize VOLT, HD calling and WiFi calling!!!! Despite numerous calls to tech support to "whitelist" my "non Rogers device imei" Nathan submitted a ticket to have this done!!!! Such a gong show!!!!! Even a level 2 tech didn't think about this!? Basically crackberry forums was the "ONLY" Channel where I got a clear answer! And with Nathan's help submitting a ticket to add the IMEI to Rogers internal device database; problem solved!!!!! Why did it take this long!?
    FF22 likes this.
    08-25-17 12:11 PM
  13. anon(870071)'s Avatar
    Thank God for Nathan @RogersHelps I suspected adding the IMEI to the Rogers database will initialize VOLT, HD calling and WiFi calling!!!! Despite numerous calls to tech support to "whitelist" my "non Rogers device imei" Nathan submitted a ticket to have this done!!!! Such a gong show!!!!! Even a level 2 tech didn't think about this!? Basically crackberry forums was the "ONLY" Channel where I got a clear answer! And with Nathan's help submitting a ticket to add the IMEI to Rogers internal device database; problem solved!!!!! Why did it take this long!?
    OK here's a follow up! On a whim I wanted to try something! I took a completely active sim from another device and stuck it into mine! Miraculously it activated VOLTE, and now have video calling and HD calling!!!!

    And also updated the account with another IMEI, one from a Rogers device!!!! Now it's working!

    Update; a few hours later my line disconnected at the switch level!? And then it reverted back to "ims not connected" !is it an issues if the device imei(rogers device) shows up on two lines on my account!?!? Would that also affect provisioning!?
    Last edited by cellphonejunkey; 08-26-17 at 05:44 AM.
    FF22 likes this.
    08-26-17 01:27 AM
  14. anon(870071)'s Avatar
    This is becoming more of a headache more than anything.
    08-26-17 12:34 PM
  15. anon(10252394)'s Avatar
    please post photo array of "blood" as it becomes available.

    my device has dimly backlit uhvijbikn keys, but I won't exchange because I fear junk replacement returned covered with slime from prior infected owner...
    08-26-17 12:53 PM
  16. ToniCipriani's Avatar
    This is becoming more of a headache more than anything.
    Are you having reception issues that you absolutely need Wi-Fi calling?
    08-26-17 03:28 PM
  17. IvanTheTolerable's Avatar
    I still have no information about my replacement. How long did it take for you to get the new one?
    08-26-17 06:11 PM
  18. anon(870071)'s Avatar
    I don't need wifi calling but the provisioning is wifi calling, VOLTE calling and HD calling!
    08-26-17 09:21 PM
  19. anon(870071)'s Avatar
    what a ÷±•™¿±}\ headache!!!!! because the replacement device is showing up as a "non Rogers device" on their internal system it won't activate any of these prior features I had to my locked to Rogers device!
    At the end of the day I got another RW device and new Sim and now all working fine! The build date is July 28/17, out of pocket!
    Last edited by cellphonejunkey; 08-27-17 at 12:55 PM.
    FF22 likes this.
    08-26-17 09:24 PM
  20. mhw100's Avatar
    What were actually using those features for? I don't notice any difference when they're on or off. I have the RW and an unlocked device. Calls are the same. Maybe video is better?
    09-01-17 11:54 AM
  21. Shane8750's Avatar
    Funny, I got my replacement delivered end of day Friday and noticed IMS setting not connected. But this replacement also has an issue with 5ghz wifi network, and not pulling in a strong signal. Where I had full coverage around my apartment, now I barely get 1 to 2 bars and a low throughput speed on tests. Only full when I hold it inches above my router. I've been on the phone with them, lucky I still have my original 'screen popper' as I'm unhappy this replacement lacks my original wifi capabilities.


    And now, as for IMS, I just put Sim back into original device, and it now says 'connected'

    This is pathetic. I expected maybe a refurb. device, and I have enjoyed blackberry phones since the Pearl days, but to have a replacement that lacks capabilities on so many levels is just not right.

    A tech from BlackBerry Mobile is supposed to call me tomorrow as higher up techs were off Friday evening to Sunday so we shall see what the word is. To say I'm unhappy with this experience is un understatement. I have case/protector since first week I got device, I baby the sh*t out of it, and the screen literally just fell forward one day, luckily not coming loose and breaking off. Will IMS work on eventually with calls to Rogers support?

    *sigh*
    Last edited by Shane8750; 09-04-17 at 12:51 AM. Reason: nothing has changed,
    09-03-17 11:01 PM
  22. Shane8750's Avatar
    An update to last night's message, i used this wonderful tool that BB Mobile has for reloading software.... low and behold, VoLTE is active and working. No drop down to 4G, fast connect time. But wifi in 5ghz still low. at least that solves one issue i will have with next replacement
    FF22 likes this.
    09-04-17 09:38 AM
  23. anon(870071)'s Avatar
    can you share how and what method you used to get VOLTE working!?
    portplayer likes this.
    09-05-17 03:35 AM

Similar Threads

  1. Dtek in other devices?
    By mad_orsi in forum Android Apps
    Replies: 9
    Last Post: 11-16-17, 10:21 PM
  2. Rock bottom BlackBerry OS10 devices a steal for low end plans.
    By swm11091959 in forum Community Reviews
    Replies: 6
    Last Post: 11-07-17, 07:28 PM
  3. Replies: 2
    Last Post: 08-27-17, 03:06 PM
  4. Replies: 10
    Last Post: 08-21-17, 09:33 PM
  5. stv 100-3 Asia Pacific devices
    By rkp10001 in forum BlackBerry Priv
    Replies: 6
    Last Post: 08-21-17, 01:30 PM
LINK TO POST COPIED TO CLIPBOARD