1. JLagoon's Avatar
    Hi folks,

    I manage to get the keyone. I popped in the SIM card from my Z30, and it worked--everything, 4G, LTE, Wifi Calling, Internet, voicemail, text etc.. After restarting the keyone, it says, "No Service." I tried removing the SIM card, and putting it back; restarting; calling TMobile to update the IMEI, etc. No deal.

    TMobile adviced to get a new SIM card.

    Do you guys have any experience with this? Perhaps Priv owners?

    Thank you.
    06-06-17 10:04 PM
  2. Jared DiPane's Avatar
    I moved my SIM over without an issue. that being said, my dad switched his SIM from one phone to another recently and same thing happened. he got a new card and no issues since.
    06-06-17 10:14 PM
  3. JLagoon's Avatar
    It is working now.

    I don't remember the exact sequence of steps, but here are what I did.

    I went to access points menu, and selected tmobile gprs.

    I went to carriers, and chose automatic registration.

    I noticed that wifi calling option can be enabled. So, I enabled it. The 4G icon appeared. Afterwards, I chose wifi only for calls (the first option). The volte icon appears.

    I tried restarting the phone, and cycling through various wifi, airplane mode, and cellular on/off. Things are fine so far.
    jamesharmeling and rkanazawa like this.
    06-06-17 10:44 PM
  4. Techno-guy's Avatar
    Z30 SIM sounds pretty old. You may want to see if T-Mobile will give you a newer one. For some reason, some of the older SIM's have various connection troubles. Glad it is working for you, though.
    06-06-17 11:16 PM
  5. cornbread0715's Avatar
    Happens to mine and a few others I know as well I have not had the error in about 4-5 days now. I have also gotten the SD card error twice so watch for that that one as well.
    06-07-17 02:02 AM
  6. Adam Frix's Avatar
    It is working now.

    I don't remember the exact sequence of steps, but here are what I did.

    I went to access points menu, and selected tmobile gprs.

    I went to carriers, and chose automatic registration.

    I noticed that wifi calling option can be enabled. So, I enabled it. The 4G icon appeared. Afterwards, I chose wifi only for calls (the first option). The volte icon appears.

    I tried restarting the phone, and cycling through various wifi, airplane mode, and cellular on/off. Things are fine so far.
    I was having signal problems, so tech support first suggested that I get a new SIM. I did. Then they had me follow the instructions that they post online for creating an APN for Galaxy S8. I did, and signal problems got better.

    The APNs that my original SIM created, weren't right.
    06-07-17 03:09 AM
  7. hoopitz's Avatar
    I just woke up to this same issue and I'm on T-Mobile, as well. It says I have no service, and when i go to make a call, it tells me to turn off Airplane mode. I know that the sim card isn't the issue because I popped it back into my Passport, and it worked just fine.

    I enabled WiFi calling and that seemed to pop up the 4GLTE icon at the top, although it's grayed out, and not showing me how much signal I have. I disabled WiFi calling, and it seems like I'm able to make calls now. I'm hoping all goes back to normal soon.
    07-08-17 11:36 AM

Similar Threads

  1. Anyone using a smart watch with KEYone?
    By bold007 in forum BlackBerry KEYone
    Replies: 129
    Last Post: 01-16-18, 09:28 AM
  2. Anyone else with a DEFECT free KeyOne?
    By tw1g_007 in forum BlackBerry KEYone
    Replies: 250
    Last Post: 07-16-17, 05:41 PM
  3. Why has NO CDMA KeyOnes Shipped? And When will they ship?
    By thoms333 in forum BlackBerry KEYone
    Replies: 26
    Last Post: 06-13-17, 05:16 PM
  4. Replies: 2
    Last Post: 06-07-17, 06:38 AM
  5. Get the job done with a wicked keyboard!
    By Matt Moes in forum BlackBerry KEYone
    Replies: 4
    Last Post: 06-06-17, 03:04 PM
LINK TO POST COPIED TO CLIPBOARD