1. SoxFan's Avatar
    Woke up this morning. Keyone battery was dead (while plugged in) and won't charge, despite changing chargers and outlets. I've also held down the power button for 30+ seconds to no avail.
    01-24-18 09:16 AM
  2. deezy87's Avatar
    Just a guess, but maybe the connectors got messed up somehow. I'd take it to a shop and get it looked at.
    01-24-18 09:34 AM
  3. SoxFan's Avatar
    Just a guess, but maybe the connectors got messed up somehow. I'd take it to a shop and get it looked at.
    What connectors...? It's still under warranty, but that's a pain.
    01-24-18 09:47 AM
  4. deezy87's Avatar
    Inside at the bottom, where the charger plugs in. Something may have effed up, don't take my word for it, that's what had happened to a buddy's device. That, I'm not too sure how it could've got damaged or whatever, I'm going to go out on a limb, and assume maybe dust or pocket lint.
    01-24-18 09:58 AM
  5. SoxFan's Avatar
    Thanks for the suggestion, but very clean in and around charging port.
    01-24-18 10:11 AM
  6. Sigewif's Avatar
    Woke up this morning. Keyone battery was dead (while plugged in) and won't charge, despite changing chargers and outlets. I've also held down the power button for 30+ seconds to no avail.
    Something similar happened to a family member's DTEK60 after it was on a charge all night. She said she had done the reboot but it didn't work. A while later I did the reboot and held it down for well over over 32 seconds, also holding the volume down button. Then that wonderful vibrate happened and it went into the boot up process and started. Maybe it just had to settle. I don't know what happened or what caused the problem.
    After it rebooted It turned out the battery actually had a charge.
    Anyway, it is worth a try after letting it sit for a while.
    01-24-18 10:37 AM
  7. SoxFan's Avatar
    Great idea. Didn't work.
    01-24-18 10:51 AM
  8. texn884's Avatar
    Call BB if its under warranty
    01-24-18 11:22 AM
  9. TheBond's Avatar
    Wild guess, but Samsung S8 also has issues with lithium battery reaching 0% and fail to charge after that. Perhaps your battery is failing to recover.
    01-24-18 07:55 PM
  10. SoxFan's Avatar
    I think that's what happened. now it's recovered. Now, the device won't recognize my SIM. grr.
    01-24-18 08:13 PM
  11. deezy87's Avatar
    Holy... one thing after another. I'd send it in for a replacement.
    01-24-18 08:58 PM
  12. ray689's Avatar
    I think that's what happened. now it's recovered. Now, the device won't recognize my SIM. grr.
    Did you try to take it out and put it back in?
    01-24-18 09:12 PM
  13. deezy87's Avatar
    Did you try to take it out and put it back in?
    The pulling out method, huh?

    Just trying to make some light of the situation.
    01-25-18 04:28 AM
  14. jazzdoctor's Avatar
    I have had the same problem across three KeyONe’s...bad luck or bad hardware...or am I using incorrect chargers...one keyone that had the problem i worked around it until the screen came off. Essentially the long press of the power and vol down work....when it hasn’t i have left it awhile and come back and it worked...at least 30 sec...sometimes it would not work if on the charger so took it off and did it...other times I had it on the charger (each time appears as a dead bberry). It’s still occurs and i know certain of my cables to avoid as the device will simply shut down when on them....crazy...I wish I did not love the keyboard...in fact i just did a reset as it became slow and buggy so all apps now on my s8+ and min on keyone....sad they underpowered this thing big time....
    01-31-18 12:53 PM

Similar Threads

  1. Keyone cache clearing
    By JWW in forum BlackBerry KEYone
    Replies: 19
    Last Post: 07-13-18, 07:18 AM
  2. WTS Blackberry Keyone GSM Unlucked
    By Al moon in forum Buy, Sell, Trade - Sold / Archived
    Replies: 21
    Last Post: 01-31-18, 06:16 PM
  3. Blackberry Keyone were to buy in Manila.
    By Jose Fores Po in forum BlackBerry KEYone
    Replies: 2
    Last Post: 01-25-18, 08:57 AM
  4. last dtek 60 won't update
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 01-24-18, 02:30 PM
  5. Replies: 7
    Last Post: 01-23-18, 08:21 PM
LINK TO POST COPIED TO CLIPBOARD