1. Zoeawar's Avatar
    Starting november 2nd my keyone has massive battery drain. Power saving mode does not work, I turn it on and the switch slides itself back to off instantly. When I unplug it the battery often says 100% all day unless its restarted, then it shows the actual level. Sometimes it wont accept a charge until I restart it. The battery center graph looks odd, but I dont know how to post a screenshot here. It only drains battery when wifi/cell data are in use. If its in airplane mode its fine, but the second wifi or cell data turn on the drain starts. My phone lasts about 4 hours without use, or 1-2 with. I have a battery app and a data app that relay which are using up everything, all background data is off. Before this my phone would run all day fine whether I used it or not, and still have 15-20% after 12 hours. But the other day there was no battery drain problem and I used it frequently, then the next day back to the same issue. The apps all had the same day to day data usage so what am I missing?
    11-22-19 10:47 AM
  2. Dunt Dunt Dunt's Avatar
    If you have installed any new apps, I'd remove or disable them.
    I'd look at data usage on WiFi and Cell see which apps are using it a lot.

    Have you tried a factory reset?
    11-22-19 12:17 PM
  3. mandony's Avatar
    I had a similar problem
    Easy solution was to install a new battery
    instructions are on YouTube
    I bought this one from Amazon for $20
    (label with Blackberry)
    UPplus BAT 63108-003 includes tool kit
    11-22-19 05:29 PM
  4. Zoeawar's Avatar
    I hadnt installed any new apps but I went ahead and deleted or disabled any that I dont use. The problem seems to be a software issue not the battery because it works fine on some days, and restarting the phone affects whether or not it will accept a charge. Some days the battery is fine and I use it all day without having to charge, then the next ill lose a 30 percent an hour. The battery light is on too sometimes after unplugging it. But the power center doesnt work, the percentages used by the battery never change even after phone is restarted and the power saving mode doesnt work at all. I click it on and the button switched itself back to off immediately. Ill see if I can attach a photo of the battery chart I dont think its supposed to look like that, I can replace the battery but I dont think thats the root of the issue.
    11-27-19 10:00 AM
  5. DanielDallas's Avatar
    whatsapp had a battery drain issue
    11-29-19 02:31 AM
  6. cbvinh's Avatar
    My KEYone used to last two days. Now, it needs charging by evening. I do think it's a software issue. Screen usage is down to 4h. BlackBerry Hub+ Services is 50+% of the battery usage. I don't have WhatsApp.
    11-30-19 08:25 AM
  7. Lionothundercat's Avatar
    Starting november 2nd my keyone has massive battery drain. Power saving mode does not work, I turn it on and the switch slides itself back to off instantly. When I unplug it the battery often says 100% all day unless its restarted, then it shows the actual level. Sometimes it wont accept a charge until I restart it. The battery center graph looks odd, but I dont know how to post a screenshot here. It only drains battery when wifi/cell data are in use. If its in airplane mode its fine, but the second wifi or cell data turn on the drain starts. My phone lasts about 4 hours without use, or 1-2 with. I have a battery app and a data app that relay which are using up everything, all background data is off. Before this my phone would run all day fine whether I used it or not, and still have 15-20% after 12 hours. But the other day there was no battery drain problem and I used it frequently, then the next day back to the same issue. The apps all had the same day to day data usage so what am I missing?
    I don't have this issue but I do notice the moment I take mine off charge at 100 percent it goes to 99 percent fairly quickly. Anyone else notice that?
    11-30-19 09:14 AM
  8. cbvinh's Avatar
    I don't have this issue but I do notice the moment I take mine off charge at 100 percent it goes to 99 percent fairly quickly. Anyone else notice that?
    What's your battery usage like?

    Mine:

    60%

    About 14h 47m left

    Last full charge 9h 30m ago (basically, my KEYone only lasts 24h now?)

    Screen usage since full charge 2h 46m

    BlackBerry Hub+ Services is the big usage app, but "While in active use" and "While in background" are both 0m. Battery usage 14%

    BBM, which I DON'T USE AT ALL, says "While in active use" 1h 24m and "While in background" 26m. Battery Usage 1%.
    12-01-19 02:04 AM
  9. the_boon's Avatar
    My KEYone used to last two days. Now, it needs charging by evening. I do think it's a software issue. Screen usage is down to 4h. BlackBerry Hub+ Services is 50+% of the battery usage. I don't have WhatsApp.
    BB Hub+ Services is a battery hog and most certainly the culprit
    12-01-19 02:12 AM
  10. cbvinh's Avatar
    BB Hub+ Services is a battery hog and most certainly the culprit
    I wasn't watching battery usage like a hawk before, since the KEYone lasted two days easy. I never looked into which apps used the most battery and even if Hub+ Services was a big user, it seems to be a bigger user now. And what's with BBM taking up battery when I don't use it at all?
    12-01-19 04:30 AM
  11. the_boon's Avatar
    I wasn't watching battery usage like a hawk before, since the KEYone lasted two days easy. I never looked into which apps used the most battery and even if Hub+ Services was a big user, it seems to be a bigger user now. And what's with BBM taking up battery when I don't use it at all?
    Did you disable BBM entirely?

    If not, do it, and it should not take up a single percent if it's disabled.

    I would also force stop and clear the cache for BlackBerry Hub+ Services if you even use the Hub or any of the BlackBerry apps.

    If you don't, just disable it too. That's what I do all on my DroidBerry's because I don't like any of those apps anyway and BlackBerry Hub+ Services is an annoying guzzler.
    12-01-19 11:30 AM
  12. cbvinh's Avatar
    Things are back to normal for me. BlackBerry Hub+ Services down to 1%. BBM still thinks it's always in use, but still 1% battery usage.
    12-07-19 10:38 PM

Similar Threads

  1. Replies: 3
    Last Post: 11-24-19, 10:52 AM
  2. BlackBerry KEYone PRD 63116-039
    By TSIAGO77 in forum Ask a Question
    Replies: 1
    Last Post: 11-21-19, 07:52 PM
  3. keyone soft update
    By PedroGebran961 in forum BlackBerry KEYone
    Replies: 4
    Last Post: 11-20-19, 07:59 PM
  4. Priv battery
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 11-20-19, 09:47 AM
  5. Picture from Camera on Motion shows BlackBerry Keyone stamp!
    By ashish_BB in forum BlackBerry Motion
    Replies: 3
    Last Post: 11-19-19, 01:57 PM
LINK TO POST COPIED TO CLIPBOARD