1. gnirkatto's Avatar
    Some of you might remember that I had troubles with reception on 4 different K1s, until I got #5 which seemed to be slightly improved in that field. Nonetheless I also had to get this one replaced, because it 'lost' the SD card. I was frustrated but not overly upset, such HW issues can happen.
    #6 is equally ok-ish in terms of reception (no LTE, 3G weak but no complete loss of signal), however, it also 'lost' my SD card (a Samsung Evo+ 128GB)!!!

    In order to figure out what was going on, I tried the following:

    I purchased another 128GB SD card ==> same as before, got 'lost' by the K1.
    I borrowed another 64GB card, freshly initialized ==> same as before, 'lost' by the K1.

    I found that after a card got lost, it almost instantly returned, so I almost never caught it to be completely gone, eg from file manager. So how did I notice it was 'lost'?:

    • Apps that used ringtones that were stored on the card suddenly defaulted back to their standard ringtones. After I moved the ringtones to internal memory, the problem was gone.
    • Music players (tried 2 different ones) 'lost' their playlists which where based on songs stored on the SD card. Couldn't move these to internal, for obvious reasons.
    • Onedrive came back asking if I wanted to include 'newly found' directories into the picture database; this reoccurred again and again for always the same directories on the SD card.
    • Once in a while, I noticed the K1's screen turning on, while lying on a table untouched, showing a message 'new SD card is being prepared' ==> so the card(s) always came back by themselves.


    All of this happened 2 to 3 times a day.
    To me it seems highly unlikely that 2 different K1s, with 3 different SD cards, show exactly the same problems. Could it be there is even one more HW flaw in the K1? The SIM/SD tray seems to be a little flimsier than the rest of the components, could that cause loose connection from time to time?
    Unfortunately, for me, this means I will have to return this K1 too - but this time I will go for a refund rather than a replacement. I had to go through too many issues which this phone, will wait and see what happens next. Still love form factor and concept.

    I wonder if others also experienced such SD card troubles. Maybe only people who actually HAD such troubles and/or have any other thoughts or questions on this issue want to reply? I understand the majority did not have this particular problem, so it's pointless to receive multiple confirmations on that here.

    BBB100-2 with AAO472
    09-24-17 09:23 AM
  2. terminatorx's Avatar
    I'm experiencing similar issues with a SanDisk 32gb sdxc card. It was working fine for a few days, then all of a sudden today the card is no longer seen. If I physically eject and reseat it, it appears and works ok for a while.

    Are we supposed to install any special driver, like the one app called 'MicrosoftexFAT for BlackBerry'?
    09-25-17 01:57 PM
  3. gnirkatto's Avatar
    Apparently, not a lot of people had these problems. Or maybe wrong forum - should have posted in the K1 support forum? Anyway, I forgot to mention that both K1s that had this problem were from the very same production date, August 16. One bad day in the factory, maybe?
    09-26-17 11:23 AM
  4. terminatorx's Avatar
    Just a quick update regarding the SD card issue I reported earlier. It turns out that the 32gb SanDisk SD card I was using is actually defective. It's hard to ascertain because sometimes the card works ok. But I tried it in another Android phone, and a Windows 10 PC, and all have given me issues. Once the SD card gets corrupted, it doesn't even show up when you reinsert or put it in other devices. If by fluke you get a device to see it and do a format, it works ok for a bit and then ultimately fails again.

    So in my case I'm happy to report that it wasn't an issue with my K1 after all. I am using a newer 64gb SanDisk card now, and haven't experienced any issues.
    FF22 likes this.
    09-27-17 11:22 AM
  5. gnirkatto's Avatar
    So it seems like I’m the only one....strange. 2 different K1s, 3 different SD cards, same problem.
    Bad for me, good for the K1’s reputation.
    09-27-17 02:18 PM
  6. johnnydoesai's Avatar
    you're definitely NOT the only one....there is a post with 300+posts in the keyone support ....so many people have this problem including me.

    but let me tell you this. tcl or blackberry mobile will ignore this issue. if I were you I would return this garbage as soon as I can and get something way way better for the same money. (like the s7 edge now or the one plus 5)

    hint: search "SD unexpectedly removed" in the k1 support forum
    gnirkatto likes this.
    09-28-17 11:20 AM
  7. gnirkatto's Avatar
    you're definitely NOT the only one....there is a post with 300+posts in the keyone support ....so many people have this problem including me.

    but let me tell you this. tcl or blackberry mobile will ignore this issue. if I were you I would return this garbage as soon as I can and get something way way better for the same money. (like the s7 edge now or the one plus 5)

    hint: search "SD unexpectedly removed" in the k1 support forum
    wow thanks for the hint - I searched but didn't find this other thread so I opened my own. Will hop over and continue there.
    09-28-17 01:08 PM

Similar Threads

  1. Fingerprint sensor not working on KEYone.
    By Abrysunny in forum BlackBerry KEYone
    Replies: 2
    Last Post: 10-11-17, 09:47 PM
  2. Can I set KEYone notification to vibration only?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 09-25-17, 10:19 PM
  3. KEYone accessories HELP!
    By icbaibic in forum BlackBerry KEYone
    Replies: 9
    Last Post: 09-25-17, 01:06 PM
  4. Replies: 2
    Last Post: 09-24-17, 11:42 AM
  5. Is the KEYone limited edition speaker equal to the original?
    By bashar hanini in forum Ask a Question
    Replies: 0
    Last Post: 09-24-17, 06:01 AM
LINK TO POST COPIED TO CLIPBOARD