1. jamiemarksberry's Avatar
    I was wondering if the verizon keyone really is that laggy. I would be coming from a classic. I've been looking at the LE but there is something about the keyone

    Posted via CB10
    10-26-18 11:24 AM
  2. coffee-turtle's Avatar
    I was wondering if the verizon keyone really is that laggy. I would be coming from a classic. I've been looking at the LE but there is something about the keyone

    Posted via CB10
    Try the suggestions in this thread:

    https://forums.crackberry.com/blackb...plore-1141374/
    10-26-18 02:33 PM
  3. rotorwrench's Avatar
    There can be several causes of lag, as there are posts where it's been resolved by deleting a particular app, cache cleaning, resets ...etc..
    but regardless, it's also obvious that lag is not an issue associated with all K1s based on the number of owners posting they haven't had any lag issues.

    While there's no doubt some are or have experienced lag, it is not a given that all K1s will experience it as a chronic issue.

    I've had my VZW compatible K1 for over a year as my work and personal phone and haven't had any lag issues except for an instance that lasted until I deleted an app that I had downloaded prior to the lag started. After deletion of the app I've had no other occurrences.

    I wouldn't hesitate to buy another K1 based on my prior experience.
    FF22 likes this.
    10-27-18 01:50 PM
  4. jamiemarksberry's Avatar
    has your keyone had good reception also on Verizon. i've heard of weak reception?
    10-27-18 03:48 PM
  5. jamiemarksberry's Avatar
    Also should I activate it by just swapping sim card out of classic to keyone or do it on Verizon site first with iema number?
    10-27-18 04:07 PM
  6. Kelvin Lau2's Avatar
    I was wondering if the verizon keyone really is that laggy. I would be coming from a classic. I've been looking at the LE but there is something about the keyone

    Posted via CB10
    As usual , mine also lag. 😂
    10-27-18 08:10 PM
  7. FF22's Avatar
    Also should I activate it by just swapping sim card out of classic to keyone or do it on Verizon site first with iema number?
    I've had mine for a year and a half. No lag that I'm aware of but maybe I'm just a sloth! (g)

    I've also not had any reception issues. While I live in Seattle with good overall service, the phone has also been in other areas of the US with fine reception as well as some small towns in Norway and Italy.

    If I recall, I just moved my sim from my Priv to the KeyOne. I did have to hit the Verizon site, if I recall, for HD calling? There is a Sticky above on doing that.
    10-29-18 10:00 AM

Similar Threads

  1. October security patch for KeyOne BBB 100-2
    By CrackPriv in forum BlackBerry KEYone
    Replies: 46
    Last Post: 11-30-18, 10:55 AM
  2. KeyOne; Hub not updating
    By robnic in forum BlackBerry HUB+ Suite
    Replies: 7
    Last Post: 11-19-18, 01:30 AM
  3. KEYone stuck in fastboot mode
    By spinky360 in forum BlackBerry KEYone
    Replies: 7
    Last Post: 10-30-18, 04:06 AM
  4. KeyOne rear battery cover
    By ralphslate in forum BlackBerry KEYone
    Replies: 4
    Last Post: 10-27-18, 11:48 AM
  5. KEYone Gmail
    By beamer67 in forum Ask a Question
    Replies: 0
    Last Post: 10-25-18, 03:44 PM
LINK TO POST COPIED TO CLIPBOARD