1. 1adam's Avatar
    I've setup all my word substitution shortcuts in BlackBerry keyboard settings menu. E.g abs = absolutely, idk = I don't know.
    I went through all of them to adjust the right capitalization setting. So for any names you force the capital letter, and for anything else it's context sensitive to being start of a new sentence or not. Great!

    It worked for days until my last restart and now all of the capitalization toggles have been reset to default again. That took me AGES to setup.

    Anyone got any ideas?
    Attached Thumbnails KEYone forgot shortcut settings-5425.jpg  
    05-22-17 05:30 AM
  2. TheBond's Avatar
    Mine still working fine after almost a month now.
    Hope you didn't clear cache for the keyboard somehow.
    05-22-17 06:44 AM
  3. VeryBumpy's Avatar
    Maybe turn off all updates. Might there have been some OS update that occurred which may have reset to default?
    05-22-17 06:47 AM
  4. 1adam's Avatar
    Maybe turn off all updates. Might there have been some OS update that occurred which may have reset to default?
    Mine still working fine after almost a month now.
    Hope you didn't clear cache for the keyboard somehow.
    Strange. I've gone nowhere near any app cache and haven't had any system updates. I can only link it to my first reboot in a little while. The substitutions are all intact but it's the capitalization flag/toggle that's all reset to "checked".
    I will go through and reset them all to the right context and pray it doesn't change again.
    05-22-17 03:41 PM
  5. gquan14's Avatar
    The first time it happened for me was w/ the Priv. I switched from Priv to DTEK60 through the content transfer and all of my word substitutions defaulted to lower case. So even by default the first letter is capitalized through a sentence, it will change it to lowercase if it's a match in word substitution. Highly annoying. Since there was wasn't a quick fix other than updating word for word, I simply decided to update the word or phrase as needed.
    05-22-17 04:21 PM
  6. 1adam's Avatar
    So I've just ran a test...
    1. Changed a few word substitutions to turn off the "capitalization" flag
    2. Backed out, checked still set, exited settings
    3. Rebooted via power key from home screen
    The flags were all reset again!

    This is clearly a bug and a very annoying one. How best to report it?
    Attached Thumbnails KEYone forgot shortcut settings-8307.jpg  
    05-22-17 04:35 PM
  7. gquan14's Avatar
    Same bug here. I've manually moved over all of my word substitutions (because moving them over from Priv to DTEK60 reset all the case sensitivity locks).. but lo and behold the same bug happens even then. This defeats the purpose of word shortcuts.
    06-11-17 04:23 PM
  8. isaiahb's Avatar
    I can confirm the same bug. Its annoying. Hopefully they will fix it with the next update.
    06-11-17 05:06 PM
  9. Polopoulos's Avatar
    Yep, I can also confirm the same bug :-(

    How come some people don't seem to be affected?
    No matter what i do, as soon as I reboot my KeyOne, all of my shortcuts in Word Substitution are reset with the "Always use this capitalisation" checked.
    Tried to remove some languages, add more words in my Personnal dictionary (both capitalised and non capitalised versions) but nothing worked.

    I'm also affected by the "shortcuts disappearing" at every reboot (have to add at least one each time, and then all the others previously stored appear again)...
    06-19-17 02:54 AM
  10. JellyGalaxy's Avatar
    I also have the same issue where my shortcuts just dissapear.
    Its only the long press shortcuts though the shortpress ones stay.
    It just happens after a while though and doesnt seem to be linked to restarting the phone.
    It's really annoying and for a 600€ phone i would really expect it to work flawlessly.
    Especially since the shortcuts are one of the main reason for me to buy this phone.
    I already wrote a message to the support but if this doesnt get fixed i wont keep this phone

    Edit: Ok this time they vanished after a restart but just the long hold shortkeys that are to call someone. Opening apps still works
    06-19-17 05:39 AM
  11. 1adam's Avatar
    I've been in contact with BlackBerry support lots. They know of the issue and said they'll push a fix out shortly. However my KEYone has just updated to latest update yesterday and the issue still prevails. This is crap.
    06-20-17 12:45 AM
  12. jordan5586's Avatar
    The priv had the same issue but it just reverted to lower case much more slowly. you'd have like 2 words a week go back to all lower case. if you wiped the phone and re-downloaded everything, then they would all be lower case. They never fixed that issue. I wouldn't hold your breath on it being fixed. They also don't have a search bar to jump to a word. Not to mention, if you want to uncheck the capitalization boxes, you have to scroll to the word, click it, uncheck it, back out, and you're right back at the top of the list. SOOOOOOOOO annoying. meaning, if you had 500 words, it would take you 12 hours to uncheck those boxes. It's ridiculous. BlackBerry was the first on the scene with autotext/word substitution and now they are falling behind even Apple with it. Crazy. Try using smart keyboard pro instead. In the settings turn on the "physical keyboard" setting and download your language pack. I.e. I also downloaded the separate app "English for Smart Keyboard Pro" and set up your word substitutions in THAT keyboard. they work perfectly
    gquan14 likes this.
    07-04-17 10:09 AM
  13. LVPBMW's Avatar
    Same happened to me now. That check box is checked for everything and now every sentence start reverts to lower case for the substitutes. What is the best way to report bugs directly to BB? My substitute list is huge and this is a major pain.
    07-06-17 07:42 AM
  14. LVPBMW's Avatar
    And to confirm, I modified a few of them and a reboot reset the flags high. Ugh.
    07-06-17 07:49 AM
  15. LVPBMW's Avatar
    I've got a ticket opened with Blackberry and will keep everyone posted. The tech support guy couldn't replicate the issue with his phone. We also confirmed app versions and did a different reboot - neither yielded anything insightful. I dumped the log files and sent through for their analysis. We'll see.
    07-07-17 11:14 AM

Similar Threads

  1. Honest review BlackBerry KEYone vs. S7 edge
    By 2high4u in forum BlackBerry KEYone
    Replies: 27
    Last Post: 01-02-19, 09:43 AM
  2. Replies: 9
    Last Post: 06-01-17, 07:08 PM
  3. Network tips on KEYone UK
    By Good Future in forum BlackBerry KEYone
    Replies: 10
    Last Post: 05-22-17, 05:04 PM
  4. Are there any KEYone live demo units in stores anywhere?
    By europolska00 in forum BlackBerry KEYone
    Replies: 2
    Last Post: 05-22-17, 07:55 AM
  5. KEYONE after ancient BlackBerry (2 questions )
    By DonnaDiva in forum BlackBerry KEYone
    Replies: 1
    Last Post: 05-21-17, 12:54 PM
LINK TO POST COPIED TO CLIPBOARD