1. Tommy-boy's Avatar
    I have a Keyone on Verizon and would like to block my caller ID when I certain calls. This was easy to do when I was using a BB10 Classic. Is there a setting somewhere I can check and uncheck to toggle btw showing and not showing my number?

    -Tom
    12-19-17 04:48 PM
  2. Bla1ze's Avatar
    In the Phone app, under Settings>Additional Settings.
    12-19-17 06:14 PM
  3. FF22's Avatar
    In the Phone app, under Settings>Additional Settings.
    NOT there on my Verizon model. I do see a Call Settings and under that something unexplained called "Voice Privacy" which can be checked or UNchecked.
    12-19-17 07:59 PM
  4. Bla1ze's Avatar
    NOT there on my Verizon model. I do see a Call Settings and under that something unexplained called "Voice Privacy" which can be checked or UNchecked.
    Wierd. Not sure then, wasn't aware VZW models were that different in that regard.
    12-19-17 10:26 PM
  5. Tommy-boy's Avatar
    Sadly "additional settings" is not a menu item on my K1 under phone settings. This kinda stinks as I can't be giving out my personal cell # to clients when I call them. Are there any apps that accomplish this that people like/trust?
    12-20-17 10:20 AM
  6. zephyr613's Avatar
    Wierd. Not sure then, wasn't aware VZW models were that different in that regard.
    Yes, anything VZW is inherently different

    Try going here:

    phone>settings>call blocking

    You can enter the Number you wish to block there. I am running 7.1.1, BB100-3 November 6th update (AAR108 and the setting is there for me.
    12-20-17 10:35 AM
  7. Bla1ze's Avatar
    Yes, anything VZW is inherently different

    Try going here:

    phone>settings>call blocking

    You can enter the Number you wish to block there. I am running 7.1.1, BB100-3 November 6th update (AAR108 and the setting is there for me.
    OP Not looking to block calls however. Looking to control caller ID to block their number from showing.
    12-20-17 10:36 AM
  8. Bla1ze's Avatar
    Sadly "additional settings" is not a menu item on my K1 under phone settings. This kinda stinks as I can't be giving out my personal cell # to clients when I call them. Are there any apps that accomplish this that people like/trust?
    You don't need an app. VZW can do it for you, just have to call them.
    12-20-17 10:37 AM
  9. zephyr613's Avatar
    OP Not looking to block calls however. Looking to control caller ID to block their number from showing.
    Sorry I misunderstood - carry on.
    12-20-17 10:37 AM
  10. Tommy-boy's Avatar
    You don't need an app. VZW can do it for you, just have to call them.
    I'd like this to be something I can toggle on/off at will. Most of my calls from my phone are personal - to family/friends, and they should see who is calling. About 10-15% of my cell phone calls are client related - and those are the ones I'd like to prevent caller ID on.
    12-20-17 03:01 PM
  11. rolfep's Avatar
    In the Phone app, under Settings>Additional Settings.
    Slightly longer path, here:

    In the Phone app, under Settings>Calls>Additional settings:

    Keyone - Block Caller ID?-1513820401124.jpg

    Not exactly a "toggle" but maybe some shortcut could be set up, idk.
    12-20-17 07:43 PM
  12. Bla1ze's Avatar
    Slightly longer path, here:

    In the Phone app, under Settings>Calls>Additional settings:

    Click image for larger version. 

Name:	1513820401124.jpg 
Views:	62 
Size:	53.6 KB 
ID:	432524

    Not exactly a "toggle" but maybe some shortcut could be set up, idk.
    You gave the same instructions I did, which are noted to not be available on VZW devices. lol
    12-20-17 07:52 PM
  13. rolfep's Avatar
    You gave the same instructions I did, which are noted to not be available on VZW devices. lol
    Well, there was another step in the path I gave, which I noted. Accuracy and precision are important when giving instructions, imo.
    12-20-17 08:05 PM
  14. FF22's Avatar
    Sorry I misunderstood - carry on.
    I'm trying to but the Port has not kicked in sufficiently! (g) But I did ski today so it should not take much.
    12-20-17 08:23 PM
  15. FF22's Avatar
    Well, there was another step in the path I gave, which I noted. Accuracy and precision are important when giving instructions, imo.
    Yes for accuracy but NO for Verizon in any event! It ain't there!
    12-20-17 08:25 PM
  16. curve8310's Avatar
    try to put #31 # before the number and see if it blocks it.
    I just tried that and it works, maybe that might work on vzw phone as well.
    12-20-17 09:24 PM
  17. Josh3's Avatar
    try to put #31 # before the number and see if it blocks it.
    I just tried that and it works, maybe that might work on vzw phone as well.
    This did not work for me. However, I tried *67 before the number and that worked. I am also using the Keyone on Verizon and all of the aforementioned instructions are inapplicable. "Additional Settings" are not in the call app anywhere.
    01-17-18 04:45 PM
  18. Tommy-boy's Avatar
    I have solved this issue and thought I'd follow-up with a post. I installed Hide Caller ID from Megapps Ventures. https://play.google.com/store/apps/d...pps.hidecaller

    This is a paid app, so there's no add nonsense (I wish all apps were this way). Easy to toggle on/off. There is a notification when on, which is a good reminder. Phone also vibrates just before making a call that has caller id blocked (another good reminder). For me, the ability to quickly bounce back and forth between on/off is great.

    -Tom
    01-23-18 11:13 AM
  19. Mastabattas's Avatar
    I have a new KeyOne, Dual SIM in Canada on Rogers' network. I am in the same boat and when I follow the above stated usual steps I also do NOT have the "calls" option under settings.

    Is this somehow related to the dual sim? Could it be something related to my google account that I've synced with the phone?

    I'm not a techie. But I follow direction well if anyone has any ideas.
    12-11-18 11:59 PM
  20. BBuso77's Avatar
    I have a new KeyOne, Dual SIM in Canada on Rogers' network. I am in the same boat and when I follow the above stated usual steps I also do NOT have the "calls" option under settings.

    Is this somehow related to the dual sim? Could it be something related to my google account that I've synced with the phone?

    I'm not a techie. But I follow direction well if anyone has any ideas.
    I have a Rogers KEYone and have the option to hide the number in phone settings.

    I am not sure but Rogers may require your plan to include a feature that is called: Call Display with Name Display or a similar feature. You should contact them because some plans will not allow certain features.
    12-12-18 10:45 AM
  21. Since2007's Avatar
    Try *67 before the number. *67-512-xxx-yyyy
    12-12-18 10:54 AM
  22. Mastabattas's Avatar
    Well I figured it out, and I was just being too literal. With the dual SIM, the option in settings is known as "calling accounts". I'm a dum dum. Image attached in case someone like me comes along later (clockwise).
    Keyone - Block Caller ID?-photostudio_1544923992707.jpg
    12-18-18 12:32 PM

Similar Threads

  1. Need help - audio/sounds with keyone
    By JWW in forum BlackBerry KEYone
    Replies: 5
    Last Post: 12-20-17, 07:18 PM
  2. Glove mode for KeyOne?
    By tmommy in forum BlackBerry KEYone
    Replies: 3
    Last Post: 12-20-17, 09:29 AM
  3. How do I block a phone #?
    By 1REDRUM in forum BlackBerry DTEK60
    Replies: 6
    Last Post: 12-19-17, 01:53 PM
  4. Cannot access KEYone folders when connected to computer
    By CrackBerry Question in forum BlackBerry Mobile Support
    Replies: 1
    Last Post: 12-19-17, 11:46 AM
  5. Just received my Keyone, impressions and asking for little tips
    By crowning73 in forum BlackBerry KEYone
    Replies: 6
    Last Post: 12-19-17, 10:49 AM
LINK TO POST COPIED TO CLIPBOARD