1. Nevalis's Avatar
    Guys,

    Thoughts on this one please; over the last 24 hours my beloved KeyOne has suddenly started running the battery down very quickly. this is in the order of 50% in 2 hours. I have done all the usual reboots, checked services etc and can find nothing significant. Similarly I am not using the device any more than usual, running any new apps nor operating in any different location.

    Any thoughts?

    Richard
    07-08-19 09:04 AM
  2. Tim-ANC's Avatar
    Guys,

    Thoughts on this one please; over the last 24 hours my beloved KeyOne has suddenly started running the battery down very quickly. this is in the order of 50% in 2 hours. I have done all the usual reboots, checked services etc and can find nothing significant. Similarly I am not using the device any more than usual, running any new apps nor operating in any different location.

    Any thoughts?

    Richard
    Have you checked app usage in your battery settings? Also the 3 dot on upper right of that page has option to check full device usage.
    07-08-19 09:12 AM
  3. the_boon's Avatar
    Yes I would think there's a bad app in there.

    I guess you can also try clearing the cache for the Google Play Services app.
    07-08-19 09:38 AM
  4. Nevalis's Avatar
    Thanks guys, "been there, done that". No change, but have noticed the device is now running hot, although everything is working as it should.
    07-08-19 10:10 AM
  5. Ecm's Avatar
    Thanks guys, "been there, done that". No change, but have noticed the device is now running hot, although everything is working as it should.
    Are you one of those affected by the cell service outages that have hit Europe and North America? Have you had dropped calls, etc? It may be that your device is working overtime trying to find a connection.
    07-08-19 11:44 AM
  6. Nevalis's Avatar
    No not cell issues. have killed all non-essential apps and phone is starting to cool down. Will let it run for a while then reboot and see what happens.

    Thanks for the suggestions.
    07-08-19 02:47 PM
  7. IceCreamPlz's Avatar
    try letting it go all the way down to 0, then wait 4 hours or so and then charge all the way up to 100. I had a similar issue. doing this seemed to re-calibrate the battery meter

    Although the high temp is telling of processor load.
    07-08-19 03:06 PM
  8. DonnaDiva's Avatar
    is your phone trying to update? My phone has done that twice in the past, both times an incomplete update seemed to be the culprit.
    07-08-19 10:36 PM
  9. BergerKing's Avatar
    Sometimes a glitch in an app, or even the device itself will present itself. Most of the time, I find a reboot of the phone will help reset the problem. I've seen it in computers and phones over the years. Once, a problem in my ex-wife's phone blew thru 8 gigs if data and battery like you wouldn't imagine, in a short amount of time.
    07-09-19 10:24 AM
  10. mandony's Avatar
    The biggest power hog is the camera app (no matter if you use the stock or other app.)
    After use close the camera with the 'clear all' function.
    Otherwise the camera will continue to draw power even if not used.

    Also go to the Power Center and close down non essential apps.
    07-09-19 08:04 PM

Similar Threads

  1. WTS: black edition blackberry keyone BB100-1
    By MB64 in forum Buy, Sell, Trade - Sold / Archived
    Replies: 30
    Last Post: 07-23-19, 08:18 AM
  2. Whatsapp eternal issue : To show or to not show on Hub?
    By aluiziomachado in forum BlackBerry KEY2
    Replies: 17
    Last Post: 07-13-19, 08:28 PM
  3. Instagram stuck on Login Screen
    By Shadowbolt in forum BlackBerry 10 OS
    Replies: 7
    Last Post: 07-11-19, 05:25 PM
  4. Chime on Bluetooth connection
    By Soapm in forum BlackBerry KEYone
    Replies: 1
    Last Post: 07-10-19, 09:13 AM
  5. RAM seems full keyone
    By chuck rund in forum Ask a Question
    Replies: 5
    Last Post: 07-08-19, 05:50 PM
LINK TO POST COPIED TO CLIPBOARD