Built for Business - Learn more about BlackBerry KEY2
  1. Nick6995's Avatar
    I love BlackBerry and have used their phones for years but I'm about ready to take my Keyone back to the Sprint store.

    This phone has had so many issues. It won't stay connected to the network which makes it hard to use many of my apps. I had to downgrade my 4g LTE down to 3g just to get some of the apps I use the most to work. But makes everything else run so slow.

    It freezes up way to often. I have to restart my phone several times a week.

    I'm going to try a factory reset to see if It will correct some of the issues.

    I hope the next phone be it the Keytwo or something else works a lot better.
    I'm terribly disappointed. Was so excited about getting the Keyone.
    macterp likes this.
    03-13-18 04:05 PM
  2. krazyatom's Avatar
    I am sure keytwo or whatever it's called will be vastly improved over current keyone. I would wait for next model.
    03-13-18 04:09 PM
  3. michaelakid's Avatar
    I am sure keytwo or whatever it's called will be vastly improved over current keyone. I would wait for next model.
    We have no idea when the next version is coming. He might need a new phone now.
    03-13-18 04:40 PM
  4. Thumb_er's Avatar
    I have two friends that brought the Sprint branded K1 and they have suffered similar connection problems. I'm using the unlocked CDMA version and haven't experienced any of these issues. Knock on wood...
    Sime0n_S likes this.
    03-13-18 04:47 PM
  5. supertom's Avatar
    Sounds like you may be having issues with Sprint. But also you may have gotten a defective unit as well. Have you found a pattern with the freezing? What are you doing that normally leads to a freeze?

    I usually reset my phone every time i charge it which is like every other day mostly and my KEYone rarely has any problems.

    i'm using the unlocked version on T-Mobile
    03-13-18 04:49 PM
  6. andreydagr8's Avatar
    Mabe it's just your phone because I have a standard se keyone and I don't have any of those issues mine works perfect but I do have an unlocked version and I'm on att
    03-13-18 09:31 PM
  7. meattray's Avatar
    I've noticed intermittent issues after using boost charge. it's really made it so my phone is slow afterwards and occasionally locks up. To me it almost seems like it's still doing something funny in the background and doesn't revert until I restart the device.

    I quit using boost charge and haven't had any issues the last few days. strange.
    03-13-18 10:22 PM
  8. ppeters914's Avatar
    I usually reset my phone every time i charge it which is like every other day mostly and my KEYone rarely has any problems.
    Seriously? Every other day? Never had to do that on my Torch 9800 or Z10 unless there was a problem.

    Hopefully, that's just your practice and not necessary for most K1 users.

    Pete
    AT&T /Z10 STL100-3 /10.3.3.3057
    03-14-18 02:20 PM
  9. supertom's Avatar
    Seriously? Every other day? Never had to do that on my Torch 9800 or Z10 unless there was a problem.

    Hopefully, that's just your practice and not necessary for most K1 users.

    Pete
    AT&T /Z10 STL100-3 /10.3.3.3057
    i restart it as a habit.. not because it is needed. it only takes like, less than a minute to boot up, so why not?
    psychofox13 and BigAl_BB9900 like this.
    03-14-18 03:12 PM
  10. FF22's Avatar
    i restart it as a habit.. not because it is needed. it only takes like, less than a minute to boot up, so why not?
    In Post #8 you said "RESET" instead of RESTART which might have caused confusion.

    edited to clarify: In Post 5 quoted in Post 8!!
    Last edited by FF22; 03-15-18 at 12:03 AM.
    rolfep and kbz1960 like this.
    03-14-18 09:16 PM
  11. stlabrat's Avatar
    (1) did you get a new sim or just stuck the old sim into your unit?
    (2) sounds like network issue. contact sprint (if you get unit from them... if you get from other source, double check compatibility... dual sim for example might not work well)
    (3) this is from website... check your apn setting or just go to sprint ask them to set up for you. https://apn.gishan.net/settings/1753...rry_keyone.php
    (4) best of luck. it does not feel like hardware/software issue on handset side based on your observation... IMHO.
    03-15-18 10:29 AM
  12. Drg84's Avatar
    Wow restarting it every 2nd day? I didn't even have to do that with my E71. In 2009. somethings wrong with that phone, and I'm leaning towards a sprint app. check the battery use. and memory use.
    03-15-18 05:23 PM
  13. 311BBerry's Avatar
    TS never came back to answer any questions so I wouldn't waste any more time until we know more.

    Kind of funny how he dumps on K1 when his symptoms seem more network provider related.

    I just got a KEYone from AT&T and have not experienced any of those issues and have not tried boost charging either - something doesn't seem right about it lol
    03-15-18 07:45 PM

Similar Threads

  1. I Miss My BlackBerry Passport. And it's never coming back
    By Shadowyugi in forum BlackBerry Passport
    Replies: 10
    Last Post: 04-10-18, 05:17 AM
  2. Optiemus KEYone doesn't download update!
    By SabarishElango in forum BlackBerry Mobile Support
    Replies: 8
    Last Post: 04-03-18, 05:56 AM
  3. Why are both my phones on different OS versions
    By hugrabow@gmail.com in forum BlackBerry Z30
    Replies: 4
    Last Post: 03-14-18, 07:49 PM
  4. Calendar support in KeyOne - is there an option?
    By siglerm in forum BlackBerry KEYone
    Replies: 2
    Last Post: 03-14-18, 12:42 PM
  5. BlackBerry Keyboard app updated with bug fixes and improvements
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 03-13-18, 03:30 PM
LINK TO POST COPIED TO CLIPBOARD