Built for Business - Learn more about BlackBerry KEY2
  1. StanVanDam's Avatar
    BBB100-1, Android 8.1.0, hardware version 05, build ABD796. Rogers-locked KEYone on Rogers network.

    Connected to LTE+, Data Saver = OFF, IMS = Connected, Voice Over LTE = ON, but the LTE Video Calling toggle switch underneath the Voice Over LTE toggle is greyed out in the OFF position and is not movable. APN settings are default and I have already tried resetting to defaults just to make sure.

    Diagnostic screen *#*#46368676#*#* shows VoLTE Provisioned = ON, but Video Calling Provisioned = OFF. Therefore, I no longer have the video calling button to the right of the normal dial button in my phone dialer and can't even try to initiate a video call, so there is no error message.

    LTE Video Calling worked fine on all Android 7 updates between January and August. The August Oreo update seemed to have killed my video calling.

    I have opened support tickets with Rogers and talked to both Tier 1 and Tier 2 tech support, none were able to diagnose the problem. They say it should be provisioned and don't know why the phone thinks it isn't.

    Does anyone know how I can force-enable Video Calling or have any other ideas to get it working again?

    IMS Connected and VoLTE on, how to force-enable LTE Video Calling?-screenshot_20180905-141254.jpgIMS Connected and VoLTE on, how to force-enable LTE Video Calling?-screenshot_20180904-152018.jpg
    Last edited by StanVanDam; 09-05-18 at 01:19 PM. Reason: Updated Phone Info screenshot
    09-04-18 02:23 PM
  2. silentbystander's Avatar
    Curious that your data service field says "Disconnected". Mine most definitely say connected, and video calling is provisioned.
    09-04-18 10:48 PM
  3. StanVanDam's Avatar
    The data service field says "Disconnected" whenever I am on WiFi. I can manually enable data connection via the 3 dots at the top or I can disconnect WiFi to enable it. I've updated the screenshot to reflect this.

    Does anyone know how to "reinstall" the same carrier-pushed update (ABD796) that I received over the air via Rogers Wireless, without doing a network or factory reset?
    09-05-18 01:22 PM
  4. psychofox13's Avatar
    The data service field says "Disconnected" whenever I am on WiFi. I can manually enable data connection via the 3 dots at the top or I can disconnect WiFi to enable it. I've updated the screenshot to reflect this.

    Does anyone know how to "reinstall" the same carrier-pushed update (ABD796) that I received over the air via Rogers Wireless, without doing a network or factory reset?
    You can use the ABD796 autoloader to reinstall, but it'll be a complete wipe of your device.
    09-05-18 02:01 PM
  5. StanVanDam's Avatar
    Following up on my Rogers-locked KEYone Oreo issues where IMS couldn't connect, Voice Over LTE immediately toggled off when trying to toggle on, Video Calling greyed out and untogglable, SMS not being able to send when Carrier Services is enabled, and MMS not being received 95% of the time..

    After the latest update (ABI087) failed to fix any of these problems, I backed up my SMS and Call logs using SMS Backup & Restore, backed up my Contacts and Notes to Outlook using MyPhoneExplorer, then did a Factory Reset from the appropriate Settings menu. After the Factory Reset, the phone booted back up, IMS was Connected, VoLTE was enabled, Video Calling was enabled, WiFi Calling was working (always worked even under Android 7), MMS pictures were received no problem, and outgoing SMS worked without having to disable Carrier Services, even over WiFi on Airplane Mode.

    The source of the problem was either going into the *#*#46368676#*#* menu and touching the VoLTE or Video Calling switch, or Oreo updating over Nougat, or Rogers' customization of Nougat and customization of the Oreo update package, or some combination of those factors.
    11-11-18 04:21 PM

Similar Threads

  1. BB Hub keeps rebooting on Huawei Mate
    By davide445 in forum Android Apps
    Replies: 6
    Last Post: 02-04-19, 06:30 PM
  2. I got my KEY2 flip case and...
    By lohikaarme in forum BlackBerry KEY2
    Replies: 19
    Last Post: 09-20-18, 08:31 AM
  3. Unable to group call
    By DavideaNY in forum BlackBerry KEY2
    Replies: 1
    Last Post: 09-13-18, 05:00 AM
  4. How to install "Google Play Store" on BBOS10?
    By JurK87 in forum BlackBerry Classic
    Replies: 3
    Last Post: 09-04-18, 03:29 PM
  5. BlackBerry KEYone Oreo beta updated to ABG328
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 09-04-18, 11:50 AM
LINK TO POST COPIED TO CLIPBOARD