05-14-19 07:09 PM
50 12
tools
  1. Blemurdefender's Avatar
    Saturday I was driving with a clear view of the sky and got GPS signal lost a couple of times with Google Maps on my KEYone. It was set on High Accuracy (battery saving mode for Location doesn't work with Google Maps it will force you to switch to high accuracy)

    Is my antenna too weak or should I switch to Waze?
    04-09-18 07:56 AM
  2. Blemurdefender's Avatar
    made the switch to Waze and no issues so far hope it will remain this way

    I guess I can say once you go waze you never go back (I love how it even alerts you when there's police around rofl)
    Uglyindian likes this.
    04-09-18 01:20 PM
  3. jdcbomb's Avatar
    Just checking if you still have issues? I too also had Google Maps with losing GPS signal. I think it's a software conflict with GMaps based on the KeyONE firmware version. I also noticed that Waze would also lose signal if GMaps was running first and locked up. But after toggling off / on location, and then starting Waze again, it runs smoothly.
    06-10-18 09:43 PM
  4. Tim-ANC's Avatar
    Are you losing GPS reception or Mobile data? Remember these apps require data to generate the map and alerts.
    06-11-18 05:42 AM
  5. jdcbomb's Avatar
    GPS reception only. I've done more testing and I cannot quite pin down why / what / how the GPS signal keeps being lost. Both Waze and GMaps will show "searching for GPS" or "GPS unavailable" at certain times. This all being under a clear sky.

    Then if I toggle off the location radio, and then toggle it on, Waze will connect immediately again...and will work normally even inside my home. Google Maps then starts working fine again also. It seems if i START with GMaps it more often fails, while Waze has more success in keeping the GPS signal. Any thoughts?

    I would hate to have to replace this again, as I would have to run down to the store and do it all over again (Sprint).
    06-12-18 01:42 PM
  6. Tim-ANC's Avatar
    GPS reception only. I've done more testing and I cannot quite pin down why / what / how the GPS signal keeps being lost. Both Waze and GMaps will show "searching for GPS" or "GPS unavailable" at certain times. This all being under a clear sky.

    Then if I toggle off the location radio, and then toggle it on, Waze will connect immediately again...and will work normally even inside my home. Google Maps then starts working fine again also. It seems if i START with GMaps it more often fails, while Waze has more success in keeping the GPS signal. Any thoughts?

    I would hate to have to replace this again, as I would have to run down to the store and do it all over again (Sprint).
    Do you have it set to high accuracy mode in Location settings?
    06-13-18 05:36 AM
  7. jdcbomb's Avatar
    Yes. After further testing, I've found both GMaps and Waze both show "No GPS Signal". GMaps appears less stable (even after using the factory installed version and new one) as it jumps location randomly, while Waze will show the general location, but both cannot start driving directions.

    On average, under different levels of cellular signal strength, both take about 2 to 3 minutes to finally " get back " the GPS signal, with Waze being faster.

    I'm now on my 2nd KeyONE and disappointed that they couldn't get this simple hardware radio right...
    06-13-18 07:44 AM
  8. FF22's Avatar
    Yes. After further testing, I've found both GMaps and Waze both show "No GPS Signal". GMaps appears less stable (even after using the factory installed version and new one) as it jumps location randomly, while Waze will show the general location, but both cannot start driving directions.

    On average, under different levels of cellular signal strength, both take about 2 to 3 minutes to finally " get back " the GPS signal, with Waze being faster.

    I'm now on my 2nd KeyONE and disappointed that they couldn't get this simple hardware radio right...
    You might download and see what "gps status" (by MobiWIA) reports.

    Also, you could boot to Safe Mode to make sure nothing else is interferring. Press the Power button and then press and HOLD on the actual POWER OFF prompt words. Unfortunately, when coming off Safe Mode, you probably will lose your Icon and Widget placements on home pages.
    06-13-18 08:57 AM
  9. jdcbomb's Avatar
    Yep downloaded and have GPS Status installed. Not sure how it's supposed to help as when GMaps or Waze both report "No GPS" the GPS Status app shows satellites in green and yellow in full view, but the bottom shows "No GPS Signal" or "Searching for GPS" When I quickly close / open / close / open GPS Status, it seems to finally lock on. Frustrating.
    06-13-18 09:59 AM
  10. FF22's Avatar
    Yep downloaded and have GPS Status installed. Not sure how it's supposed to help as when GMaps or Waze both report "No GPS" the GPS Status app shows satellites in green and yellow in full view, but the bottom shows "No GPS Signal" or "Searching for GPS" When I quickly close / open / close / open GPS Status, it seems to finally lock on. Frustrating.
    Where are you running into this problem? I have not heard about the problem in a while but there were windshields at one time that could block gps signals. The glass contained some form of reflective metal shielding to keep temperatures down.

    Have you tried in an open field with a clear view of the sky as an initial test? Did your previous versions work in the same vehicle?

    I have to admit that I mainly use mine when hiking since my car has a gps. But I've used it with friends on occasion and it has worked. Actually, now that I think of it, it worked in Oslo when on a city bus in Jan.
    06-13-18 11:45 AM
  11. jdcbomb's Avatar
    Where are you running into this problem? I have not heard about the problem in a while but there were windshields at one time that could block gps signals. The glass contained some form of reflective metal shielding to keep temperatures down.

    Have you tried in an open field with a clear view of the sky as an initial test? Did your previous versions work in the same vehicle?

    I have to admit that I mainly use mine when hiking since my car has a gps. But I've used it with friends on occasion and it has worked. Actually, now that I think of it, it worked in Oslo when on a city bus in Jan.
    The problem occurs when I'm opening either GPS app after it's been closed for at least 5 minutes. I even disabled some power saving settings in the locations settings menu to test. No difference. I have not tested just in an open field, but I can report this: For the BlackBerry PRIV, even though GMaps opened slow (processor issue), the GPS lock would occur instantly. Under the same conditions (in my car, on the road without trees or buildings in the way, sitting on the dashboard), the KeyONE GPS can take upwards of 3 minutes to lock. This is even after a fresh reboot, cache cleared, no other apps running. I've seen other apps such as Yelp take a VERY long time to find "what's close by."
    06-13-18 11:58 AM
  12. FF22's Avatar
    The problem occurs when I'm opening either GPS app after it's been closed for at least 5 minutes. I even disabled some power saving settings in the locations settings menu to test. No difference. I have not tested just in an open field, but I can report this: For the BlackBerry PRIV, even though GMaps opened slow (processor issue), the GPS lock would occur instantly. Under the same conditions (in my car, on the road without trees or buildings in the way, sitting on the dashboard), the KeyONE GPS can take upwards of 3 minutes to lock. This is even after a fresh reboot, cache cleared, no other apps running. I've seen other apps such as Yelp take a VERY long time to find "what's close by."
    Then you certainly might have a bad device. I use Nogago Tracks almost daily and it generally finds my location immediately. On occasion it has not done so. It accurately tracks my hikes. And accidentally last week, my entire 110 mile drive home after the hike since I forgot to turn it off!

    Again, I don't use navigation much since the car has its own gps. But I've use gmaps and Here WeGo (I had downloaded maps of Oslo, Norway) but tracked and navigated our walks and as I noted, a bus ride through town.
    06-13-18 01:15 PM
  13. jdcbomb's Avatar
    Thanks for the feedback here. I personally only use GPS about once a week or less as I'm familiar with most of the area around me. It's just annoying that I've already replaced my device once (for an unrelated Sprint firmware issue...still ongoing) only to be given another bad device. I wish BB had better quality control in this regard...
    06-13-18 02:06 PM
  14. Tim-ANC's Avatar
    I suggest downloading a simple GPS locator app that gives you coordinates and the satellite constellation you are receiving input from. If it's spotty, means there is something wrong with your receiver.
    06-13-18 07:57 PM
  15. jdcbomb's Avatar
    I've been using GPS status app for several days now and it seems to show at least 12 GPS satellites above me at any given time all in the green. The bizarre thing is that even if it shows GPS lock, Waze and / or GMaps may or may not agree on my immediate location and will both jump around for a couple minutes. I have no idea what this may mean so if anyone has any thoughts that would be great.
    06-14-18 07:59 AM
  16. FF22's Avatar
    I've been using GPS status app for several days now and it seems to show at least 12 GPS satellites above me at any given time all in the green. The bizarre thing is that even if it shows GPS lock, Waze and / or GMaps may or may not agree on my immediate location and will both jump around for a couple minutes. I have no idea what this may mean so if anyone has any thoughts that would be great.
    You may be already doing this but only run ONE of those mapping/navigation apps at a time and see how it responds. If multiple apps are attempting to grab gps data, it might affect how they run.

    Also, in some cases the mapping data could be wrong - it happens in certain areas.
    Tim-ANC likes this.
    06-14-18 09:53 AM
  17. jdcbomb's Avatar
    Good point on not running multiple apps. I have found the current pattern to work the fastest though (could be unrelated): First run GPS Status and let it "find" all the satellites, then I open Waze / GMaps and they find it "faster" (1 to 3 minutes). If I cold open Waze / GMaps, it takes upwards of 5 minutes for apps to find my location and allow for real navigation to begin. This never happened with the PRIV.

    As for mapping data being wrong, I'm pretty sure that's not the case as I live in a suburban area...again where the PRIV found my location a lot faster. I read somewhere on Reddit that another group of users were experiencing "random jumping" of the location also.
    06-14-18 09:57 AM
  18. FF22's Avatar
    Good point on not running multiple apps. I have found the current pattern to work the fastest though (could be unrelated): First run GPS Status and let it "find" all the satellites, then I open Waze / GMaps and they find it "faster" (1 to 3 minutes). If I cold open Waze / GMaps, it takes upwards of 5 minutes for apps to find my location and allow for real navigation to begin. This never happened with the PRIV.

    As for mapping data being wrong, I'm pretty sure that's not the case as I live in a suburban area...again where the PRIV found my location a lot faster. I read somewhere on Reddit that another group of users were experiencing "random jumping" of the location also.
    Holy crap!!! I just opened Waze and it immediately had my location. Sitting in my house by the way.

    Maybe I will note that I have the "Verizon" version if that makes any difference.
    06-14-18 01:41 PM
  19. jdcbomb's Avatar
    Holy crap!!! I just opened Waze and it immediately had my location. Sitting in my house by the way.

    Maybe I will note that I have the "Verizon" version if that makes any difference.
    @ FF22: Well it may "appear" it has your location, as it's using AGPS and GPS to find the "general" location you may be at. Can you try and start a navigation journey in Waze (pick any location) and see how quickly the actual arrow shows up? Occasionally, the arrow will pop up and start talking to me within a minute, but more often than not, it sits there and "finds gps" for minutes at a time.
    06-14-18 01:56 PM
  20. FF22's Avatar
    Actually, when I opened it, I quickly put in REI and it offered the nearby stores and I picked one and it was navigating.

    And it showed my house location.
    06-14-18 02:02 PM
  21. Tim-ANC's Avatar
    Good point on not running multiple apps. I have found the current pattern to work the fastest though (could be unrelated): First run GPS Status and let it "find" all the satellites, then I open Waze / GMaps and they find it "faster" (1 to 3 minutes). If I cold open Waze / GMaps, it takes upwards of 5 minutes for apps to find my location and allow for real navigation to begin. This never happened with the PRIV.

    As for mapping data being wrong, I'm pretty sure that's not the case as I live in a suburban area...again where the PRIV found my location a lot faster. I read somewhere on Reddit that another group of users were experiencing "random jumping" of the location also.
    I noticed that on BB10, sometimes had to open the basic GPS app, get a fix, then my more sophisticated Nav apps would lock in quicker.

    Now you say there are other reports about GPS in your area. That could be interference from something or intentional jamming. Do you live near a naval or military installation?
    FF22 likes this.
    06-14-18 06:30 PM
  22. Tim-ANC's Avatar
    Actually, when I opened it, I quickly put in REI and it offered the nearby stores and I picked one and it was navigating.

    And it showed my house location.
    Yeah, but you might be getting WiFi and Mobile data assist. Turn both off, and see what pure GPS reception gives you.
    06-14-18 06:33 PM
  23. FF22's Avatar
    Yeah, but you might be getting WiFi and Mobile data assist. Turn both off, and see what pure GPS reception gives you.
    Wifi - OFF.

    Just as fast - instantaneous. Searched for an exotic restaurant about 6 miles away. Provided route. Now, none of this means that as I start driving/moving in that direction it won't lose the gps signal.

    Oh, where's mobile data assist located?
    06-14-18 06:39 PM
  24. Tim-ANC's Avatar
    Wifi - OFF.

    Just as fast - instantaneous. Searched for an exotic restaurant about 6 miles away. Provided route. Now, none of this means that as I start driving/moving in that direction it won't lose the gps signal.

    Oh, where's mobile data assist located?
    Put it in airplane mode
    06-14-18 07:04 PM
  25. jdcbomb's Avatar
    I noticed that on BB10, sometimes had to open the basic GPS app, get a fix, then my more sophisticated Nav apps would lock in quicker.

    Now you say there are other reports about GPS in your area. That could be interference from something or intentional jamming. Do you live near a naval or military installation?
    Sorry to clarify...its at least a couple other KeyONE users on reddit...not necessarily near me or any bases or interference. Very peculiar behavior...standing outside earlier with clear southern sky...took 5 min for gps to lock. Another time I tried in the garage it connected instantly!
    06-14-18 08:16 PM
50 12

Similar Threads

  1. BB browser on Android devices
    By CUSI911 in forum BlackBerry Android OS
    Replies: 19
    Last Post: 07-12-18, 03:45 AM
  2. BlackBerry KEYone SIM keeps losing service
    By tharlowe1 in forum BlackBerry KEYone
    Replies: 7
    Last Post: 06-12-18, 09:17 AM
  3. Typing on the Motion
    By Lionel Passport in forum BlackBerry Motion
    Replies: 4
    Last Post: 04-11-18, 07:10 PM
  4. Typing on the Keyone
    By Lionel Passport in forum BlackBerry KEYone
    Replies: 17
    Last Post: 04-11-18, 08:00 AM
  5. Att passport on mint sim?
    By vtecberry in forum BlackBerry Passport
    Replies: 5
    Last Post: 04-09-18, 01:35 PM
LINK TO POST COPIED TO CLIPBOARD