1. angelitop's Avatar
    Got my K1 today from Amazon. I've never had to deal with an unlocked phone so I went to my local AT&T and they took the SIM from my old phone (SAMSUNG S6) and inserted it in my K1. They said it should be good to go but when I turned it on and started, it prompted me to do the "set up as new" and I chose "use celular network for set up". It says "Activating cellular service" and it has been like that for 20 minutes with no progress. You think the SIM is bad? Did I miss a step to set up? Or the guy at the store missed a step to set up?
    06-05-17 05:17 PM
  2. howarmat's Avatar
    have you tried to setup via wifi?

    You might have to then change the APN to work on cellular
    06-05-17 05:26 PM
  3. angelitop's Avatar
    Thank you. I went to another ATT store and the guy did the initial set up via wifi. I can now make phone calls and receive/send test messages, but I can't go in the internet. My 4G icon on the top corner is greyed out. Anything I can do to finish the set up and get internet as well? Thank you.
    06-05-17 08:01 PM
  4. adokis's Avatar
    See the post above. You need to input settings.
    06-05-17 08:03 PM
  5. adjmcloon's Avatar
    Activation issues usually lie with the carrier. I would revisit your local store or call ATT support
    06-05-17 08:04 PM
  6. angelitop's Avatar
    Adokis, input settings? Forgive my ignorance, but Im a Tech guy so I'm not sure what that it. Howarmat, change the APN? Any links that can show me how to do that? Thank you.
    06-05-17 08:12 PM
  7. Al moon's Avatar
    you need to talk with someone at att who knows what they are doing they may need to input the phone's imei number into their database so it can get data services
    06-05-17 08:30 PM
  8. NtotheK's Avatar
    Adokis, input settings? Forgive my ignorance, but Im a Tech guy so I'm not sure what that it. Howarmat, change the APN? Any links that can show me how to do that? Thank you.
    http://apn-settings.com/us/att-apn-settings/
    06-05-17 08:35 PM
  9. angelitop's Avatar
    NtotheK, thank you. I will try that. I'm getting the "unable to establish wireless data connection. Touch to open APN Settings" error message. So hopefully it does work.
    06-06-17 09:57 AM
  10. psychofox13's Avatar
    I'm on AT&T and I didn't have to change any information. I plugged my SIM Card in and I have full service; data, talk, text. I have LTE in places that have LTE, and HSPA+ in others.

    It's weird that you're having issues.
    Johberry likes this.
    06-06-17 10:20 AM
  11. m69c44's Avatar
    I'm on AT&T and I didn't have to change any information. I plugged my SIM Card in and I have full service; data, talk, text. I have LTE in places that have LTE, and HSPA+ in others.

    It's weird that you're having issues.
    Same here just moved my Sim card and everything was there and working.
    06-06-17 10:24 AM
  12. angelitop's Avatar
    UPDATE & SOLUTION: Turns out that my issue was my wireless plan. The tech guy at ATT called me back and he said that my plan that i've had for almost 10 years was not compatible with my BB K1. So he gave me a new plan that was compatible and it costs LESS that what I was paying, AND it's unlimited talk, text, and data!!! Now my BBK1 works all the way and it's SOOOOO awesome!!!
    06-07-17 05:10 PM

Similar Threads

  1. How to clear up RAM?
    By khlover520 in forum BlackBerry KEYone
    Replies: 32
    Last Post: 10-24-17, 03:13 AM
  2. Replies: 2
    Last Post: 06-06-17, 08:39 PM
  3. Who is still waiting for the KEYone?
    By consv93 in forum BlackBerry KEYone
    Replies: 7
    Last Post: 06-05-17, 05:35 PM
  4. Replies: 1
    Last Post: 06-05-17, 03:40 PM
  5. Just now downloaded a large update on my unlocked Priv...
    By jackcarr in forum BlackBerry Priv
    Replies: 1
    Last Post: 06-05-17, 02:39 PM
LINK TO POST COPIED TO CLIPBOARD