Built for Business - Learn more about BlackBerry KEY2
  1. rickzimmerman's Avatar
    Hi All,

    I know that the Google Lens app has never worked on BlackBerrys. However it did work by clicking on the icon at the bottom of the Photos app.

    For some reason it doesn't work any more there either. There's a message saying it's not available.

    Does anyone know why this has changed? Maybe in one of the updates?

    Thanks.
    09-09-19 11:23 AM
  2. Sigewif's Avatar
    Hi All,

    I know that the Google Lens app has never worked on BlackBerrys. However it did work by clicking on the icon at the bottom of the Photos app.

    For some reason it doesn't work any more there either. There's a message saying it's not available.

    Does anyone know why this has changed? Maybe in one of the updates?

    Thanks.
    I am on a KEY2 and downloaded the Google Lens app from Google Play Store and it works fine. I don't have it on my KEYone but know someone who has it on their DTEK60. Just search for Google Lens in the Play Store. The app will appear under the name "Lens" in your app drawer or where you place it.
    PS you did not mention which device you are using but I assume it is a KEYone since you posted in the KEYone forum.
    Last edited by Sigewif; 09-09-19 at 12:18 PM.
    09-09-19 11:35 AM
  3. conite's Avatar
    Hi All,

    I know that the Google Lens app has never worked on BlackBerrys. However it did work by clicking on the icon at the bottom of the Photos app.

    For some reason it doesn't work any more there either. There's a message saying it's not available.

    Does anyone know why this has changed? Maybe in one of the updates?

    Thanks.
    No issues here. Maybe you are suffering from a regional restriction.
    09-09-19 11:55 AM
  4. rickzimmerman's Avatar
    Thanks for the reply.

    I have a Key 2 and a Key 1 BE and the app will not open on either of them. I get the message “Thanks for updating. Lens will be available soon.” When I open a photo in google photo and click on the Lens icon on the bottom I get the message “Something went wrong. Google Lens is not available”. The app has never worked but I know Lens used to work on individual photos.

    I guess I could have disabled some google setting but other than this everything seems to work OK on both phones.
    09-09-19 12:02 PM
  5. rickzimmerman's Avatar
    Maybe it’s Bell specific. I used to be on Rogers. I don’t know if it was working when I was with them or not.
    09-09-19 12:05 PM
  6. rickzimmerman's Avatar
    Location is Vancouver B.C.
    09-09-19 12:06 PM
  7. rickzimmerman's Avatar
    Not carrier. Forgot to mention it won’t download or work on wifi either.
    09-09-19 12:11 PM
  8. Sigewif's Avatar
    Thanks for the reply.

    I have a Key 2 and a Key 1 BE and the app will not open on either of them. I get the message “Thanks for updating. Lens will be available soon.” When I open a photo in google photo and click on the Lens icon on the bottom I get the message “Something went wrong. Google Lens is not available”. The app has never worked but I know Lens used to work on individual photos.

    I guess I could have disabled some google setting but other than this everything seems to work OK on both phones.
    You mention that you guess could have disabled some Google settings. That would be the next place to check out to see if there are permissions it needs that you may have disabled or turned off.
    09-09-19 12:26 PM
  9. rickzimmerman's Avatar
    Here's a strange thing - I took out my old Priv, installed Lens, and it works great. The Priv is running 6.0.1 Marshmallow. The Key 1 and Key 2 running 8.1.0 Oreo won't run it. That would suggest it's the O.S. or one of the updates that are preventing it from installing or running. Surely you guys must be running Oreo on your phones. Can't find anything else different on the phones.
    09-10-19 04:12 PM
  10. conite's Avatar
    Here's a strange thing - I took out my old Priv, installed Lens, and it works great. The Priv is running 6.0.1 Marshmallow. The Key 1 and Key 2 running 8.1.0 Oreo won't run it. That would suggest it's the O.S. or one of the updates that are preventing it from installing or running. Surely you guys must be running Oreo on your phones. Can't find anything else different on the phones.
    KEYᵒⁿᵉ and KEY² on the latest Oreo builds.
    09-10-19 04:31 PM
  11. rickzimmerman's Avatar
    Oh well. Doesn’t matter. I can live without it.
    09-10-19 05:21 PM
  12. Sigewif's Avatar
    KEYᵒⁿᵉ and KEY² on the latest Oreo builds.
    Mine works on my KEY2. I don't see why it wouldn't work unless there is some setting that is blocking it.
    09-10-19 05:22 PM
  13. RLeeSimon's Avatar
    works on my phone too, why not cycle off and on the photos app and see if it updates and improves. It also works in the Standalone app. That would be on a keyone and I don't know about any other models.
    09-10-19 05:29 PM
  14. Sigewif's Avatar
    works on my phone too, why not cycle off and on the photos app and see if it updates and improves. It also works in the Standalone app. That would be on a keyone and I don't know about any other models.
    The stand alone app is what I have been using.
    09-10-19 07:29 PM

Similar Threads

  1. Browsing on Wi-fi selectively blocks certain websites & apps
    By saturnx-808 in forum BlackBerry KEYone
    Replies: 4
    Last Post: 09-15-19, 09:17 AM
  2. Replies: 3
    Last Post: 09-11-19, 02:08 AM
  3. Can't turn off BlackBerry Protect on my Passport
    By StripeyMiata in forum BlackBerry Passport
    Replies: 2
    Last Post: 09-08-19, 07:33 PM
  4. Longer dwell time on lock screen notifications?
    By blackshark in forum BlackBerry KEY2
    Replies: 0
    Last Post: 09-08-19, 12:04 PM
  5. No volume control while on calls
    By blackshark in forum BlackBerry KEY2
    Replies: 0
    Last Post: 09-07-19, 01:13 PM
LINK TO POST COPIED TO CLIPBOARD