1. marcusperkins's Avatar
    Each time DTEK scans my K1 it flags up unused permission for apps that I'm using every day. For example I use the Signal app every day and regularly make calls and take photos. Yet DTEK is suggesting the camera and mic permissions are not used and should be switched off. I get the same message for all other app permissions.

    Any clues anybody?

    Thanks.
    10-17-18 06:48 PM
  2. wmatsura's Avatar
    At this point, you can either revoke those permissions or simply ignore it. Unused permissions won't change your "excellent" rating on the DTEK app.

    I've read somewhere here on the forums that future updates will probably feature an option to manage those unused permissions
    10-17-18 09:00 PM
  3. marcusperkins's Avatar
    At this point, you can either revoke those permissions or simply ignore it. Unused permissions won't change your "excellent" rating on the DTEK app.

    I've read somewhere here on the forums that future updates will probably feature an option to manage those unused permissions
    Thanks - and of course you're correct. But if it's getting that so wrong, what else is it misreading. Hopefully it will get fixed in an update.
    10-18-18 06:09 PM
  4. BCGrog's Avatar
    I am seeing the same thing. "Unused Permissions" for programs I use all day long every day. I just clear them, it's just weird.
    10-18-18 06:39 PM
  5. wmatsura's Avatar
    Thanks - and of course you're correct. But if it's getting that so wrong, what else is it misreading. Hopefully it will get fixed in an update.
    In your case, I understand it's kinda frustrating, as the DTEK app is flagging permissions you are in fact using.

    But I can say that issue is not happening for everyone, mine only showed me permissions I wasn't using.
    10-18-18 07:36 PM
  6. marcusperkins's Avatar
    I am seeing the same thing. "Unused Permissions" for programs I use all day long every day. I just clear them, it's just weird.
    At least I'm not alone. It does though question the value and effectiveness of the app. On the one hand I get a report to say my phone is secure whilst on the other hand I know it's not working properly.
    10-18-18 08:09 PM
  7. BB_RobertL's Avatar
    Hi @marcusperkins, Thanks for the feedback on DTEK unused permissions feature. I will have the team look into it. If you can give a few more examples of apps that have permissions you are using, but DTEK is showing them as not being used, that would really help our investigation
    Thanks!
    Robert
    10-30-18 03:37 PM
  8. marcusperkins's Avatar
    Hi @marcusperkins, Thanks for the feedback on DTEK unused permissions feature. I will have the team look into it. If you can give a few more examples of apps that have permissions you are using, but DTEK is showing them as not being used, that would really help our investigation
    Thanks!
    Robert
    Thanks for the follow-up. Very much appreciated.

    I've just run a test and the correct unused permissions are now showing. The app was updated since first highlighting the issue, so perhaps that solved the problem. I also cleared the cache and data which may also have had a positive impact.

    In short, the problem seems to have been resolved - as have the delayed notifications reported separately.
    10-30-18 06:30 PM
  9. BB_RobertL's Avatar
    Ok, sounds good. If you notice it popping up again just tag me and let me know
    10-30-18 06:48 PM
  10. tragicallybrokenhip's Avatar
    @BB_RobertL Same issue has been happening with my phone since 2019 January. All the unused permissions are those I use daily but which my phone thinks haven't been used in 217 (and counting) days: Phone, SIM services, Hub, Calendar, Contacts, Messages, Google Play Store. The list also shows the same *unused* app multiple times: Hub twice, Contacts thrice, etc. Yeah, it's annoying even though the status is 'excellent' but as others, it does make me question if there are other issues not being identified. Suggestions welcome.
    02-26-19 07:57 AM
  11. BB_RobertL's Avatar
    Hi @tragicallybrokenhip, have you tried clearing DTEK data and cache? It will unfortunately undo all your settings, but it is possible that something went wrong when updating from whatever version you were on to the newest. Clearing the slate isn't really the ideal solution path, but it is probably the quickest way to resolve the issue you are seeing.

    Also, which DTEK version are you using?
    Which device and OS version are you using?

    Thanks!
    Robert
    02-26-19 06:25 PM

Similar Threads

  1. KEY2 Back Panel Issues?
    By Byrese in forum BlackBerry KEY2
    Replies: 3
    Last Post: 10-18-18, 12:21 PM
  2. DTEK SD Card Issues
    By TelvisTed in forum BlackBerry Motion
    Replies: 2
    Last Post: 10-16-18, 01:32 PM
  3. Vibration/Fingerprint Scanner Issues
    By Massonite in forum BlackBerry KEY2
    Replies: 6
    Last Post: 10-16-18, 12:19 AM
  4. My dtek 60 has a battery problem.
    By sprinter4337 in forum BlackBerry DTEK60
    Replies: 2
    Last Post: 10-13-18, 11:37 PM
LINK TO POST COPIED TO CLIPBOARD