1. guilemo's Avatar
    I've had issues with my KEYone regarding the auto correction using the physical keyboard and the BlackBerry Keyboard. For most of the time it works perfectly fine, but for certain words it's dodgy as hell. Pretty consistently 'is' becomes 'I'd'. I've also seen examples where similar cases have presented themselves: I'm typing a perfectly legit English word and it's auto corrected to something different. This I'd incredibly frustrating.

    Has anyone else experienced similar issues?

    Thanks guys.
    OrlandoAlex likes this.
    06-04-17 10:44 AM
  2. crackbee's Avatar
    Yes, and it also doesn't allow me to use slang. Having the physical kb gives me enough control and don't need the extra help. Turned the feature off.
    OrlandoAlex likes this.
    06-04-17 10:51 AM
  3. medic22003's Avatar
    you know you can add slang to your personal dictionary and those words will come up as options right? the more you type on the phone the more it learns your style and word use. it's a little annoying at first but it does get significantly better
    06-04-17 11:04 AM
  4. schwartz1030's Avatar
    I've had issues with my KEYone regarding the auto correction using the physical keyboard and the BlackBerry Keyboard. For most of the time it works perfectly fine, but for certain words it's dodgy as hell. Pretty consistently 'is' becomes 'I'd'. I've also seen examples where similar cases have presented themselves: I'm typing a perfectly legit English word and it's auto corrected to something different. This I'd incredibly frustrating.

    Has anyone else experienced similar issues?

    Thanks guys.
    Yep, me too. I used to have similar (not as bad) problems with the Classic. I just turn it off because the physical keyboard is generally more accurate in my case.
    OrlandoAlex likes this.
    06-04-17 11:09 AM
  5. guilemo's Avatar
    Thanks guys. I might just turn off the auto correct feature then. I also turned off the Learning feature some weeks ago as it would also learn my mistakes, capitalization (e.g I would start a sentence with an unfamiliar word, it would learn it capitalised.) and generally behave in a weird way.

    I also have a Chinese keyboard (simplified pinyin) installed and it would learn these words too. The character 大 is 'da', so whenever I would type 'da..' It would give me 大 as a suggestion.
    OrlandoAlex likes this.
    06-04-17 11:30 AM
  6. BB-JAM215's Avatar
    Thanks guys. I might just turn off the auto correct feature then...
    You can reduce the degree of Auto-correction from strong to weak and see if that helps.
    OrlandoAlex likes this.
    06-04-17 11:42 AM
  7. guilemo's Avatar
    You can reduce the degree of Auto-correction from strong to weak and see if that helps.
    Already set to 'weak', I'm afraid.

    For now, ive just added 'is' to a list of words to never correct. Its an annoying fix though, as its fixing a symptom.
    OrlandoAlex likes this.
    06-04-17 11:49 AM
  8. crackbee's Avatar
    you know you can add slang to your personal dictionary and those words will come up as options right? the more you type on the phone the more it learns your style and word use. it's a little annoying at first but it does get significantly better
    Thanks for the tip. Might be beneficial for me to start saving some words.
    OrlandoAlex likes this.
    06-04-17 12:18 PM
  9. mikeydodds's Avatar
    Auto correct is only useful on virtual keyboards.
    slagman5 likes this.
    06-05-17 06:41 AM
  10. anon(10250369)'s Avatar
    Yep, I started noticing some annoyances like automatically capitalizing web and internet, when I don't use that style. The setting went from "weak" correction on physical keyboard to completely off.
    06-05-17 06:51 AM
  11. luvsql's Avatar
    Where are these settings? I'm getting tired of sucks changing to ducks. I want no autocorrect.
    06-11-17 08:43 PM
  12. anon(3750701)'s Avatar
    Where are these settings? I'm getting tired of sucks changing to ducks. I want no autocorrect.
    Settings > Language & Input > Keyboard Settings > BlackBerry Keyboard > Prediction and correction > Auto Correction
    DolemiteDONS likes this.
    06-11-17 08:49 PM
  13. luvsql's Avatar
    I was looking everywhere thank you. I just didn't open the BBKeyboard. Thank you!
    anon(3750701) likes this.
    06-11-17 08:51 PM
  14. Johberry's Avatar
    Settings > Language & Input > Keyboard Settings > BlackBerry Keyboard > Prediction and correction > Auto Correction
    Ah, thank you! I was going nuts trying to figure out how to turn off autocorrect. Cheers.
    anon(3750701) likes this.
    06-11-17 09:39 PM
  15. jeansboy54's Avatar
    King Benny that's a sweet King Richard pic.

    Posted via CB10
    06-11-17 09:51 PM
  16. anon(3750701)'s Avatar
    King Benny that's a sweet King Richard pic.

    Posted via CB10
    It's actually Kirk McLean
    06-11-17 10:12 PM
  17. jeansboy54's Avatar
    You're sooo right I should have zoomed in on my phone ,my bad. Go 'Nucks!!

    Posted via CB10
    06-11-17 10:18 PM
  18. slagman5's Avatar
    I've had issues with my KEYone regarding the auto correction using the physical keyboard and the BlackBerry Keyboard. For most of the time it works perfectly fine, but for certain words it's dodgy as hell. Pretty consistently 'is' becomes 'I'd'. I've also seen examples where similar cases have presented themselves: I'm typing a perfectly legit English word and it's auto corrected to something different. This I'd incredibly frustrating.

    Has anyone else experienced similar issues?

    Thanks guys.
    Auto-correct? What in the heck is that? I use physical keyboard phones, I have no clue what this "auto correct" mumbo jumbo is... ;-)
    06-11-17 11:44 PM
  19. slagman5's Avatar
    You can reduce the degree of Auto-correction from strong to weak and see if that helps.
    I set mine to the degree of "off" lol.
    06-11-17 11:45 PM
  20. blueyestm's Avatar
    I had mine off but when I submitted all the words that have apostrophes so I don't have to type that it never worked and I had to put it on weak. It's not too terribly bad and I'm watching it for the most part so when I see it autocorrect I quickly backspace to get it to go back and add it to the dictionary.
    06-12-17 01:06 AM
  21. yessuz's Avatar
    I find it better not to turn off autocorrect completely, but just disable correct on space.
    So i can use whatever i want when i type but autocorrect option is still available on top

    Using bb10 btw but presume BlackBerry keyboard will have same option.
    06-12-17 03:15 AM
  22. guilemo's Avatar
    I find it better not to turn off autocorrect completely, but just disable correct on space.
    So i can use whatever i want when i type but autocorrect option is still available on top

    Using bb10 btw but presume BlackBerry keyboard will have same option.
    That's what I've done too now after reading the advise in this thread. I find that if the auto correct is set to weak, I still have the original issues I had in my original post (is turns to I'd, etc). If the auto correct didnt have issues like this (whic surely must be bug-related), then I'd turn it back on.
    06-25-17 07:46 AM

Similar Threads

  1. Is there better calendars for the Keyone ?
    By m69c44 in forum Android Apps
    Replies: 11
    Last Post: 08-28-17, 09:25 PM
  2. Is there anyway to make the BlackBerry launcher 4 tiles wide?
    By Luke Beauchamp in forum BlackBerry Android OS
    Replies: 8
    Last Post: 06-11-17, 07:25 AM
  3. Do Not Disturb: is there a shortcut?
    By todena in forum BlackBerry KEYone
    Replies: 13
    Last Post: 06-04-17, 09:07 PM
  4. is the Bluetooth issue a Rogers one?
    By velkod in forum Ask a Question
    Replies: 2
    Last Post: 06-04-17, 02:54 AM
  5. Replies: 3
    Last Post: 06-03-17, 06:24 PM
LINK TO POST COPIED TO CLIPBOARD