Built for Business - Learn more about BlackBerry KEY2
  1. pantagruel_bb's Avatar
    I have had my Keyone for a year and nine months. Whenever I charge it I get the green semi circle that says charge only and boost mode. Last night a new option appeared: charge and data. I didn't think twice about it, but now I notice that the phone is charging more slowly.

    As far as I can remember I didn't change any settings. Any advice on how to get back my quick charging speed!?!?
    09-18-19 11:37 AM
  2. coffee-turtle's Avatar
    different cable?
    different power source/plug?
    pantagruel_bb likes this.
    09-18-19 11:47 AM
  3. ibaxx's Avatar
    Have enabled developer options?

    Turn on animations when turned off!
    Helped on mine!
    09-18-19 11:48 AM
  4. pantagruel_bb's Avatar
    different cable?
    different power source/plug?
    Same cable and power source as always.
    09-18-19 11:54 AM
  5. pantagruel_bb's Avatar
    Have enabled developer options?

    Turn on animations when turned off!
    Helped on mine!
    Thanks for the tip. Pardon my ignorance, but where can I find these settings?
    09-18-19 11:54 AM
  6. ibaxx's Avatar
    Settings -> system -> developer options


    But when you never seen it before, it will be not the problem
    09-18-19 01:38 PM
  7. pantagruel_bb's Avatar
    Settings -> system -> developer options


    But when you never seen it before, it will be not the problem
    Thanks! Should developer options be on or off?
    09-18-19 01:46 PM
  8. coffee-turtle's Avatar
    Thanks! Should developer options be on or off?
    It should be off. If it is on, then USB debugging and USB debugging in charging mode, and Install via USB all should be off.
    09-18-19 02:00 PM
  9. pantagruel_bb's Avatar
    Phone still charging very slowly. Tried googling some fixes but I am stumped.
    09-18-19 05:10 PM
  10. ibaxx's Avatar
    Do a factory reset!
    09-19-19 12:36 AM
  11. pantagruel_bb's Avatar
    I did the "hold the power button for 32 seconds" thing. It worked! Charge + data went away, and it charges normally!
    yamahammer and coffee-turtle like this.
    09-19-19 06:03 PM
  12. RLeeSimon's Avatar
    you got lucky
    09-20-19 03:15 PM
  13. yamahammer's Avatar
    you got lucky
    I'd prefer to say, good job!
    pantagruel_bb likes this.
    09-20-19 10:14 PM
  14. RLeeSimon's Avatar
    It's lucky it worked because factory reset is a drudgery...
    Last edited by RLeeSimon; 09-21-19 at 10:20 AM.
    09-21-19 09:53 AM

Similar Threads

  1. Strange playbook issue
    By netrate in forum BlackBerry PlayBook
    Replies: 3
    Last Post: 09-17-19, 06:01 PM
  2. Priv doesn't want to charge
    By TJ_BB in forum BlackBerry Priv
    Replies: 3
    Last Post: 09-16-19, 04:23 PM
  3. Strange wireless issue w/ Key 2 LE (Freedom Mobile)
    By Apostata in forum General BlackBerry Discussion
    Replies: 4
    Last Post: 09-14-19, 01:47 PM
  4. Will there be any future software issues with the Blackberry KEY2?
    By Blackberry Keytwo in forum Ask a Question
    Replies: 1
    Last Post: 09-11-19, 10:28 AM
  5. screen lock issues
    By yeo123 in forum BlackBerry Motion
    Replies: 3
    Last Post: 09-10-19, 08:12 PM
LINK TO POST COPIED TO CLIPBOARD