1. luvsql's Avatar
    The builtin photos app was updated last week and since then, I either can't delete photos or get errors saying it can't delete, but eventually does delete. I do NOT have any cloud sync'ng setup. All of my photos are on my SD card and the Photos app can see them so this isn't an issue where the app doesn't have access to the SD card.

    Other than this builtin app, is there something better? I simply want to view images and not have to rely on the file explorer app to delete.

    Errors are "Can't delete item. Photos doesn't have access to delete items on your SD card. Go to the Gallery app to continue deleting."

    I then click on Launch Gallery and get a message "No apps can perform this action."

    Can't Delete from Photos App with latest update-error1.pngCan't Delete from Photos App with latest update-message2.png
    02-02-18 12:43 PM
  2. Bla1ze's Avatar
    Other than this builtin app, is there something better? I simply want to view images and not have to rely on the file explorer app to delete.
    Thousands of options...

    Try Piktures.

    It should ask you for permission to delete from sd card too but well, it'll work lol.
    02-02-18 01:07 PM
  3. TheBond's Avatar

    Errors are "Can't delete item. Photos doesn't have access to delete items on your SD card. Go to the Gallery app to continue deleting."

    I then click on Launch Gallery and get a message "No apps can perform this action."

    Click image for larger version. 

Name:	Error1.png 
Views:	43 
Size:	22.5 KB 
ID:	433952Click image for larger version. 

Name:	Message2.png 
Views:	42 
Size:	10.8 KB 
ID:	433953
    Looks like either you didn't give the app access to delete from SD card / External storage. I don't use other apps because I rely on Google Photos backup heavily.

    I don't use a SD Card on my KEYᵒⁿᵉ however for the purpose of testing I tried this.

    1. When I delete a photo from SD card using Photo app, it prompts me the very first time to give access.
    2. After two prompts and accepting them, its all set and I was able to delete.




    You can also verify whether your Photos app has access to the external card or not

    1. Open System Settings (from top right after pulling down the notification tray)
    2. Goto Apps > Photos > Storage
    3. You should find External Storage, probably at the bottom.



    If not then you haven't given access. If you still find issues then I suspect either there's some encryption on the SD card or its not formatted well. You may want to format the SD Card and retry.
    02-02-18 05:38 PM
  4. luvsql's Avatar
    This is a fairly new issue as I've had my Keyone for over 7 months now. There was an update to this app last week and this seems to be a fairly common google searched issue but no real solution. I do not have encryption on my SD card. I formatted my SD card ON the Keyone last month so it's formatted correctly. File Explorer sees and deletes fine. This is an issue specific to this app. I can download others, however, having an add-free free app would be way better.
    02-02-18 07:19 PM
  5. luvsql's Avatar
    I do have External Storage and it shows 2 Items.
    02-02-18 07:21 PM
  6. TheBond's Avatar
    I do have External Storage and it shows 2 Items.
    Perhaps remove the access as above.

    Then take a photo, assuming your camera is storing it on the SD Card. Go back to Photos app, select the photo and from the top right ellipsis choose delete from SD Card.

    It should prompt you for access again twice. See if that works.
    02-03-18 03:05 AM
  7. luvsql's Avatar
    On the current version of PHotos, when selecting the 3 dot button the option is "Delete from Device" which I've done. It then sits at Deleting at the bottom. This time it did eventually delete.

    I have verified that the info on the photo is in fact on my SD card (in the DCIM > Camera folder). I don't get any popups for access to delete.

    I think this latest update is just very buggy. Many others having same issue.
    02-03-18 09:38 AM
  8. TheBond's Avatar
    On the current version of PHotos, when selecting the 3 dot button the option is "Delete from Device" which I've done. It then sits at Deleting at the bottom. This time it did eventually delete.

    I have verified that the info on the photo is in fact on my SD card (in the DCIM > Camera folder). I don't get any popups for access to delete.

    I think this latest update is just very buggy. Many others having same issue.
    Seems like the update must have stuffed up permissions. I always worry about such updates. I'd rather do a back up and then do the update, followed by factory reset and restore.

    At least it'll keep the phone in optimum shape.
    02-03-18 10:27 AM

Similar Threads

  1. Problem with the contacts
    By kosiosl in forum BlackBerry KEYone
    Replies: 6
    Last Post: 03-14-18, 12:24 PM
  2. Shell/terminal apps in BB10, keyboard and paste
    By dpgo in forum BlackBerry 10 OS
    Replies: 6
    Last Post: 02-11-18, 03:32 PM
  3. Priv-After Marshmallow update Wifi-Calling no longer works
    By Privilage or Not in forum BlackBerry Priv
    Replies: 6
    Last Post: 02-09-18, 11:50 AM
  4. Replies: 2
    Last Post: 02-03-18, 06:44 AM
  5. DTEK50 boots only in a menu, after an update.
    By 3lxq8ht in forum Ask a Question
    Replies: 4
    Last Post: 02-02-18, 12:40 PM
LINK TO POST COPIED TO CLIPBOARD