1. NeoJia's Avatar
    Suddenly this happens today when I am trying to take a picture. then I have tried the following:

    1) Reset camera app and clean cache / data

    2) Safe mode

    3) Factory reset

    issue still exists

    Anybody has seen similar issue?

    I bought this one from Amazon, if it is warranty time, should I contact Amazon or Blackberry directly? anybody knows how long will the RMA take?
    07-09-17 03:41 AM
  2. russelldmorrow's Avatar
    Same happened for me. I contacted Amazon returns, completed the online questions, answered one email from their customer support team and had a new device in 2 days. UPS picked up the defective unit next day with Amazon’s return label. Very simple process for me other than having to set up the new phone again.
    07-09-17 10:25 AM
  3. NeoJia's Avatar
    Thanks a lot, you are lucky. Just called Amazon this morning, they don't have those phone in-stock, so I have to buy it from TCL on amazon.
    07-09-17 02:25 PM

Similar Threads

  1. BlackBerry Hub Android
    By My BlackBerry-10 in forum Ask a Question
    Replies: 5
    Last Post: 03-07-18, 10:26 AM
  2. KeyOne acting like Priv :(
    By denning in forum BlackBerry Android OS
    Replies: 4
    Last Post: 07-10-17, 09:11 AM
  3. Did Whatsapp stop working on bb by June 30?
    By donald rege in forum Ask a Question
    Replies: 7
    Last Post: 07-10-17, 08:28 AM
  4. Productivity Tab on Priv
    By Nicksydney348 in forum BlackBerry Priv
    Replies: 8
    Last Post: 07-09-17, 10:59 AM
  5. Replies: 0
    Last Post: 07-09-17, 01:49 AM
LINK TO POST COPIED TO CLIPBOARD