1. anon(1305645)'s Avatar
    Hi,

    so I got mine a month ago and was using actively AndroidAuto/Google Maps with my VW Passat (Builtin Satnav: MIB II - Discover Pro). Today after 2h of Google Maps Navigation I noticed that the screen of the Discover Pro froze. I then took the KeyOne and it was powered off. I can't switch it on anymore. When I connect the power cable nothing happens. It is just dead.

    I noticed since I bought it that it randomly rebooted (mostly when in it was in the pockets of my pants). Otherwise it seemed alright.

    Any idea how to get this thing working again?
    07-02-17 06:28 PM
  2. howarmat's Avatar
    leave it on the charger for an hour and see what happens.
    FF22 likes this.
    07-02-17 06:32 PM
  3. anon(1852343)'s Avatar
    sounds like a defective device and I would definitely send it back
    07-02-17 06:34 PM
  4. conite's Avatar
    Hold the power button down for 32 seconds.
    anon(1305645) likes this.
    07-02-17 07:32 PM
  5. anon(1305645)'s Avatar
    Thx @conite. Next morning it rebooted after holding the power button for approx 10 sec
    07-04-17 06:22 PM
  6. howsjau's Avatar
    Press both volume keys for ten seconds

    Posted via CB10
    07-04-17 07:26 PM
  7. nycspaces.'s Avatar
    sounds like a defective device and I would definitely send it back
    That or defective pants.
    07-04-17 07:28 PM
  8. Makaveli@Beta's Avatar
    yes buy better materials!
    07-04-17 08:11 PM
  9. mithrazor's Avatar
    Press both volume keys for ten seconds

    Posted via CB10
    I've had this happen to a friend's Windows phone. It just shut off and would not power on until he held the power button for 10 seconds
    07-04-17 08:29 PM
  10. conite's Avatar
    Press both volume keys for ten seconds

    Posted via CB10
    That or defective pants.
    yes buy better materials!
    I've had this happen to a friend's Windows phone. It just shut off and would not power on until he held the power button for 10 seconds
    Guys, problem was resolved in post 5.
    07-04-17 09:27 PM
  11. FF22's Avatar
    I don't know if it is a BB issue or other devices also take their time showing life if the battery gets depleted. I know on my various BB phones, that if I did run the battery completely down, that it would not show any signs of life (battery icon or led or...) for a couple to more than a couple of minutes. I found that just plug it in and leave it alone for 10-15 minutes and then it might show "life" or it may need the power button Pressed or rebooted.
    07-05-17 12:19 PM
  12. VeryBumpy's Avatar
    Press both volume keys for ten seconds

    Posted via CB10
    What is this suppose to do exactly?
    07-05-17 12:27 PM

Similar Threads

  1. Looking for Blackberry Priv
    By Idontgetiphones in forum Buy, Sell, Trade - Sold / Archived
    Replies: 7
    Last Post: 07-24-17, 08:59 AM
  2. When was the last time someone From BlackBerry spoke about BB10 OS
    By Sandeep Jain1 in forum BlackBerry 10 OS
    Replies: 94
    Last Post: 07-14-17, 02:35 AM
  3. Can you play MOV (Quicktime) video files on a Blackberry Z10?
    By crackberriest in forum General BlackBerry News, Discussion & Rumors
    Replies: 1
    Last Post: 07-03-17, 04:09 PM
  4. Which Keyone for Argentina? GSM
    By CrackBerry Question in forum Ask a Question
    Replies: 3
    Last Post: 07-03-17, 03:50 PM
  5. Replies: 1
    Last Post: 07-03-17, 12:07 PM
LINK TO POST COPIED TO CLIPBOARD