1. dannz89's Avatar
    Hi, I have searched for a long time and can't even find this issue raised let alone answered.

    Short question is, when I go into settings->storage->Scandisk SD card, I get a glimpse of the SD card settings / storage breakdown then get bounced straight back out to the Storage overview (where you can see the different storage types available and how much is used / free) or even the main settings menu itself. Sometimes it's so quick I don't even get the glimpse.

    I can't see my new SD card in Files app even though the system knows it's there and can interact with it; not a big issue but I think (based on the below) something's not right.

    Longer background:

    I recently had trouble with apps either installed on or using my external SD card (It was a ScanDisk 180GB) card. The first symptom I noticed was the above but that was only after I started noticing that various apps - I narrowed it down to a list of about 7 - would not update in google play, they just hung on download. Looking at those, I saw they were all installed on the SD card.

    While those apps worked, they did weird things like not showing images or not being able to download videos from within them or whatever.; WeChat was the one I used most They threw up a few warnings too like 'cannot access videos, images or GIFs because external storage is unavailable, please restart to fix' (which clearly I tried but it didn't work). I could move them off the card OK but they still didn't quite work and wouldn't update in Google play until I uninstalled and reinstalled.

    The phone could read the card and I could navigate it with the 'Files' app or even windows explorer if I connected the phone in transfer mode but nothing could delete from / write to it. After trying various things: virus checking, uninstalling apps, clearing various caches and data, trying to reformat the card (the phone couldn't even reformat it and neither could windows even with a long format; it got right to the end after a couple of hours then said it couldn't complete the format and all the data was still there), I deemed the card corrupt and took it out.

    I replaced the card with a new ScanDisk 256 GB card. I formatted the card as internal storage successfully and it shows a few GB used and the rest free. I experimentally moved and app to the card and all fine. But then I took a photo and although it took, the camera threw up a warning about there only being on board storage available (although I think that might be because I somehow set the camera to use the SD card before).

    Well, it seems I can move apps on and off the SD card ok still but the original issue I mentioned is still happening - I go into settings->storage->ScanDisk SD card and bam! Straight back out to main settings menu. I also can't see it Files app.

    Phone specs are:

    I have a BB KeyOne running Android 8.1.0
    China Mobile contract (although I bought the phone unlocked in the UK and previously had a UK Vodafone SIM in it(
    Model BBB100-2
    Patch level 5 Mar 2019
    Baseband version: MPSS. TA.2.3.c1-00723-8953_GEN_PACK-1.185906.1.190315.2
    Kernel version: 3.18.71.per.gc924168 (gcc version 4.9.x 20150123 (prerelease) (GCC) ) ecagent@br631cnc #1 Fri Mar 1 01:13:32 EST 2019
    Build number ABS154

    Any help appreciated.
    Best wishes,
    Dan
    09-02-19 01:03 AM
  2. RLeeSimon's Avatar
    I don't know if this helps or even relates. I had my whole like on my 400gb SanDisk card and it started dismounting... it would remount. I right away put the card in my windows10 computer and copied the whole thing to a new card (512gb Samsung). it took quite a while to complete. fantastic result, no data lost. I've never had a microSDXC failure and I feel very lucky. I have iDrive cloud unlimited lifetime, so now I let it back up everything so I don't gut punked. what occurred? I'll likely never now. windows10 offered to repair the card on recognition but failed to do it several times.

    I believe the take home lesson is:

    back up everything
    don't put ail your eggs on a card
    did I say, BACK UP EVERYTHING?
    09-02-19 01:40 PM

Similar Threads

  1. BlackBerry Travel
    By Crusader03 in forum BlackBerry Passport
    Replies: 15
    Last Post: 09-19-19, 07:52 PM
  2. Can't turn off "character" suggestions on Key2
    By tommichael88 in forum BlackBerry KEY2
    Replies: 4
    Last Post: 09-03-19, 11:25 PM
  3. Replies: 4
    Last Post: 09-03-19, 07:08 PM
  4. Universal Remote with BlackBerry PKB??
    By bb10adopter111 in forum General BlackBerry Discussion
    Replies: 5
    Last Post: 09-03-19, 06:32 PM
  5. BlackBerry work app freezing iPad Pro
    By jisola in forum Ask a Question
    Replies: 1
    Last Post: 09-03-19, 09:35 AM
LINK TO POST COPIED TO CLIPBOARD