1. RLeeSimon's Avatar
    I got a newish appearing KEYᵒⁿᵉ advanced replacement in October for screen pop.

    I charge always via a USB-c connected to QI receiver around back under an Amzer snap on placed on a QI charge stand output 5v 1a.

    Occasionally I feel the device get warm and the charge stalls at once 72% and just now 93% ... I took it off, let it cool, put it on, and it completed charge to 100% with no heating.

    Any explanation?
    12-25-18 01:18 PM
  2. anon(4297019)'s Avatar
    I got a newish appearing KEYᵒⁿᵉ advanced replacement in October for screen pop.

    I charge always via a USB-c connected to QI receiver around back under an Amzer snap on placed on a QI charge stand output 5v 1a.

    Occasionally I feel the device get warm and the charge stalls at once 72% and just now 93% ... I took it off, let it cool, put it on, and it completed charge to 100% with no heating.

    Any explanation?
    Try charging it with a correct power source directly to the USB port and report back with the results.
    12-25-18 09:55 PM

Similar Threads

  1. Blackberry Classic Battery Issue
    By Alison Jason in forum BlackBerry Classic
    Replies: 3
    Last Post: 05-02-19, 06:28 PM
  2. User removable batteries
    By The_Passporter in forum General BlackBerry Discussion
    Replies: 57
    Last Post: 01-22-19, 07:50 AM
  3. Priv no longer charges after Google Update
    By rohanpriv123 in forum BlackBerry Priv
    Replies: 8
    Last Post: 12-25-18, 01:23 PM
  4. Battery DTEK60 NO CHARGE and flashing Red Light
    By derekmulveen in forum BlackBerry DTEK60
    Replies: 0
    Last Post: 12-23-18, 06:38 AM
  5. Battery draining issue
    By ElGorgon in forum BlackBerry KEY2 LE
    Replies: 0
    Last Post: 12-22-18, 03:54 AM
LINK TO POST COPIED TO CLIPBOARD