1. Seiks's Avatar
    I have an unlocked US KEYone that I'm using on Fido but am not able to get LTE+. Have used a Bell SIM and am able to get Bell's LTE+ - wondering if others are able to get LTE+ on Rogers or Fido before I settle on it being a cosmetic issue that the "+" does not appear due to Fido carrier settings.

    I also don't seem to get VoLTE calling on Fido.

    Been going in circles in a Fido forum chat on this haha:
    Solved: Re: BlackBerry KEYone - Page 3 - Fido
    01-09-18 12:30 AM
  2. Carlito27's Avatar
    I'm with Fido with silver keyone and I don't think I ever saw the +- next to LTE, I checked my IMS settings and voLTE and LTE video calling are both enabled. Maybe it's just that Fido does not have LTE+- coverage in that region?
    01-09-18 10:48 AM
  3. booker1953's Avatar
    Same with mine in Sherwood Park, Alberta.
    01-09-18 02:57 PM
  4. silentbystander's Avatar
    I have VoLTE working on Rogers with my Keyone BE. LTE band reach is much better in my condo than 4G, and I was unable to take calls on 4G within my condo. It was an extremely painful process, because they don't want 'unlocked' phones getting access to value add services like VoLTE or Wifi Calling.

    Eventually I filed a complaint with CCTS, got the case escalated to a tier 2 tech support team leader, and they found "a work around". Everything they tell you about it not being possible to get VoLTE working on their network with an unlocked phone is bull****. But at the same time it's not just a question of white listing your phone's IMEI.

    I wish you luck.
    01-09-18 04:12 PM
  5. Seiks's Avatar
    Thanks for the feedback guys. I'll keep bugging them on this when I have time. My IMS setting say "not connected" even though they're set on. Fingers crossed haha
    01-09-18 10:26 PM
  6. anon(870071)'s Avatar
    I have an unlocked US KEYone that I'm using on Fido but am not able to get LTE+. Have used a Bell SIM and am able to get Bell's LTE+ - wondering if others are able to get LTE+ on Rogers or Fido before I settle on it being a cosmetic issue that the "+" does not appear due to Fido carrier settings.

    I also don't seem to get VoLTE calling on Fido.

    Been going in circles in a Fido forum chat on this haha:
    Solved: Re: BlackBerry KEYone - Page 3 - Fido
    I had use an original Silver model locked to Rogers and IMS settings were working! Now using the unlocked black edition and definitely IMS is "not connected" with a Rogers Sim inserted!
    01-10-18 04:15 AM

Similar Threads

  1. Any official word on Oreo?
    By Drg84 in forum BlackBerry KEYone
    Replies: 115
    Last Post: 01-12-18, 02:17 PM
  2. Replies: 3
    Last Post: 01-10-18, 04:52 PM
  3. AT&T WiFi calling
    By bog131 in forum BlackBerry Mobile Support
    Replies: 2
    Last Post: 01-10-18, 01:32 AM
  4. Day dream keyone on IOS11
    By thesinex in forum BlackBerry KEYone
    Replies: 5
    Last Post: 01-09-18, 10:04 AM
  5. Replies: 0
    Last Post: 01-08-18, 10:07 PM
LINK TO POST COPIED TO CLIPBOARD