1. neuropre's Avatar
    Hi folks, I am loving my K2LE after using it for approx 3 months now. However, one issue has arisen and gotten worse in the last 2-3 wks.

    I can send and receive MMS/SMS texts for all devices with the exception of to my significant other. Lately when they send me something, including both text and pictures (more pictures / MMS though), I get the following placeholder. If I ever click on it, I get an unknown message sender listed in my texts and no actual text. My SO is getting tired of sending me stuff. This isn't happening with anyone else from what I can tell. And no issues when I send to her.

    My SO is using iOS on iPhone 7 on ATT. I am on Straight Talk (ATT MVNO).

    I have tried hard reset, Sim card removal, but no dice.

    Any help is greatly appreciated, esp since it will get my SO no longer upset with me!Probs w/ texts from 1 iOS device-notable-00113.jpeg
    03-14-19 04:13 PM
  2. glwerry's Avatar
    Hi folks, I am loving my K2LE after using it for approx 3 months now. However, one issue has arisen and gotten worse in the last 2-3 wks.

    I can send and receive MMS/SMS texts for all devices with the exception of to my significant other. Lately when they send me something, including both text and pictures (more pictures / MMS though), I get the following placeholder. If I ever click on it, I get an unknown message sender listed in my texts and no actual text. My SO is getting tired of sending me stuff. This isn't happening with anyone else from what I can tell. And no issues when I send to her.

    My SO is using iOS on iPhone 7 on ATT. I am on Straight Talk (ATT MVNO).

    I have tried hard reset, Sim card removal, but no dice.

    Any help is greatly appreciated, esp since it will get my SO no longer upset with me!Click image for larger version. 

Name:	NOTABLE-00113.jpeg 
Views:	17 
Size:	46.8 KB 
ID:	443391
    I think that this is an Android issue and you have to set your phone so that you're using CELLULAR connection to receive MMS messages.
    I had this problem when I went to my PRIV a couple of years back.

    I don't remember how to do this but you can Google it.
    kalphreef likes this.
    03-14-19 04:45 PM
  3. neuropre's Avatar
    I think that this is an Android issue and you have to set your phone so that you're using CELLULAR connection to receive MMS messages.
    I had this problem when I went to my PRIV a couple of years back.

    I don't remember how to do this but you can Google it.
    Thanks for your response. I tried looking up alternative APN addresses online for Straight Talk via ATT. I can enter ones that make the MMS with my SO work fine (although MMS with others worked fine previously through iOS just not hers). However then I lose the ability to use the data connection.

    Guess I will have to pick my poison.

    Sigh.
    03-14-19 08:58 PM
  4. glwerry's Avatar
    Uh, I don't remember having to change my APN address. It was a setting just on the phone.

    Try googling "android unable to receive mms message".
    03-15-19 09:45 AM
  5. neuropre's Avatar
    Most things I could find were about the APN. The one thing I discovered randomly is as below. That was somehow set to off so changed it to ON. Let's see if that makes any diff. Thanks!Probs w/ texts from 1 iOS device-notable-00121.jpeg
    03-15-19 01:12 PM
  6. neuropre's Avatar
    I left out the part about - is this the item you were talking about? I also went into phone settings using *#*#46368676#*#* and didn't see anything regarding MMS or SMS there.

    An old thread mentioned that there is something using *#*#4636#*#* but that doesn't work on my K2LE At least.
    03-15-19 01:54 PM
  7. neuropre's Avatar
    So there is an improvement with receiving character texts, but still having problems with pictures/videos from just my SO still whether as the sole recipient or group MMS. Things from others are coming through without issue from what I can tell.

    Thanks.
    03-18-19 08:21 PM
  8. spARTacus's Avatar
    Did you come from an iPhone just before and if so did you fully "de register" from iMessaging?

    Posted via CB10 on Z10
    03-18-19 08:34 PM
  9. neuropre's Avatar
    Sorry no, I have been an android user since 2011.
    Yesterday 01:07 AM
  10. spARTacus's Avatar
    Did ATT offer you any suggestions for fixing it?

    Posted via CB10 on Z10
    Yesterday 05:42 AM
  11. neuropre's Avatar
    Straight Talk, which is an MVNO that uses AT&T, is useless unfortunately when it comes to help beyond activating a phone.
    Yesterday 11:57 PM

Similar Threads

  1. Killed off my texting
    By ArbuckleWillis in forum BlackBerry KEY2 LE
    Replies: 9
    Last Post: Yesterday, 09:56 AM
  2. Autoloaders have moved from MEGA
    By fergusd in forum BlackBerry 10 OS
    Replies: 9
    Last Post: 03-17-19, 11:29 PM
  3. Time to move on from the Priv???
    By Tech Idiot in forum BlackBerry Priv
    Replies: 15
    Last Post: 03-16-19, 06:52 PM
  4. you can only access this conversation from this device
    By XxWile_E_CoyotexX in forum eBBM Suite & BBM Protected
    Replies: 0
    Last Post: 03-14-19, 10:26 AM
  5. How do you stream music from Key 2 LE to USB input?
    By Machinests in forum BlackBerry KEY2
    Replies: 1
    Last Post: 03-13-19, 03:52 PM
LINK TO POST COPIED TO CLIPBOARD