Sign up now for Disney+
  1. fop518's Avatar
    Sorry, no. Only indicator is on the screen when you make the call. No way from the settings that are accessible to get that indicator back.

    Also, yes, I cannot get QSM to create a shortcut. Not sure why that is, but I also have not tried contacting the developer about that, so that would be the other option.

    And after a reboot this does go away, no way around it that I have found. But at least it's only a switch and not the whole thing. Slightly annoying, sure, but I'll take annoying to have the WiFi calling lol.
    You don't think any setting in arda or elsewhere in QSM would turn on the indicator? It must be there somewhere.

    Also I wish someone could explain why BlackBerry removed this feature when it clearly worked. Does anyone know if the US LE versions work with wfc?
    04-22-19 02:04 PM
  2. jelp2's Avatar
    SWEET! Thanks @fop518 ! That works like a charm, found it in shortcuts as well. Save me 2 clicks! Lol
    In my case though, even if I switch to cellular only it still makes wifi calls. Which is fine, but if I just want cellular I have to toggle wifi calling off.
    04-22-19 05:12 PM
  3. ThaSwapMeetPimp's Avatar
    hate to burst bubbles, but...followed your instructions. got the little wifi calling icon. I don't think it's actually wifi calling though and this is why: it won't start making the call unless you are on a carrier signal. I need wifi calling because my house has super thick walls and it is a signal deadzone. can't initiate a call without the carrier signal is effectively no wifi calling, just an icon to make us think it is

    Edit: calling preference had reverted to cellular preferred. Next time I lose signal will see if it makes the call. Wish I could just toggle the stupid cell network off but no options for that that I can see
    Last edited by ThaSwapMeetPimp; 04-25-19 at 12:56 AM.
    04-25-19 12:39 AM
  4. Chris_R's Avatar
    I got one question for the experienced here for the reason for using WiFi calling in general.

    In Germany T-mob will charge as per normal even if i use WiFi calling. Is this the same in the US? For me there's no reason to use it!?

    On a side note, my Key2 must have received/enabled WiFi calling in one of the recent updates. Or at least I haven't seen the switch before.
    04-25-19 06:09 AM
  5. ThaSwapMeetPimp's Avatar
    I got one question for the experienced here for the reason for using WiFi calling in general.

    In Germany T-mob will charge as per normal even if i use WiFi calling. Is this the same in the US? For me there's no reason to use it!?

    On a side note, my Key2 must have received/enabled WiFi calling in one of the recent updates. Or at least I haven't seen the switch before.
    I have an unlimited data plan and the walls in my house are super dense for some reason (need a concrete drill to get into them, but they are not concrete), also at least with my last few blackberries I would lose signal immediately upon stepping foot within the boundaries of the property, (not my key2 though, just once I'm inside) so I rely on wifi calling so I don't have to go outside and possibly off property in order to get a carrier signal, the call is carried by the wifi in my house.
    04-25-19 12:24 PM
  6. jelp2's Avatar
    hate to burst bubbles, but...followed your instructions. got the little wifi calling icon. I don't think it's actually wifi calling though and this is why: it won't start making the call unless you are on a carrier signal. I need wifi calling because my house has super thick walls and it is a signal deadzone. can't initiate a call without the carrier signal is effectively no wifi calling, just an icon to make us think it is

    Edit: calling preference had reverted to cellular preferred. Next time I lose signal will see if it makes the call. Wish I could just toggle the stupid cell network off but no options for that that I can see
    You can toggle airplane mode and then turn on wifi. It'll work, I have cellular off and wifi on and its making a wifi call. Wi-Fi calling working.-notable-00008.jpg
    04-26-19 04:16 PM
  7. fop518's Avatar
    well my ota upgrade to april abt974 failed with an error code 3305. it rebooted and said update failed but it has updated my build # and patch level... however the wfc still works and I think my modem wasnt upgraded. this happened with my keyone when I tried a different modem... I think ota's only half work.
    probably not a huge deal
    04-28-19 11:58 AM
  8. flyhayes's Avatar
    ...-(note on the below, if you do not have any options in Advanced Calling let me know, might be another step to get that to show up)-...
    @Summer_Moon, I had no joy finding this option in the QSM. Those extra instructions would be highly appreciated.
    05-04-19 10:04 PM
  9. jelp2's Avatar
    well my ota upgrade to april abt974 failed with an error code 3305. it rebooted and said update failed but it has updated my build # and patch level... however the wfc still works and I think my modem wasnt upgraded. this happened with my keyone when I tried a different modem... I think ota's only half work.
    probably not a huge deal
    The past 2 OTA's said the same thing when I downloaded them. I took about 3 reboots for them to load. Maybe it's the old modem throwing it off or android OTA's just suck. Don't know.
    05-05-19 01:39 PM
  10. Christian_Haitian's Avatar
    First you'll need to enable Developer Options on your phone, and in the options scroll down to Debugging section and make sure that USB debugging and USB debugging in charging mode is toggled on.

    Plug in your phone to your computer using USB (I've had flaky connection with some ports/cables, so might have to try the commands multiple times, or find the right combination for ports and cables for a stable connection). It should recognize the connection on the phone and make sure to select charge and data and then transfer files option on the phone when it's connected.

    Download the zip file from this link https://mega.nz/#!V5owHArY!yPCQCcmXR...GqiTmPtMxiUz-M and extract to a directory on your computer (doesn't really matter where as long as you know where to find it). Navigate to the folder where you extracted it to. Then hold your left shift key and right-click in the folder (empty space) and choose open cmd prompt here (might say powershell instead of cmd prompt depending on your Windows setup, either will work).

    Once at the shell (it should show that you are in the folder where you extracted the files) you will want to run the following commands (without the quotes):

    ".\bin\adb devices" this should show you what devices are attached to your computer, the first time you run it, it should start up the service. I always run it again after it starts the service to make sure the phone is listed as an attached device.

    ".\bin\adb shell settings put global wfc_ims_enabled1 1" this will write a 1 to the wfc_ims_enabled1 flag in the global settings. Also, might be useful to get the SetEdit app on your phone and check the Global table and scroll to wfc_ims_enabled1 and see what it's at prior to writing it, there's a few other wifi calling and ims settings in that table, but all of mine were on (1) already except for wfc_ims_enabled1

    The next portion is to write the ABA044 modem to your device. You'll have to disable any pin lock that you have on your phone in settings first. Then restart your phone into fastboot mode by holding power and volume down at the same time and keep holding it until it is in fastboot.

    Then in your cmd prompt (or powershell) use the following command to write the modem (without quotes):

    ".\bin\fastboot.exe flash modem .\NON-HLOS.bin" this writes the americas modem, so you may want to make sure that you have the right PRD for this. My PRD is PRD-63825-003, I believe ABA044 should work for any BBF100-2 device. And of course you can try on a different one, but I have no way to guarantee it will work or be able to get your original modem back other than to download your autoloader and load it back onto your phone.

    Then reboot your phone using the fastboot menu. Go back through the original set of steps and give wifi calling another try.

    And that should be the complete number of steps/settings that I did on my device.
    These instructions work excellently for my Blackberry Key 2 on T-Mobile. I was contemplating on selling my phone and getting a One Plus 6T just because of WFC but after this fix, I am keeping my wonderful phone. Not sure why TCL got rid of this feature on it because it works so well. Thanks again for your research and sharing your findings. Now here's hoping TCL doesn't release an update that disables this again.
    Summer_Moon likes this.
    05-05-19 02:28 PM
  11. Summer_Moon's Avatar
    @Summer_Moon, I had no joy finding this option in the QSM. Those extra instructions would be highly appreciated.
    Well it's been quite a while back now and I don't fully remember what setting will make that Advanced Calling show up. I'll have to try to remember where it's at. However, I don't think that step is actually necessary. The biggest part is the old modem loaded and to turn on wifi calling provisioned in the dialer code.
    05-05-19 06:01 PM
  12. flyhayes's Avatar
    Well it's been quite a while back now and I don't fully remember what setting will make that Advanced Calling show up. I'll have to try to remember where it's at. However, I don't think that step is actually necessary. The biggest part is the old modem loaded and to turn on wifi calling provisioned in the dialer code.
    I actually got it working late last night. The "Advanced Calling" wasn't in the root menu area of the QSM as the original directions seemed to indicate. Instead it was located under "Settings". At least for me. Thanks for a great tutorial, this was the one thing holding me back from upgrading my Passport to a Key2. This thread is the sole reason I took the leap.
    Summer_Moon likes this.
    05-05-19 06:15 PM
  13. enik's Avatar
    So I can confirm that the modem worked on my Indian model. It did toggle off power to the mobile radio for some reason, but now I'm getting wifi calling.
    Summer_Moon likes this.
    05-06-19 06:37 PM
  14. fop518's Avatar
    one thing I will say is wfc is a bit buggy. sometimes audio stops working or it wont engage. resetting the modem in arda via qms seems to fix it. still better than nothing. from what im gathering via some contacts at tmobile, tcl is not going to put much effort in enabling or fixing this. im not sure how rogers managed to get this officially supported.
    Summer_Moon likes this.
    05-06-19 08:14 PM
  15. scubafan's Avatar
    Question, does anyone know whether VoWiFi can work with AT&T?

    Just my $.02, YMMV ! ;-) sent via my Q10
    05-07-19 05:49 AM
  16. IceCreamPlz's Avatar
    Question, does anyone know whether VoWiFi can work with AT&T?

    Just my $.02, YMMV ! ;-) sent via my Q10
    Does not work.
    05-07-19 09:24 AM
  17. Summer_Moon's Avatar
    Question, does anyone know whether VoWiFi can work with AT&T?

    Just my $.02, YMMV ! ;-) sent via my Q10
    Like IceCreamPlz said, doesn't work. Unless you happen to have your SIM card provisioned to allow IMS. But it's one of the main reasons I left AT&T (Cricket) and went to T-Mobile (Ultra Mobile).
    05-07-19 11:36 AM
  18. fop518's Avatar
    I think in the us we are talking tmobile only. keyone had wfc calling support on tmobile the whole time I believe. key2 only worked on first os release for some reason
    Summer_Moon and megafan2000 like this.
    05-07-19 11:48 PM
  19. Ntario's Avatar
    I was able to get Wi-Fi calling to work on my unlocked Key2 on the Rogers network through tech support. It took some time as they insisted I needed a rogers device for it to work. Bottom line is it's a lie. Reason I know this is I swapped SIM card with my wife who has an S10+ with Wi-Fi calling working. Once her SIM was in my phone, the Wi-Fi calling worked with no issues. when I put my SIM in the S10+ Wi-Fi calling didn't work. Long story short it turns out her account had VoLTE enabled and mine didn't. After a bit of arguing with the tech, I escalated the call and had a manager have the tech enable it on my phone. Yes, I was told it was not possible, but with a threat of leaving the carrier it somehow became possible. Now I have Wi-Fi calling and VoLTE. Happy it works, not happy with what the carriers are doing.
    Crusader03 likes this.
    05-30-19 04:50 PM
  20. Crusader03's Avatar
    I was able to get Wi-Fi calling to work on my unlocked Key2 on the Rogers network through tech support. It took some time as they insisted I needed a rogers device for it to work. Bottom line is it's a lie. Reason I know this is I swapped SIM card with my wife who has an S10+ with Wi-Fi calling working. Once her SIM was in my phone, the Wi-Fi calling worked with no issues. when I put my SIM in the S10+ Wi-Fi calling didn't work. Long story short it turns out her account had VoLTE enabled and mine didn't. After a bit of arguing with the tech, I escalated the call and had a manager have the tech enable it on my phone. Yes, I was told it was not possible, but with a threat of leaving the carrier it somehow became possible. Now I have Wi-Fi calling and VoLTE. Happy it works, not happy with what the carriers are doing.
    I am also on Rogers. Have tried with them many times and no joy. I have a NA unlocked device. Is yours also a NA device or a Rogers device? Just confirming before I give them another call. Thanks,
    05-30-19 09:35 PM
  21. Ntario's Avatar
    I am also on Rogers. Have tried with them many times and no joy. I have a NA unlocked device. Is yours also a NA device or a Rogers device? Just confirming before I give them another call. Thanks,
    My device is not a rogers device
    06-01-19 04:42 PM
  22. Crusader03's Avatar
    My device is not a rogers device
    Well, tried again yesterday and spoke with the President's office and no joy. They say they cannot do it.
    06-01-19 06:04 PM
  23. Ntario's Avatar
    Well, tried again yesterday and spoke with the President's office and no joy. They say they cannot do it.
    It's all lies. They reluctantly did it for me. It's a all about enabling VoLTE on the accountWi-Fi calling working.-32027.jpg
    06-02-19 06:52 AM
  24. anon(10562251)'s Avatar
    It's all lies. They reluctantly did it for me. It's a all about enabling VoLTE on the accountClick image for larger version. 

Name:	32027.jpg 
Views:	31 
Size:	35.0 KB 
ID:	444662
    On Telus I have VoLTE but no Wi-Fi calling. Called in about it and they told me it wasn't supported on the Key2. The feature is also enabled on my account.

    The difference in your case is that Rogers supports both features. With the rules in Canada regarding unlocked phones, technically they can't deny service if you are paying for the feature and you have the exact same model.

    I agree though that in all cases, and if the phone supports the feature - it is simply a matter of the carrier allowing the phone to register on the network. Of course they will come up with all kinds of excuses as to why that can't happen, such as testing, the carrier doesn't sell it, etc.

    I had Wi-Fi calling on my Pixel 3 and quite frankly I wasn't impressed. Despite having a great Wi-Fi signal the calls were spotty and inconsistent, and once I left the house it booted me to HSPA and failed to register VoLTE. So for anyone who is missing it I would say on Android at least, it still has a long way to go.
    Crusader03 likes this.
    06-02-19 10:17 AM
  25. bob bagheri's Avatar
    I've followed all the steps and now stuck on the advanced calling, where I can't find any options... any way to get that? Thanks...
    06-02-19 06:12 PM
101 12345

Similar Threads

  1. Replies: 10
    Last Post: 04-24-19, 01:53 AM
  2. Your stickers wont work on BlackBerry Enterprise's BBMe.
    By yye74807 in forum General BlackBerry Discussion
    Replies: 17
    Last Post: 04-21-19, 04:49 PM
  3. speaker stopped working
    By mtalinm in forum BlackBerry KEY2
    Replies: 1
    Last Post: 04-20-19, 03:14 PM
  4. Replies: 4
    Last Post: 04-19-19, 10:07 PM
  5. Replies: 1
    Last Post: 04-18-19, 06:14 PM
LINK TO POST COPIED TO CLIPBOARD