12-04-19 08:13 AM
103 1234 ...
tools
  1. drkohut's Avatar
    Right, tested earlier in town and verified VoLTE without WiFi connected. Connected to WiFi back home and back to WiFi calling
    So future firmware updates won't negate these changes? Or do we have to redo this after every update?
    02-12-19 10:09 PM
  2. Summer_Moon's Avatar
    So future firmware updates won't negate these changes? Or do we have to redo this after every update?
    That remains to be something that will have to be tested. If you use the OTA update then yes this will go away and you will have to redo it assuming BBMo hasn't closed some of these settings from being able to be edited. If you use autoloader and comment out the modem line in the script then you won't lose that part. But I don't know if you would lose any of the changes in ARDA, the flag values, or the other settings that were changed in QSM.
    02-13-19 06:08 AM
  3. Summer_Moon's Avatar
    Just a quick note for anyone who did these steps to enable WiFi calling and wondering if it will go away after an update. I just ran the autoloader for ABP924 on my phone. The only things that I had to do to get it back was:

    1) commented out the modem line in the no wipe script (use notepad or something similar and put "REM" in front of the modem line, which is right under the commented out userdata line in the script)
    2) after I finished installing and rebooted I went back into *#*#46368676#*#* and toggled WiFi calling provisioned back on

    So a lot easier after you have already done all of the steps to be able to get it back after an update.

    I know all of you below did these steps so figured you would want this info
    @drkohut @jelp2 @JKames
    strikeIII, jelp2 and Crusader03 like this.
    02-15-19 04:26 PM
  4. miketedeschi's Avatar
    It's nice not having a constant notification that wifi calling is on.
    i couldn't disagree with you more, especially not having wi-fi calling for so long. i miss that icon...

    doesn't seem to be working for me, even with the old modem. but, wifi calling is provisioned toggle was on for me on t-mobile.

    Edit: it started working! Yes
    Last edited by miketedeschi; 02-18-19 at 07:30 PM.
    02-17-19 12:44 PM
  5. Chuck Finley69's Avatar
    So here is everything that I did, I am not sure if all of it needs to be done or only some of it, or some combination of it.

    The #1 important piece here is that you need to check if the toggle for WiFi calling provisioned is available in the phone information. To do this open your dialer and use dial code *#*#46368676#*#* and click on Phone Information at the to. In the next screen towards the bottom should be several toggles, one of these will say Wi-Fi calling provisioned. If you are able to toggle this on or is already turned on you should be good to continue. If you are not able to, I doubt any of the rest of this will help.

    Next, while you are still in the Phone Information section click on the 3 dots in the upper right hand corner and click on IMS Service Status. Make sure this says Registered, if it doesn't, again I am not sure the rest of this will help.

    Next, open up QuickShortcutMaker aka QSM (can get it from the Play Store) and click on ARDA, then ARDA again and click Try. In here click on IMS. At the top make sure that IMS service daemon is toggled on. Then click on IMS General Settings. Check your IMS User Agent, I am curious what everyone's is set to so if you wouldn't mind copying out what's there and posting it, that would be great. Mine is set to "T-Mobile VoLTE-RCS-ePDG-IR94-RTT-ussd" (no quotes). Then click back.

    Still in the IMS main page, click on IMS Services. Verify that Wi-Fi Calling (WFC) is toggled on in both Provisioned Settings and the User Settings. It's also necessary to click back out of this page and go back in it. If the toggles stay and don't flip back, then you're good. If they do flip back to off, then this is probably going to be a no-go for you.

    Back onto the IMS main page click on VoWiFi. In here first make sure that the VoWiFi MDN field is set to your phone number including country and area code. Toggle VoWiFi Enabled to On and check that the VoWiFi Roaming Preference is set to WiFi Preferred. There's another setting in here that we'll come back to later and which ultimately ended up making this work for me.

    Back on the IMS main page click on IMS Developer Tools and click on Tap to reset modem now. You should see your cell signal drop and then reconnect (also every once in a while WiFi won't come back until you actually manually go to WiFi and reconnect it yourself).

    Now back out of ARDA back into QSM scroll down to Phone Services and open that, then find Wi-Fi Calling. Click on that and click Try. Should open up a page where Wi-Fi calling toggle is on and has a selection of Wi-Fi Preferred, Wi-Fi only or Cellular network preferred. I have mine set to Wi-Fi Preferred.

    Back into QSM scroll down to Settings, open that and find Wi-Fi calling (should be fairly close to the bottom of the Settings list, probably easier to search from the bottom up), there are 2 of them right next to each other, either of them will work. Tap on try for that and verify that the toggle here is OFF. Yes, you read that correctly, this toggle should be off.

    -(note on the below, if you do not have any options in Advanced Calling let me know, might be another step to get that to show up)-
    Back into QSM and scroll down a little to Advanced Calling, tap try for that and it should bring up an option that says something like Activate Wi-Fi Calling, or Tap here to activate. Tap on Wi-Fi calling and it will bring up an error saying not activated, try again later and a little notice at the bottom that says Wi-Fi calling activated. Ignore the error and tap on Wi-Fi calling again. Should take you to another screen where the toggle for Wi-Fi calling is on and have 2 options under it. Tap on the Update Current Emergency Address, you'll get another error saying it failed with a notice at the bottom saying successful. Ignore the error and exit back to QSM.

    Back in QSM scroll down to Calling PLUS, click on try and verify the toggle is On.

    Now enable Airplane mode, wait a few seconds, and disable Airplane mode. Wait for wifi to reconnect and try calling someone, should hopefully see wifi calling like in my first post show up on the call. If it doesn't give this next part a try.

    Back into QSM -> ARDA -> IMS -> VoWiFi and scroll down to the Emergency Address Management section, on the Use Empty Authentication Token put a check mark in the box. Exit out and give another try at calling, ultimately this check box is what finally got my phone to make wifi calls.

    Let me know if this works for anyone else or if there are questions. It may or may not work, but would be curious based on how it does for others what the right combination from above is to get it to work.
    I confirm this is very helpful. I’ve used the instructions on my AT&T carrier branded and locked KEYone. Of course WFC is not enabled and toggle is grayed out. However, VoLTE is adjustable from here, enable toggle capable and turned on.

    It appears that I’ve never lost VoLTE since Oreo upgrade but still don’t have WFC and probably never ever will.
    02-17-19 01:10 PM
  6. Summer_Moon's Avatar
    i couldn't disagree with you more, especially not having wi-fi calling for so long. i miss that icon...

    doesn't seem to be working for me, even with the old modem. but, wifi calling is provisioned toggle was on for me on t-mobile.
    Sorry to hear it didn't work for you. But without actually having the device in my hand I can't say for sure which step, or additional step you would need to get it to work.

    Also, I've been looking for the icon, but have not found a way to get the icon to be permanently there.
    02-17-19 02:21 PM
  7. jelp2's Avatar
    i couldn't disagree with you more, especially not having wi-fi calling for so long. i miss that icon...

    doesn't seem to be working for me, even with the old modem. but, wifi calling is provisioned toggle was on for me on t-mobile.
    I remember the last thing on my PRIV was an ongoing wifi calling enabled banner. That's what I was talking about. It was annoying.
    I don't get the small wifi calling icon when I make a call, but the call screen itself show wifi calling just before the call connects.
    02-18-19 10:03 AM
  8. jelp2's Avatar
    Just a quick note for anyone who did these steps to enable WiFi calling and wondering if it will go away after an update. I just ran the autoloader for ABP924 on my phone. The only things that I had to do to get it back was:

    1) commented out the modem line in the no wipe script (use notepad or something similar and put "REM" in front of the modem line, which is right under the commented out userdata line in the script)
    2) after I finished installing and rebooted I went back into *#*#46368676#*#* and toggled WiFi calling provisioned back on

    So a lot easier after you have already done all of the steps to be able to get it back after an update.

    I know all of you below did these steps so figured you would want this info
    @drkohut @jelp2 @JKames
    Is there any way to do that if we use OTA update?
    02-18-19 10:13 AM
  9. Summer_Moon's Avatar
    Is there any way to do that if we use OTA update?
    If you use OTA update it will overwrite the modem. So you would have to manually write the older modem back. Not sure if the other settings would remain or not. You might have to go back through the whole steps again.
    02-18-19 10:58 AM
  10. jelp2's Avatar
    If you use OTA update it will overwrite the modem. So you would have to manually write the older modem back. Not sure if the other settings would remain or not. You might have to go back through the whole steps again.
    Thought so, just figured I'd ask. Thanks
    Summer_Moon likes this.
    02-18-19 05:06 PM
  11. jelp2's Avatar
    Just a quick note for anyone who did these steps to enable WiFi calling and wondering if it will go away after an update. I just ran the autoloader for ABP924 on my phone. The only things that I had to do to get it back was:

    1) commented out the modem line in the no wipe script (use notepad or something similar and put "REM" in front of the modem line, which is right under the commented out userdata line in the script)
    2) after I finished installing and rebooted I went back into *#*#46368676#*#* and toggled WiFi calling provisioned back on

    So a lot easier after you have already done all of the steps to be able to get it back after an update.

    I know all of you below did these steps so figured you would want this info
    @drkohut @jelp2 @JKames
    REM didnt work for me. Don't know how else I could have done it, so ran through the process again. It's much faster if all the needed QSM tabs are favorited. Anyway it's all good again.
    02-19-19 12:10 PM
  12. Summer_Moon's Avatar
    REM didnt work for me. Don't know how else I could have done it, so ran through the process again. It's much faster if all the needed QSM tabs are favorited. Anyway it's all good again.
    That works as well
    02-19-19 04:41 PM
  13. fop518's Avatar
    will this modem file work for a dual-sim -6 from the uk? I really need to get wfc working since my t-mobile coverage at work sucks
    04-16-19 11:50 PM
  14. fop518's Avatar
    jcrutchvt2010 pointed me to the right modem. going to try flashing tonight to the original modem... wish me luck!!!
    04-18-19 01:11 PM
  15. moosbb's Avatar
    jcrutchvt2010 pointed me to the right modem. going to try flashing tonight to the original modem... wish me luck!!!
    Good luck!
    04-18-19 02:48 PM
  16. fop518's Avatar
    Hurrah!! It worked. Flashing your modem to the original os release ABA044 plus using shortcut maker to flip the switches in arda and phone and settings. All detailed in this thread. Dialer code doesn't work for me unfortunately but isn't necessary! Wifi calling works on t-mobile USA with a dual Sim uk model. I had to find the proper modem file. The global one.

    No wifi calling indicator in the top indicator bar which I miss. Would love to know how to enable that!

    Update: have to toggle a wifi setting in quick shortcut maker after a reboot. Slightly annoying. Also can't get qsm to actually make a shortcut. Nothing happens when I hit create. Anyone else have that issue?
    Attached Thumbnails Wi-Fi calling working.-screenshot_20190417-205121.jpg  
    Last edited by fop518; 04-18-19 at 10:59 PM.
    04-18-19 10:42 PM
  17. fop518's Avatar
    any tips on getting the wifi calling indicator back?
    04-19-19 01:37 PM
  18. randa107's Avatar
    I don’t have any options in advanced calling what are the next steps?
    So here is everything that I did, I am not sure if all of it needs to be done or only some of it, or some combination of it.

    The #1 important piece here is that you need to check if the toggle for WiFi calling provisioned is available in the phone information. To do this open your dialer and use dial code *#*#46368676#*#* and click on Phone Information at the to. In the next screen towards the bottom should be several toggles, one of these will say Wi-Fi calling provisioned. If you are able to toggle this on or is already turned on you should be good to continue. If you are not able to, I doubt any of the rest of this will help.

    Next, while you are still in the Phone Information section click on the 3 dots in the upper right hand corner and click on IMS Service Status. Make sure this says Registered, if it doesn't, again I am not sure the rest of this will help.

    Next, open up QuickShortcutMaker aka QSM (can get it from the Play Store) and click on ARDA, then ARDA again and click Try. In here click on IMS. At the top make sure that IMS service daemon is toggled on. Then click on IMS General Settings. Check your IMS User Agent, I am curious what everyone's is set to so if you wouldn't mind copying out what's there and posting it, that would be great. Mine is set to "T-Mobile VoLTE-RCS-ePDG-IR94-RTT-ussd" (no quotes). Then click back.

    Still in the IMS main page, click on IMS Services. Verify that Wi-Fi Calling (WFC) is toggled on in both Provisioned Settings and the User Settings. It's also necessary to click back out of this page and go back in it. If the toggles stay and don't flip back, then you're good. If they do flip back to off, then this is probably going to be a no-go for you.

    Back onto the IMS main page click on VoWiFi. In here first make sure that the VoWiFi MDN field is set to your phone number including country and area code. Toggle VoWiFi Enabled to On and check that the VoWiFi Roaming Preference is set to WiFi Preferred. There's another setting in here that we'll come back to later and which ultimately ended up making this work for me.

    Back on the IMS main page click on IMS Developer Tools and click on Tap to reset modem now. You should see your cell signal drop and then reconnect (also every once in a while WiFi won't come back until you actually manually go to WiFi and reconnect it yourself).

    Now back out of ARDA back into QSM scroll down to Phone Services and open that, then find Wi-Fi Calling. Click on that and click Try. Should open up a page where Wi-Fi calling toggle is on and has a selection of Wi-Fi Preferred, Wi-Fi only or Cellular network preferred. I have mine set to Wi-Fi Preferred.

    Back into QSM scroll down to Settings, open that and find Wi-Fi calling (should be fairly close to the bottom of the Settings list, probably easier to search from the bottom up), there are 2 of them right next to each other, either of them will work. Tap on try for that and verify that the toggle here is OFF. Yes, you read that correctly, this toggle should be off.

    -(note on the below, if you do not have any options in Advanced Calling let me know, might be another step to get that to show up)-
    Back into QSM and scroll down a little to Advanced Calling, tap try for that and it should bring up an option that says something like Activate Wi-Fi Calling, or Tap here to activate. Tap on Wi-Fi calling and it will bring up an error saying not activated, try again later and a little notice at the bottom that says Wi-Fi calling activated. Ignore the error and tap on Wi-Fi calling again. Should take you to another screen where the toggle for Wi-Fi calling is on and have 2 options under it. Tap on the Update Current Emergency Address, you'll get another error saying it failed with a notice at the bottom saying successful. Ignore the error and exit back to QSM.

    Back in QSM scroll down to Calling PLUS, click on try and verify the toggle is On.

    Now enable Airplane mode, wait a few seconds, and disable Airplane mode. Wait for wifi to reconnect and try calling someone, should hopefully see wifi calling like in my first post show up on the call. If it doesn't give this next part a try.

    Back into QSM -> ARDA -> IMS -> VoWiFi and scroll down to the Emergency Address Management section, on the Use Empty Authentication Token put a check mark in the box. Exit out and give another try at calling, ultimately this check box is what finally got my phone to make wifi calls.

    Let me know if this works for anyone else or if there are questions. It may or may not work, but would be curious based on how it does for others what the right combination from above is to get it to work.
    04-21-19 03:27 PM
  19. randa107's Avatar
    I don’t have any options in advanced calling what are those steps?
    04-21-19 03:28 PM
  20. Summer_Moon's Avatar
    any tips on getting the wifi calling indicator back?
    Sorry, no. Only indicator is on the screen when you make the call. No way from the settings that are accessible to get that indicator back.

    Also, yes, I cannot get QSM to create a shortcut. Not sure why that is, but I also have not tried contacting the developer about that, so that would be the other option.

    And after a reboot this does go away, no way around it that I have found. But at least it's only a switch and not the whole thing. Slightly annoying, sure, but I'll take annoying to have the WiFi calling lol.
    04-21-19 04:13 PM
  21. fop518's Avatar
    Hey I had the same issue with qsm but figured the work around. You need to launch qsm via the shortcuts menu in the launcher... for some reason that's the one way to get it to create a new shortcut.

    If you look on Google play ppl say you need to launch it via its widget for it to work for oreo on but I couldn't find a widget, I did see it in the shortcut menu and that works!
    Summer_Moon likes this.
    04-21-19 04:22 PM
  22. Summer_Moon's Avatar
    Hey I had the same issue with qsm but figured the work around. You need to launch qsm via the shortcuts menu in the launcher... for some reason that's the one way to get it to create a new shortcut.

    If you look on Google play ppl say you need to launch it via its widget for it to work for oreo on but I couldn't find a widget, I did see it in the shortcut menu and that works!
    SWEET! Thanks @fop518 ! That works like a charm, found it in shortcuts as well. Save me 2 clicks! Lol
    04-21-19 04:26 PM
  23. danp2000's Avatar
    So I am having trouble finding the files needed to roll back my radio to the ABA044 radio.
    04-21-19 05:19 PM
  24. Summer_Moon's Avatar
    So I am having trouble finding the files needed to roll back my radio to the ABA044 radio.
    Should be this link here https://mega.nz/#!V5owHArY!yPCQCcmXR...GqiTmPtMxiUz-M
    04-21-19 06:26 PM
  25. fop518's Avatar
    make sure you use the right modem for your prd though. I had to use the global one since mine is a uk phone etc
    04-21-19 06:59 PM
103 1234 ...

Similar Threads

  1. Replies: 10
    Last Post: 04-24-19, 01:53 AM
  2. Your stickers wont work on BlackBerry Enterprise's BBMe.
    By yye74807 in forum General BlackBerry Discussion
    Replies: 17
    Last Post: 04-21-19, 04:49 PM
  3. speaker stopped working
    By mtalinm in forum BlackBerry KEY2
    Replies: 1
    Last Post: 04-20-19, 03:14 PM
  4. Replies: 4
    Last Post: 04-19-19, 10:07 PM
  5. Replies: 1
    Last Post: 04-18-19, 06:14 PM
LINK TO POST COPIED TO CLIPBOARD