Sign up now for Disney+
08-25-19 05:25 PM
101 123 ...
tools
  1. Summer_Moon's Avatar
    So I recently switched from Cricket (MVNO of AT&T) to Ultra Mobile (MVNO of T-Mobile, also owner of Mint Mobile). I have spent many days messing with settings, accidentally disabling VoLTE in the process, figuring out how to get it back, and then stumbling on wifi calling suddenly working.

    I am not exactly sure what got it to work as I have messed with too much of it to know for certain exactly what it was that made it work, I have a suspicion, but now that it's working, I'm afraid to touch any settings or to reboot my phone lol.

    For what it's worth Ultra Mobile has had better signal where I am at, does not throttle data, is cheaper by about $5/month compared to cricket for exact same plan, and allows VoLTE out of the box with all unlocked phones that support it. They also support a wide range of devices for VoWiFi including bring your own, although the BlackBerry Key2 is technically not supported.

    Here are some screenshots:
    Attached Thumbnails Wi-Fi calling working.-wificall1.jpg   Wi-Fi calling working.-wificall2.jpg   Wi-Fi calling working.-wificall3.jpg  
    02-11-19 11:26 AM
  2. coffee-turtle's Avatar
    Thanks for the post!
    I am on TMO and with a KeyOne and never had an issue using Wi-Fi calling. Hopefully, your post helps others.
    02-11-19 11:53 AM
  3. Summer_Moon's Avatar
    FYI, if anyone is interested in what all I did to get WiFi calling working just let me know. I would expect this to not only work for Ultra Mobile but also T-Mobile, Mint Mobile, or any other T-Mobile MVNO.

    In theory it should work for any carrier, assuming that your IMS is registered and that you have the toggle to turn on WiFi calling provisioning on the phone.

    One special note though, Ultra Mobile has a section in the account page where you can manually enable or disable WiFi calling for your plan yourself, which I assume does play a role in this working.
    02-11-19 07:29 PM
  4. Scut77's Avatar
    Hi Summer_Moon I am interested... how to proceed?
    02-11-19 07:56 PM
  5. mtalinm's Avatar
    same here
    02-11-19 08:45 PM
  6. jelp2's Avatar
    FYI, if anyone is interested in what all I did to get WiFi calling working just let me know. I would expect this to not only work for Ultra Mobile but also T-Mobile, Mint Mobile, or any other T-Mobile MVNO.

    In theory it should work for any carrier, assuming that your IMS is registered and that you have the toggle to turn on WiFi calling provisioning on the phone.

    One special note though, Ultra Mobile has a section in the account page where you can manually enable or disable WiFi calling for your plan yourself, which I assume does play a role in this working.
    I'm interested too but I've never seen a toggle anywhere on my tmobile account page.
    02-11-19 09:05 PM
  7. Summer_Moon's Avatar
    So here is everything that I did, I am not sure if all of it needs to be done or only some of it, or some combination of it.

    The #1 important piece here is that you need to check if the toggle for WiFi calling provisioned is available in the phone information. To do this open your dialer and use dial code *#*#46368676#*#* and click on Phone Information at the to. In the next screen towards the bottom should be several toggles, one of these will say Wi-Fi calling provisioned. If you are able to toggle this on or is already turned on you should be good to continue. If you are not able to, I doubt any of the rest of this will help.

    Next, while you are still in the Phone Information section click on the 3 dots in the upper right hand corner and click on IMS Service Status. Make sure this says Registered, if it doesn't, again I am not sure the rest of this will help.

    Next, open up QuickShortcutMaker aka QSM (can get it from the Play Store) and click on ARDA, then ARDA again and click Try. In here click on IMS. At the top make sure that IMS service daemon is toggled on. Then click on IMS General Settings. Check your IMS User Agent, I am curious what everyone's is set to so if you wouldn't mind copying out what's there and posting it, that would be great. Mine is set to "T-Mobile VoLTE-RCS-ePDG-IR94-RTT-ussd" (no quotes). Then click back.

    Still in the IMS main page, click on IMS Services. Verify that Wi-Fi Calling (WFC) is toggled on in both Provisioned Settings and the User Settings. It's also necessary to click back out of this page and go back in it. If the toggles stay and don't flip back, then you're good. If they do flip back to off, then this is probably going to be a no-go for you.

    Back onto the IMS main page click on VoWiFi. In here first make sure that the VoWiFi MDN field is set to your phone number including country and area code. Toggle VoWiFi Enabled to On and check that the VoWiFi Roaming Preference is set to WiFi Preferred. There's another setting in here that we'll come back to later and which ultimately ended up making this work for me.

    Back on the IMS main page click on IMS Developer Tools and click on Tap to reset modem now. You should see your cell signal drop and then reconnect (also every once in a while WiFi won't come back until you actually manually go to WiFi and reconnect it yourself).

    Now back out of ARDA back into QSM scroll down to Phone Services and open that, then find Wi-Fi Calling. Click on that and click Try. Should open up a page where Wi-Fi calling toggle is on and has a selection of Wi-Fi Preferred, Wi-Fi only or Cellular network preferred. I have mine set to Wi-Fi Preferred.

    Back into QSM scroll down to Settings, open that and find Wi-Fi calling (should be fairly close to the bottom of the Settings list, probably easier to search from the bottom up), there are 2 of them right next to each other, either of them will work. Tap on try for that and verify that the toggle here is OFF. Yes, you read that correctly, this toggle should be off.

    -(note on the below, if you do not have any options in Advanced Calling let me know, might be another step to get that to show up)-
    Back into QSM and scroll down a little to Advanced Calling, tap try for that and it should bring up an option that says something like Activate Wi-Fi Calling, or Tap here to activate. Tap on Wi-Fi calling and it will bring up an error saying not activated, try again later and a little notice at the bottom that says Wi-Fi calling activated. Ignore the error and tap on Wi-Fi calling again. Should take you to another screen where the toggle for Wi-Fi calling is on and have 2 options under it. Tap on the Update Current Emergency Address, you'll get another error saying it failed with a notice at the bottom saying successful. Ignore the error and exit back to QSM.

    Back in QSM scroll down to Calling PLUS, click on try and verify the toggle is On.

    Now enable Airplane mode, wait a few seconds, and disable Airplane mode. Wait for wifi to reconnect and try calling someone, should hopefully see wifi calling like in my first post show up on the call. If it doesn't give this next part a try.

    Back into QSM -> ARDA -> IMS -> VoWiFi and scroll down to the Emergency Address Management section, on the Use Empty Authentication Token put a check mark in the box. Exit out and give another try at calling, ultimately this check box is what finally got my phone to make wifi calls.

    Let me know if this works for anyone else or if there are questions. It may or may not work, but would be curious based on how it does for others what the right combination from above is to get it to work.
    02-12-19 08:01 AM
  8. JKames's Avatar
    followed all instructions but didn't work. too bad. do I have put my settings back to the way they were?
    02-12-19 09:04 AM
  9. Summer_Moon's Avatar
    followed all instructions but didn't work. too bad. do I have put my settings back to the way they were?
    Shouldn't hurt anything to keep them as is. I was hoping that the Empty Authentication Token would be the winner here so looks like my other 2 steps may also be necessary, although they are probably a tad bit harder to do.

    It involves using ADB to turn on a flag in the settings Global table and also using FastBoot to write the Modem from ABA044.

    If anyone is interested in these other 2 steps just let me know, was hoping that they were not necessary. But I can write those up and share the modem file if anyone is interested.
    02-12-19 09:45 AM
  10. jelp2's Avatar
    Shouldn't hurt anything to keep them as is. I was hoping that the Empty Authentication Token would be the winner here so looks like my other 2 steps may also be necessary, although they are probably a tad bit harder to do.

    It involves using ADB to turn on a flag in the settings Global table and also using FastBoot to write the Modem from ABA044.

    If anyone is interested in these other 2 steps just let me know, was hoping that they were not necessary. But I can write those up and share the modem file if anyone is interested.
    I would try it. If I remember correctly I couldn't get ADB to work for Key2. I can try again though
    Summer_Moon likes this.
    02-12-19 12:29 PM
  11. Summer_Moon's Avatar
    First you'll need to enable Developer Options on your phone, and in the options scroll down to Debugging section and make sure that USB debugging and USB debugging in charging mode is toggled on.

    Plug in your phone to your computer using USB (I've had flaky connection with some ports/cables, so might have to try the commands multiple times, or find the right combination for ports and cables for a stable connection). It should recognize the connection on the phone and make sure to select charge and data and then transfer files option on the phone when it's connected.

    Download the zip file from this link https://mega.nz/#!V5owHArY!yPCQCcmXR...GqiTmPtMxiUz-M and extract to a directory on your computer (doesn't really matter where as long as you know where to find it). Navigate to the folder where you extracted it to. Then hold your left shift key and right-click in the folder (empty space) and choose open cmd prompt here (might say powershell instead of cmd prompt depending on your Windows setup, either will work).

    Once at the shell (it should show that you are in the folder where you extracted the files) you will want to run the following commands (without the quotes):

    ".\bin\adb devices" this should show you what devices are attached to your computer, the first time you run it, it should start up the service. I always run it again after it starts the service to make sure the phone is listed as an attached device.

    ".\bin\adb shell settings put global wfc_ims_enabled1 1" this will write a 1 to the wfc_ims_enabled1 flag in the global settings. Also, might be useful to get the SetEdit app on your phone and check the Global table and scroll to wfc_ims_enabled1 and see what it's at prior to writing it, there's a few other wifi calling and ims settings in that table, but all of mine were on (1) already except for wfc_ims_enabled1

    The next portion is to write the ABA044 modem to your device. You'll have to disable any pin lock that you have on your phone in settings first. Then restart your phone into fastboot mode by holding power and volume down at the same time and keep holding it until it is in fastboot.

    Then in your cmd prompt (or powershell) use the following command to write the modem (without quotes):

    ".\bin\fastboot.exe flash modem .\NON-HLOS.bin" this writes the americas modem, so you may want to make sure that you have the right PRD for this. My PRD is PRD-63825-003, I believe ABA044 should work for any BBF100-2 device. And of course you can try on a different one, but I have no way to guarantee it will work or be able to get your original modem back other than to download your autoloader and load it back onto your phone.

    Then reboot your phone using the fastboot menu. Go back through the original set of steps and give wifi calling another try.

    And that should be the complete number of steps/settings that I did on my device.
    hxh145 likes this.
    02-12-19 04:15 PM
  12. jelp2's Avatar
    First you'll need to enable Developer Options on your phone, and in the options scroll down to Debugging section and make sure that USB debugging and USB debugging in charging mode is toggled on.

    Plug in your phone to your computer using USB (I've had flaky connection with some ports/cables, so might have to try the commands multiple times, or find the right combination for ports and cables for a stable connection). It should recognize the connection on the phone and make sure to select charge and data and then transfer files option on the phone when it's connected.

    Download the zip file from this link https://mega.nz/#!V5owHArY!yPCQCcmXR...GqiTmPtMxiUz-M and extract to a directory on your computer (doesn't really matter where as long as you know where to find it). Navigate to the folder where you extracted it to. Then hold your left shift key and right-click in the folder (empty space) and choose open cmd prompt here (might say powershell instead of cmd prompt depending on your Windows setup, either will work).

    Once at the shell (it should show that you are in the folder where you extracted the files) you will want to run the following commands (without the quotes):

    ".\bin\adb devices" this should show you what devices are attached to your computer, the first time you run it, it should start up the service. I always run it again after it starts the service to make sure the phone is listed as an attached device.

    ".\bin\adb shell settings put global wfc_ims_enabled1 1" this will write a 1 to the wfc_ims_enabled1 flag in the global settings. Also, might be useful to get the SetEdit app on your phone and check the Global table and scroll to wfc_ims_enabled1 and see what it's at prior to writing it, there's a few other wifi calling and ims settings in that table, but all of mine were on (1) already except for wfc_ims_enabled1

    The next portion is to write the ABA044 modem to your device. You'll have to disable any pin lock that you have on your phone in settings first. Then restart your phone into fastboot mode by holding power and volume down at the same time and keep holding it until it is in fastboot.

    Then in your cmd prompt (or powershell) use the following command to write the modem (without quotes):

    ".\bin\fastboot.exe flash modem .\NON-HLOS.bin" this writes the americas modem, so you may want to make sure that you have the right PRD for this. My PRD is PRD-63825-003, I believe ABA044 should work for any BBF100-2 device. And of course you can try on a different one, but I have no way to guarantee it will work or be able to get your original modem back other than to download your autoloader and load it back onto your phone.

    Then reboot your phone using the fastboot menu. Go back through the original set of steps and give wifi calling another try.

    And that should be the complete number of steps/settings that I did on my device.
    I'm on Tmobile and this works! Thanks for the write up, it should be stickied.
    Attached Thumbnails Wi-Fi calling working.-notable-00006.jpg  
    Last edited by jelp2; 02-12-19 at 06:44 PM. Reason: added pic
    Summer_Moon and hxh145 like this.
    02-12-19 06:27 PM
  13. Summer_Moon's Avatar
    I'm on Tmobile and this works! Thanks for the write up, it should be stickied.
    Awesome! Good to hear
    jelp2 and hxh145 like this.
    02-12-19 06:42 PM
  14. JKames's Avatar
    didnt work for me. I wonder what I did wrong. I followed cmd steps and installed bin file
    02-12-19 07:00 PM
  15. JKames's Avatar
    wow. it works. had to go back in and toggle wifi provisioning in the secret menu *#*# how did you figure this out Summer Moon. Are you a phone genius? You are definitely my phone hero
    Summer_Moon likes this.
    02-12-19 07:04 PM
  16. megafan2000's Avatar
    All you've done is effectively restore your phone to the exact state it was in when you took it out of the box. ABA044 is what was installed when I first turned my phone on. When I put my T-Mobile Sim in wi-fi calling was there, menu and all. The day 1 update gets installed (ABC432), Wi-Fi calling menu disappears and it's been that way ever since.
    02-12-19 07:44 PM
  17. JKames's Avatar
    so I lost all my updates since then or are they still installed except for the original wifi calling feature
    Summer_Moon likes this.
    02-12-19 07:46 PM
  18. JKames's Avatar
    I still show ABP242 and no new updates available. is Summer Moon still my hero? Yes
    Summer_Moon likes this.
    02-12-19 07:47 PM
  19. jelp2's Avatar
    It's just the modem that was replaced. All other updates are there.
    Summer_Moon likes this.
    02-12-19 08:00 PM
  20. Summer_Moon's Avatar
    All you've done is effectively restore your phone to the exact state it was in when you took it out of the box. ABA044 is what was installed when I first turned my phone on. When I put my T-Mobile Sim in wi-fi calling was there, menu and all. The day 1 update gets installed (ABC432), Wi-Fi calling menu disappears and it's been that way ever since.
    What jelp2 said, only the modem piece is rolled back to ABA044. All other updates like system are still in tact.
    02-12-19 08:17 PM
  21. Summer_Moon's Avatar
    so I lost all my updates since then or are they still installed except for the original wifi calling feature
    You didn't lose any updates, everything is still installed. Modem is only piece rolled back. Which only contains cellular and WiFi as far as I know.
    Last edited by Summer_Moon; 02-12-19 at 08:24 PM. Reason: Clarification
    02-12-19 08:18 PM
  22. Summer_Moon's Avatar
    wow. it works. had to go back in and toggle wifi provisioning in the secret menu *#*# how did you figure this out Summer Moon. Are you a phone genius? You are definitely my phone hero
    Lol, wish I was, but no I'm not. Took me spending 5 days with messing with all of the settings and breaking a lot of the stuff along the way to get it. About fell out of my chair when I saw the WiFi calling work that first time
    hamilgs and moosbb like this.
    02-12-19 08:20 PM
  23. drkohut's Avatar
    Lol, wish I was, but no I'm not. Took me spending 5 days with messing with all of the settings and breaking a lot of the stuff along the way to get it. About fell out of my chair when I saw the WiFi calling work that first time
    Summer_Moon, wow that is amazing! So i have no icon at top showing WFC is on but it just works in the background now as soon as wifi is on i guess?
    02-12-19 09:14 PM
  24. Summer_Moon's Avatar
    Summer_Moon, wow that is amazing! So i have no icon at top showing WFC is on but it just works in the background now as soon as wifi is on i guess?
    Right, tested earlier in town and verified VoLTE without WiFi connected. Connected to WiFi back home and back to WiFi calling
    02-12-19 09:35 PM
  25. jelp2's Avatar
    It's nice not having a constant notification that wifi calling is on.
    02-12-19 09:39 PM
101 123 ...

Similar Threads

  1. Replies: 10
    Last Post: 04-24-19, 01:53 AM
  2. Your stickers wont work on BlackBerry Enterprise's BBMe.
    By yye74807 in forum General BlackBerry Discussion
    Replies: 17
    Last Post: 04-21-19, 04:49 PM
  3. speaker stopped working
    By mtalinm in forum BlackBerry KEY2
    Replies: 1
    Last Post: 04-20-19, 03:14 PM
  4. Replies: 4
    Last Post: 04-19-19, 10:07 PM
  5. Replies: 1
    Last Post: 04-18-19, 06:14 PM
LINK TO POST COPIED TO CLIPBOARD