Built for Business - Learn more about BlackBerry KEY2
11-23-18 11:52 AM
77 1234
tools
  1. sachmalh's Avatar
    loaded on my key2 with bell Prd63825004 with no wipe and worked like a charm. Will play around and see if I can add to the discussion (new features etc)
    10-22-18 09:05 AM
  2. sachmalh's Avatar
    Memory management significantly improved. Went from 4 gb to 3gb
    10-22-18 09:07 AM
  3. miketedeschi's Avatar
    Well...not yet working but there are some new settings screens that indicate progress being made. I'm using the new digits app for the time being. It works for me as long as you just turn off cellular data (don't use airplane mode).
    I would have thought wifi calling on android would be a module independent of hardware. Or maybe it is, and the TCL cellular part isn't playing nice with it.

    either way, sounds like there's light at the end of the tunnel.
    Thanks.
    10-22-18 09:55 AM
  4. danp2000's Avatar
    GooglePay is working after updating to this version. Sometimes when using an autoloader it says the device is rooted.

    Nice!
    10-22-18 10:31 AM
  5. ray689's Avatar
    Ended up loading this (nowipe) on my Sasktel Key2. So far so good.
    10-22-18 10:40 AM
  6. ray689's Avatar
    Dual accounts (just like with the KEY2 LE) is also supported from this build.
    I see this. But no way to add to the list. Just has apps already listed. Does that mean BBM can't be a dual app for example?
    10-22-18 12:53 PM
  7. Renwick's Avatar
    I see this. But no way to add to the list. Just has apps already listed. Does that mean BBM can't be a dual app for example?
    From the KEY2 LE product page:

    Currently available for: Instagram®, Facebook Messenger®, Whatsapp® and WeChat®.
    10-22-18 01:15 PM
  8. ray689's Avatar
    From the KEY2 LE product page:

    Currently available for: Instagram®, Facebook Messenger®, Whatsapp® and WeChat®.
    Noted. Thank you.
    10-22-18 01:21 PM
  9. hoytbowhunter's Avatar
    Dual apps option is already built into the software on the KEY2 KEYᵒⁿᵉ and Motion, just needed to be turned on and this Autoloader does it.. Sweet job..
    10-22-18 01:38 PM
  10. Bla1ze's Avatar
    Noted. Thank you.
    WhatsApp and WeChat might not work though, those apps are reserved for dual-SIM devices as they require a unique number for each account.
    10-22-18 01:55 PM
  11. Bla1ze's Avatar
    My KEY2 hates this autoloader on my Mac. Dunno why... it borks so hard it loads up an entirely different boot screen and everything. Had to manually flash each individual file just to get it back to working order on the previous OS. So weird. PRD-63825-002.

    Universal Autoloader for Testing - ABI067-img_0074.jpg
    10-22-18 01:56 PM
  12. ray689's Avatar
    WhatsApp and WeChat might not work though, those apps are reserved for dual-SIM devices as they require a unique number for each account.
    I probably wouldn't have used either anyways. BBM maybe if it was available.
    10-22-18 01:58 PM
  13. ray689's Avatar
    My KEY2 hates this autoloader on my Mac. Dunno why... it borks so hard it loads up an entirely different boot screen and everything.

    Click image for larger version. 

Name:	IMG_0074.jpg 
Views:	28 
Size:	110.8 KB 
ID:	440915
    No windows device around to give it a shot?
    10-22-18 01:58 PM
  14. Bla1ze's Avatar
    No windows device around to give it a shot?
    On OSX - Autoloader runs and borks.Something about bootchain errors.
    On Windows 10 - Autloader won't run, says not valid for variant.
    10-22-18 02:00 PM
  15. ray689's Avatar
    On OSX - Autoloader runs and borks.Something about bootchain errors.
    On Windows 10 - Autloader won't run, says not valid for variant.
    Funny, I had that on windows 10 on one device and ran fine on another. Both were surface pro 3 devices. So no idea what the issues would be.
    10-22-18 02:21 PM
  16. Bla1ze's Avatar
    Funny, I had that on windows 10 on one device and ran fine on another. Both were surface pro 3 devices. So no idea what the issues would be.
    Yeah, I dunno. I tried everything to fix it myself, 3 different computers, updating platform tools, etc.. but whatever. Not saying any of this to discourage others, just saying for me it was a no go.
    10-22-18 02:23 PM
  17. bobmoley's Avatar
    Yeah, I dunno. I tried everything to fix it myself, 3 different computers, updating platform tools, etc.. but whatever. Not saying any of this to discourage others, just saying for me it was a no go.
    Powershell does not work for me on windows, but cmd works like a charm every time. If you're using Powershell, try cmd
    10-22-18 02:34 PM
  18. Bla1ze's Avatar
    Powershell does not work for me on windows, but cmd works like a charm every time. If you're using Powershell, try cmd
    I don't even know what Power Shell is . I only use Windows like once every 6 mnths.
    10-22-18 02:37 PM
  19. Vistaus's Avatar
    Funny, I had that on windows 10 on one device and ran fine on another. Both were surface pro 3 devices. So no idea what the issues would be.
    Could have something to do with the USB ports. On some Surface Pro 3 variants, the USB ports are in a low-power mode, which causes issues with recognizing certain USB hardware, which is why some software says "not supported" or "not valid for ..." .
    10-22-18 03:20 PM
  20. Vistaus's Avatar
    Btw, anyone here with a KEY2 from Western Europe? If so, does this build work fine for you?
    10-22-18 03:21 PM
  21. jcrutchvt2010's Avatar
    Yeah, I dunno. I tried everything to fix it myself, 3 different computers, updating platform tools, etc.. but whatever. Not saying any of this to discourage others, just saying for me it was a no go.
    Probably an issue with my shell script idk. I'm posting the remaining builds that haven't been posted yet now so maybe you'll have better luck? In the mean time, i'll see if i have something screwy in the shell. But if it didn't run on windows, not sure what the problem is...
    10-22-18 03:52 PM
  22. Bla1ze's Avatar
    Probably an issue with my shell script idk. I'm posting the remaining builds that haven't been posted yet now so maybe you'll have better luck? In the mean time, i'll see if i have something screwy in the shell. But if it didn't run on windows, not sure what the problem is...
    Don't waste any time on it on my account. If it's working for others, awesome! Just to further address it though, it's the first half of the script that seems funky.

    $BIN/$FASTBOOT flash tz_${slot} $IMG/tz.mbn
    $BIN/$FASTBOOT flash devcfg_${slot} $IMG/devcfg.mbn
    $BIN/$FASTBOOT flash rpm_${slot} $IMG/rpm.mbn
    $BIN/$FASTBOOT flash hyp_${slot} $IMG/hyp.signed.mbn
    $BIN/$FASTBOOT flash pmic_${slot} $IMG/pmic.elf
    $BIN/$FASTBOOT flash xbl_${slot} $IMG/xbl.elf
    $BIN/$FASTBOOT flash abl_${slot} $IMG/abl.elf
    $BIN/$FASTBOOT flash cmnlib_${slot} $IMG/cmnlib.signed.mbn
    $BIN/$FASTBOOT flash cmnlib64_${slot} $IMG/cmnlib64.signed.mbn
    $BIN/$FASTBOOT flash keymaster_${slot} $IMG/keymaster64.signed.mbn
    $BIN/$FASTBOOT flash mdtpsecapp_${slot} $IMG/mdtpsecapp.signed.mbn
    $BIN/$FASTBOOT oem switch-bootchain:${slot}
    ^^ That all fails.

    And...

    $BIN/$FASTBOOT flash modem $IMG/NON-HLOS.bin
    ^^ That part fails. But if I flashboot flash modem the file manually, it accepts it.
    10-22-18 03:58 PM
  23. conite's Avatar
    Deleted
    Last edited by conite; 10-22-18 at 04:26 PM.
    10-22-18 04:01 PM
  24. jcrutchvt2010's Avatar
    Ah that will do it. The multiple bootchain thing is a pain all around. It flashes those first ones to the first part of the bootchain and then reboots and switches for the rest. Maybe I need to rework for the shell script. Don't mind taking a look. It could also be I need to use a later version of the factory loader when building the user one. Strange though since we have the same PRD...
    10-22-18 04:03 PM
  25. Renwick's Avatar
    My KEY2 hates this autoloader on my Mac. Dunno why... it borks so hard it loads up an entirely different boot screen and everything. Had to manually flash each individual file just to get it back to working order on the previous OS. So weird. PRD-63825-002.
    According to conite's sheet, this build is available for this particular PRD via OTA, isn't it?
    10-22-18 04:06 PM
77 1234

Similar Threads

  1. A Potential Fix for SMS on Verizon With a BBE100-5
    By thurask in forum BlackBerry KEY2 LE
    Replies: 70
    Last Post: 01-02-19, 10:15 PM
  2. Task Manager app for BlackBerry 9780
    By Vigneshd332 in forum Ask a Question
    Replies: 1
    Last Post: 10-20-18, 02:48 AM
  3. Autoloader Aurora BBC100-1 Build AAN772
    By Oke Banget in forum BlackBerry Aurora
    Replies: 1
    Last Post: 10-19-18, 08:32 PM
LINK TO POST COPIED TO CLIPBOARD